locked
Cloud backup to Azure Blob from QNAP slow, fails RRS feed

  • Question

  • Hello,

    We have a QNAP TVS-871T NAS with 21 TB used for video storage, and are using cloud storage both on Amazon S3 and Azure Blob.

    I can get 19 TB up to S3 in a month over our ISP connection, but if I try to upload the main Video folder to Blob it gets a few hundred GB in and fails, often with a "too many files cannot be processed" error.

    QNAP has a built in app for Azure which we utilize. We had to drop the block size down to 1 MB and set concurrent file processing to 1. With this setting I have had 1 of the sub folders backing up for three weeks so far without issue, but is sub-optimal as we need to get the initial 19 TB up quickly and then just add the new files as they hit our NAS.  

    On the Blob side our performance/access tier is "standard/cool" going to North Central US, South Central US locations for the backup.

    QNAP tech tells me its a Azure issue, and I have a call with an Azure tech today to discuss.

    Is anyone using a similar setup that can add their experience?

    Our network at the NAS site is good, I believe its a 300MB pipe which we bandwidth limit during 1st shift so as not to impact users there.

    We may test using a computer onsite to send, using Microsoft Azure Storage Explorer, uploads through that app rather than the QNAP, but thats not optimal either.

    We also want to stay away from scripting as much as possible to not add overhead to managing more services.

    Any thoughts would be appreciated.

    Tuesday, August 29, 2017 2:02 PM

All replies

  • As you informed that “I have a call with an Azure tech today to discuss”, have you created any technical support ticket? 

    Can you share the snap shot of the error message?

    ------------------------------------------------------------------------------------------

    Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.


    Tuesday, August 29, 2017 5:27 PM