none
hi i m getting "failed to install assembly:- microsoft.visualbasic.vsa.dll because of system error:-0x80131107" RRS feed

  • Question

  • pls help me rectifying this error n pls guide me to rectify it

    hi i m getting "failed to install assembly:- microsoft.visualbasic.vsa.dll because of system error:-0x80131107" during the installtion of microsoft .net framework 2.0
    Sunday, November 4, 2007 6:36 AM

Answers

All replies

  • Hi,

    Please first try the workaround in this article: Assembly load failure installing the 2.0 Framework which described an issue similar to yours.

    You can also try to use the following steps to get the machine back into a known state and then install things back one by one:

    1. Download the .NET Framework cleanup tool and choose to cleanup the version of the .NET Framework that is causing problems on your system
    2. Download and install the version of the .NET Framework that you cleaned up in step 1 (such as the .NET Framework 1.0, .NET Framework 1.1 or .NET Framework 2.0)
    3. (optional) Download and run the .NET Framework verification tool to double-check that all .NET Framework files are correctly installed
    4. Download and install the desired .NET Framework service pack (such as .NET Framework 1.0 SP3 or .NET Framework 1.1 SP1) by running the setup package directly instead of using Windows Update.  Running it directly will allow the service pack setup to display error dialogs instead of having Windows Update suppress them

    Running these steps should ideally put your machine back into a known good state with the .NET Framework plus a service pack installed. For more details, please visit What to do if other .NET Framework setup troubleshooting steps do not help.

    Hope this helps!

    Thanks!

    Tuesday, November 6, 2007 1:25 AM
  • this has fixed my problem thank you. like clock work

     

     

    Tuesday, January 8, 2008 7:19 PM
  • Mr Chen,

    Can I use this tool with a XP MEDIA EDITION OS?

    I am seeing Like VisualBasic.vsa.dll in the C:/windows/Assembly/gac/  directory these have older dates
    than the Visualbasic.Vsa.dll I am trying to install will deleting the later dated files solve my problem or
    Can I use the cleanup tool on a Media edition computer?

    Thanks

    Hugo
    Wednesday, February 24, 2010 6:37 AM
  • I've been trying to install Framework 2.0 for the past 7 months (and spent several hours on it again today).   Today I finally got it to where it was giving the error message mentioned by romi24879 about visualbasic.vsa.dll....

    I ran across this link (http://social.msdn.microsoft.com/Forums/en-US/vssetup/thread/8655d21b-259b-449d-a0f4-0b94cdc353a1) which mentioned deleting the
    "C:\WINDOWS\Microsoft.NET\Framework
    \v2.050727    directory.

    Guess what?  I did that and it instantly worked like a charm!!  Try it for yourself.  

    IMPORTANT:  Actually, I renamed the v.2.050727 directory to "v.2.050727XXXX" so just in case the fix didn't work I could go back and rename it to it's original name without having messed anything up.  I suggest doing that rather than actually deleting the directory out right.

    Btw, if it makes any difference, I was installing the 32 bit dotnetfx.exe on my XP.

    Cheers and the best of luck with your issues!


    Saturday, April 24, 2010 8:23 PM