none
I can't find security header. How to use access credential? RRS feed

  • Question

  • hi, I'm not good English skills.
    <?xml version='1.0' encoding='UTF-8'?>
    <WL5G3N0:definitions targetNamespace="http://openapi.com/sdp" xmlns="" xmlns:WL5G3N0="http://schemas.xmlsoap.org/wsdl/" xmlns:WL5G3N1="http://docs.oasis-
    open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd" xmlns:WL5G3N2="http://openapi/sdp" xmlns:WL5G3N3="http://schemas.xmlsoap.org/wsdl/soap/"
    xmlns:wsp="http://schemas.xmlsoap.org/ws/2004/09/policy">
      <WL5G3N0:import location="http://testapi.com:80/testApi/TestApiManager?WSDL/TestApiManager_common.wsdl" namespace="http://openapi.com/sdp"/>
      <wsp:UsingPolicy WL5G3N0:Required="true"/>
      <wsp:Policy WL5G3N1:Id="Auth.xml">
        <wssp:Identity xmlns:wssp="http://www.bea.com/wls90/security/policy">
          <wssp:SupportedTokens>
            <wssp:SecurityToken TokenType="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-username-token-profile-1.0#UsernameToken">
              <wssp:UsePassword Type="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-username-token-profile-1.0#PasswordText"/>
            </wssp:SecurityToken>
            <wssp:SecurityToken TokenType="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-x509-token-profile-1.0#X509v3"/>
          </wssp:SupportedTokens>
        </wssp:Identity>
      </wsp:Policy>
    =================operation part=====================
      <WL5G3N0:service name="testApiManagerService">
        <WL5G3N0:port binding="WL5G3N2:testApiManagerSoapBinding" name="testApiManager">
          <WL5G3N3:address location="http://testapi.com:80/testApi/TestApiManager"/>
        </WL5G3N0:port>
      </WL5G3N0:service>
    </WL5G3N0:definitions>
    I want to call a operation from wsdl.
    But I can't find usertoken(wsdl to .cs,  wsdl webservice).
    However, when the error was compiled.
    error : 
    Unhandled Exception : System.Web.Service.Protocol.SoapHaederException : No Securoty haeder in massage but required by policy.

    I also tried .dll reference, web service reference, credentialcatch and etc....
    -create .cs option**a)wsdl.exe /l:cs uri
    -create .cs option**b)wsdl.exe /l:cs /d:domain /u:username /p:password
    -create .cs option**c)wsdl.exe /l:cs /pd:.. /pu:.. /pp:..
    However, the same error has occurred.

    Find the wsdl and the existing wsdl the difference 
    http://docs.oasis-
    open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd
    and 
    http://docs.oasis-
    open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd  
    Authentication is successful, the call should be.
    I need help, Thanks.
    (http://openapi.com/sdp, http://schemas.xmlsoap.org/wsdl/, http://testapi.com:80/testApi/TestApiManager?WSDL/TestApiManager_common.wsdl is fiction)
    • Moved by Bob Shen Thursday, May 30, 2013 7:08 AM
    Wednesday, May 29, 2013 5:08 AM

Answers

All replies