locked
Change Forms authentication to ADFS/Claims based RRS feed

  • Question

  • User1793652459 posted

    I have converted an older website designed in VS2005 into a VS2015 website. It used to have FBA and now it needs to have the ADFS authentication. I have all the correct namespaces and references, code added but when the application loads locally after showing me the ADFS login page, it doesn't redirect me to the proper aspx page but instead gives this error:

    This site can’t be reached

    https://localhost:44039/

    The connection was reset.
    Try:
    Checking the connection
    Checking the proxy and the firewall
    Running Windows Network Diagnostics
    ERR_CONNECTION_RESET
    HIDE DETAILS
    Check your Internet connection
    Check any cables and reboot any routers, modems, or other network devices you may be using.
    Allow Chrome to access the network in your firewall or antivirus settings.
    If it is already listed as a program allowed to access the network, try removing it from the list and adding it again.
    If you use a proxy server…
    Check your proxy settings or contact your network administrator to make sure the proxy server is working. If you don't believe you should be using a proxy server: Go to the Chrome menu > Settings > Show advanced settings… > Change proxy settings… > LAN Settings and deselect "Use a proxy server for your LAN".

    In the older asp.net website design using Forms authentication, after login.aspx it went to the default.aspx. Not sure why it can't find the default.aspx, it's set as the startup page in the Website. Is there any other place where I could specifiy for it to redirect a user to the correct aspx page after a login in the Home Realm Discovery Page? Or is it due to some other error. I have tried changing the port numbers but it didn't help either. 


    Thanks

    Wednesday, February 1, 2017 9:22 PM

All replies

  • User-2057865890 posted

    Hi Johnzee,

    This site can’t be reached

    https://localhost:44039/

    The connection was reset.

    SSL enabled? At least one Web site in IIS must be configured with SSL so that federated users can access Web-based applications that are hosted on the AD FS-enabled Web server. Take a look at this thread

    reference: https://technet.microsoft.com/en-us/library/cc771145(v=ws.11).aspx

    Best Regards,

    Chris

    Friday, February 3, 2017 2:36 AM
  • User1793652459 posted

    Note my website is not installed on an IIS server yet, I am trying to run it locally.  How would I create the certificate locally?   Also I already have another local site with https working fine that I created from scratch in VS2013 and I didn't have to do anything special with the certificate on my machine.  The main difference with this second app is that it was a older asp.net website designed in VS2005 and I opened it in VS2015 to convert it as a Web application. 

    Friday, February 3, 2017 1:12 PM
  • User-2057865890 posted

    Hi Johnzee,

    Note my website is not installed on an IIS server yet, I am trying to run it locally.

    Make sure that the project is set to run as HTTPS:

    reference: https://www.codeproject.com/Tips/766918/Visual-Studio-Use-HTTPS-SSL-On-Web-Application-Pro

    Best Regards,

    Chris

    Wednesday, February 8, 2017 2:03 AM