locked
Help with touchpad on my ASUS laptop

    Question

  • Hello. I'm actually enjoying this Windows 8 build so far.. a lot! It's great. Love the Metro UI. I do have one big problem that is driving me nuts, however. I can't access my laptop's touchpad settings. I *need* to disable clicking on the touchpad itself. I'm always accidentally highlighting text, opening things, etc. Can't stand it!!

    In my device manager, it doesn't show a touchpad at all. Just a typical mouse. I went to the Asus website, downloaded their drivers for my correct model of laptop, and the drivers would not install (with the message "no touchpad found"). I've done a ton of searches through the metro ui for touchpad settings, mouse settings, etc. I get nothing on touchpad, at all. And there's no option in mouse settings to change the touchpad settings, obviously.

     

    Anyone have any ideas of what to do? It's hampering my enjoyment of this new splendid OS quite a bit. :(


    Thursday, September 15, 2011 9:30 PM

All replies

  • Hello. I'm actually enjoying this Windows 8 build so far.. a lot! It's great. Love the Metro UI. I do have one big problem that is driving me nuts, however. I can't access my laptop's touchpad settings. I *need* to disable clicking on the touchpad itself. I'm always accidentally highlighting text, opening things, etc. Can't stand it!!

    In my device manager, it doesn't show a touchpad at all. Just a typical mouse. I went to the Asus website, downloaded their drivers for my correct model of laptop, and the drivers would not install (with the message "no touchpad found"). I've done a ton of searches through the metro ui for touchpad settings, mouse settings, etc. I get nothing on touchpad, at all. And there's no option in mouse settings to change the touchpad settings, obviously.

     

    Anyone have any ideas of what to do? It's hampering my enjoyment of this new splendid OS quite a bit. :(


    This is kind of a longshot, but try looking up drivers according to your system's serial number rather than by the model number to ensure that you download the right drivers.  My Asus U81's touchpad drivers (and hotkey/OSD drivers) installed without complications, and my multi-touch works correctly in non-Metro apps.  (In some Metro apps two-finger scroll does nothing, and in others it scrolls everything.)
    Thursday, September 15, 2011 9:54 PM
  • Thanks for your help. Initially... I thought I had some success! But alas... it is not meant to be. :P

     

    When I redownloaded the driver, I noticed in the Device Manager that the mouse was gone, and replaced by Finger Sensing Pad! Yay!

    I get to the settings, change all the stuff I was bitching about up above, and.....................didn't do anything. Restart. Still nothing. All the changes are saved and applied, but the touchpad click is still active, and I'm not able to use multigesture. Ugh. :(

    Friday, September 16, 2011 12:16 AM
  • Also would like to add that none of the Metro Apps will open. Store, weather, stocks, etc. :(
    Friday, September 16, 2011 12:22 AM
  • On Fri, 16 Sep 2011 00:22:11 +0000, Biglesworth23 wrote:

    Also would like to add that none of the Metro Apps will open. Store, weather, stocks, etc. :(

    For one thing the Store isn't available in the DP build. What display
    resolution are you running at? You need to be at a minimum of 1024x768 for
    the Metro apps to work.


    Paul Adare
    MVP - Identity Lifecycle Manager
    http://www.identit.ca
    Any sufficiently advanced bug is indistinguishable from a feature.  --
    Kulawiec

    Friday, September 16, 2011 7:48 AM
  • Since the manufacturers have not created drivers for Windows Developers Preview, I suggest you update to the most current Windows 7 driver.
    If that doesn't work, they try to install in compatibility mode.


    For the driver/drivers you downloaded use the compatibility troubleshooter to install them to see if that resolves the problem.
    You can do this by:

    ·         Enter the Start screen

    ·         Move your mouse to the bottom left of the screen to expand the Charms section

    ·         Select Search

    ·         Type Compatibility

    ·         Click Settings in the right column

    ·         Click Run programs made for previous versions of Windows

    ·         Then follow the prompts and direct the troubleshooter to the installer for your computer's driver.


    Let us know if Installing the drivers in compatibility mode helps.

    Marilyn
    Friday, September 23, 2011 12:50 AM
    Moderator