locked
InvalidServerResponse when requesting ad [C++][WP8.1] RRS feed

  • Question

  • Hello, I'm trying to create an InterstitialAd in C++ but when I request an ad using a real id it fails.  The test ids work fine.  I've created a video interstitial targeting mobile. The ErrorOcurred exception is thrown with the following parameters.

    ErrorMessage: InvalidXml

    ErrorCode: InvalidServerResponse(5)

    This also appears in the output window

    Microsoft::Advertising::Documents::XMLLiteException at memory location 0x09B6F460

    Can anyone offer any guidance as to how I can diagnose this further?

    Thanks


    • Edited by Ten Ton Cat Sunday, January 24, 2016 5:22 PM
    Sunday, January 24, 2016 5:20 PM

Answers

  • Actually the most common problem is the AD sdk is BROKEN.

    Right now no one appears to be getting Interstitials to display - including on previously live apps with zero code changes as per referenced thread above.

    Our experiance (when interstitial ads actually worked) is

    Interstitials will be displayed with test ids.

    Interstitials will not be displayed with real/live ids until after MS have published your app for the first time.


    • Edited by bbjbbj Monday, February 8, 2016 9:29 AM
    • Marked as answer by Ten Ton Cat Thursday, February 18, 2016 10:57 AM
    Monday, February 8, 2016 9:22 AM

All replies

  • I see that error when the ad sizes won't fit well in the space provided, but that doesn't really apply to Interstitials.

    How long after creating the ad in DevCenter did you try to show it? It takes a while for ads to start working after you create them.

    Tuesday, January 26, 2016 3:36 PM
  • Been trying for a few days, getting a different error now

    (1)NoAdAvailable

    Invalid media src

    Do interstitials work for you?

    Wednesday, January 27, 2016 2:58 PM
  • Recently I started getting a NetworkFailure error using Win10, which could be causing the same thing as you are seeing. I have a thread on it:

    https://social.msdn.microsoft.com/Forums/en-US/47bcf8eb-503c-4019-a00c-3a95bc66a230/getting-networkconnectionfailure-error-after-updating-universal-ad-sdk?forum=aiamgr#62d09d06-ba79-476f-bcae-7f018a07af5a

    Wednesday, January 27, 2016 3:27 PM
  • Most common cause is if you use an AdUnit that was provisioned for banners in the InterstitialAd API.
    • Proposed as answer by AdMediator Friday, February 5, 2016 9:48 PM
    Friday, February 5, 2016 9:48 PM
  • Actually the most common problem is the AD sdk is BROKEN.

    Right now no one appears to be getting Interstitials to display - including on previously live apps with zero code changes as per referenced thread above.

    Our experiance (when interstitial ads actually worked) is

    Interstitials will be displayed with test ids.

    Interstitials will not be displayed with real/live ids until after MS have published your app for the first time.


    • Edited by bbjbbj Monday, February 8, 2016 9:29 AM
    • Marked as answer by Ten Ton Cat Thursday, February 18, 2016 10:57 AM
    Monday, February 8, 2016 9:22 AM