none
Registry key ReadingModePrintedPage Word 2013 RRS feed

  • Question

  • Hello,

    I'm using Interop to generate Word documents based on a template. Since Word 2013 a problem occurs. On some computers the template can not be edited because the registery key ReadingModePrintedPage (inside HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Word\Options) is set. As soon the key is deleted, everything works. Where can I find the option corresponding to this key and what does it do exactly?

    Thanks,

    Sven

    Wednesday, June 25, 2014 11:17 AM

Answers

  • Hi Sven

    The better place to find out about Registry settings is the TechNet forum, since they deal with Group Policies and such. But I think I know which this one is... See if the information in this blog article is relevant to what you're seeing:

    http://blogs.msmvps.com/wordmeister/2013/02/22/word2013bug-not-available-for-reading/

    If it is this, then the relevant setting can be found in File/Options/Trust Center/Trust Center Settings/Protected View. But as a developer you shouldn't be changing this setting. It would be best if your template where installed in a Trusted Location and/or digitally signed.

    Even better, if you were to update your code to not work with the Interop, at all, and instead generate the documents by leveraging the Word Open XML.


    Cindy Meister, VSTO/Word MVP, my blog

    Wednesday, June 25, 2014 2:47 PM
    Moderator