locked
HTML5 master page throwing javascript error RRS feed

  • Question

  • I created a masterpage with html 5 and css3. I haave been able to elimate almost all of the javascript errors except 1.  Creating a list column with throw the following error. SCRIPT5007: Unable to set property 'action' of undefined or null reference.  File: fldNew.aspx, Line: 1083, Column: 4.  Does anyone have a fix for this one?
    Thursday, February 27, 2014 2:20 AM

Answers

  • Hi,

    According to your post, a JavaScript error occurred when you used HTML5 master page in SharePoint 2013.

    We can use the IE F12 Developer Tools to Debug the JavaScript Error.
    http://msdn.microsoft.com/en-us/library/ie/gg699336(v=vs.85).aspx

    I suggest you to provide your html5 master page code for further research.

    Thanks,
    Dennis Guo
    TechNet Community Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Dennis Guo
    TechNet Community Support

    • Marked as answer by Patrick_Liang Friday, March 7, 2014 12:40 PM
    Tuesday, March 4, 2014 2:22 PM

All replies

  • Hi,

    According to your post, a JavaScript error occurred when you used HTML5 master page in SharePoint 2013.

    We can use the IE F12 Developer Tools to Debug the JavaScript Error.
    http://msdn.microsoft.com/en-us/library/ie/gg699336(v=vs.85).aspx

    I suggest you to provide your html5 master page code for further research.

    Thanks,
    Dennis Guo
    TechNet Community Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Dennis Guo
    TechNet Community Support

    • Marked as answer by Patrick_Liang Friday, March 7, 2014 12:40 PM
    Tuesday, March 4, 2014 2:22 PM
  • I think you are missing some content placeholders in your masterpage. I ran into the same problem and googling brought me here hoping to find the answer which one.

    When i know which one it is i will post it in here.

    Friday, March 7, 2014 2:44 PM
  • Hi, 

    I solved my problem. (in  SP2013 ) It is the PlaceHolderUtilityContent contentplaceholder.

    Make sure it is not invisible and it is not rendered inside your default form. 

    This contentplaceholder renders an extra form tag below the default form. As you can't nest forms
    this is where the javascript breaks (by not finding the right form tag to submit)

    This problem is not only related to creating site columns but also breaks the recycle bin. Try it ;)

    Good luck!

    Friday, March 7, 2014 3:08 PM