none
“Open Selection in Microsoft Excel" broken: TF80012 error, with VS 2010 Pro and Office 2010 RRS feed

  • Question

  • Issue:

    1.      When I open an Excel spreadsheet I no longer see the Team tab.

    2.      I can no longer use the “Open in Microsoft Office” feature in TFS to open a TFS query in Excel, and get this error when I attempt to do so:

    TF80012:  The document cannot be opened because there is a problem with the installation of the Microsoft Visual Studio v10.0 Team Foundation Office integration components. Please see the Team Foundation Installation Guide for more information.

    Details:

    This broke suddenly, in the middle of an operation. It was working for an hour and suddenly it just stopped working. I didn’t update, install or repair any application and my computer had not been patched in a couple of days. (I did get a lot of patches/updates a week earlier but my computer had been restarted several times since). No changes were made to our Team Foundation Server. This same issue affected a co-worker the next day and neither of us has found a workaround.

    I’m running VS 2010 Pro, Visual Studio Team Explorer 2010, Office 2010 Professional.

    Attempted Fixes:

    I’ve tried to Repair Office, Repair Visual Studio, Repair VS Team Explorer. I’ve also uninstalled and reinstalled all of these programs too.


    Karin Meier
    Tuesday, March 8, 2011 5:22 PM

Answers

  • John Qiao from Microsoft provided me with a solution to this issue. Thank you, John!

    His first recommendation was to switch to 32-bit Office if I was running the 64-bit version, which I was not.

    His second recommendation worked for me: re-register the Office add-in using the Regsvr32 command:

    For 64-bit windows, open a command window as an Administrator and use this command:

    Regsvr32 "C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\PrivateAssemblies\TFSOfficeAdd-in.dll"

     

    For 32-bit windows, open a command window as an Administrator and use this command:

    Regsvr32 "C:\Program Files\Microsoft Visual Studio 10.0\Common7\IDE\PrivateAssemblies\TFSOfficeAdd-in.dll"

     

    --Karin


    Karin Meier
    • Marked as answer by Karin Meier Wednesday, March 9, 2011 6:48 PM
    Wednesday, March 9, 2011 6:47 PM

All replies

  • John Qiao from Microsoft provided me with a solution to this issue. Thank you, John!

    His first recommendation was to switch to 32-bit Office if I was running the 64-bit version, which I was not.

    His second recommendation worked for me: re-register the Office add-in using the Regsvr32 command:

    For 64-bit windows, open a command window as an Administrator and use this command:

    Regsvr32 "C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\PrivateAssemblies\TFSOfficeAdd-in.dll"

     

    For 32-bit windows, open a command window as an Administrator and use this command:

    Regsvr32 "C:\Program Files\Microsoft Visual Studio 10.0\Common7\IDE\PrivateAssemblies\TFSOfficeAdd-in.dll"

     

    --Karin


    Karin Meier
    • Marked as answer by Karin Meier Wednesday, March 9, 2011 6:48 PM
    Wednesday, March 9, 2011 6:47 PM
  • Thanks for the post. Regsvr did it from me as well.
    Wednesday, September 7, 2011 2:46 AM
  • Thanks, that worked for me too.  But I had to make sure to run as administrator otherwise I got error 0x80070005 (Access is Denied).  After that it fixed the office integration, which broke when installing Visual Studio 2010 SP1.
    Friday, September 23, 2011 2:03 PM
  • good for me too. and your remark about error helped in saving time. thanks!
    Friday, October 14, 2011 5:14 PM
  • This issue reoccurred for me yesterday, and the same fix worked. I’m not sure what causes the add-in to become unregistered.

     

    --Karin


    Karin Meier
    Friday, October 14, 2011 5:28 PM
  • Hey there,

    I've got the same error with VS2012 Ultimate now. The problem is that the TFSOfficeAdd-in.dll does not exist for VS2012.

    Any ideas????

    Thanks,

    Julian

    Thursday, November 1, 2012 5:21 PM
  • This great post worked for fixing it in VS 2012 for me.  I got to Step 4 before it worked, but it did the trick :)

    - Dan - "Can't never could do anything"

    Monday, February 25, 2013 11:30 PM
  • I had the same error for VS 2012 and instead of following the other trick - i actually registered the same TFSOfficeAdd-in.dll that is used by VS 2012.

    Here is the regsvr32 command:

    regsvr32 "C:\Program Files\Common Files\Microsoft Shared\Team Foundation Server\11.0\x86\TFSOfficeAdd-in.dll"

    Hope it helps.

    -Jigesh

    Thursday, August 8, 2013 6:15 PM
  • And for Visual Studio 2013 it is:

    Regsvr32 "C:\Program Files\Common Files\microsoft shared\Team Foundation Server\12.0\x86\TFSOfficeAdd-in.dll"

    Friday, July 4, 2014 4:28 AM
  • I ran across this problem today as well in Visual Studio 2013. As far as I can tell the "TFS Add for Office" was disabled by Group Policy. I corrected it with the following steps:

    1. Boot Office application (Excel)
    2. Click on the 'File' (far left top tab)
    3. Choose 'Options' bottom of left hand menu
    4. Select Add-ins
    5. At the bottom of that dialog is a list box, drop it, and select 'Com Add-ins' and press Go.
    6. Check Team Foundation Add-in and press OK.

    Result: Started working.  If you are still having problems try the Regsvr32 entries up above.   You might have to run as admin. for those to work.  If you do, create a shortcut using that URL.   Right click on the resulting Shortcut and run as Administrator.

    Kevin Van Flandern


    • Edited by YOUTIGANOW Monday, March 30, 2015 8:20 PM
    Monday, March 30, 2015 8:20 PM