Does office 365 exchange server supports Foreign Connector? RRS feed

  • Question

  • Does office 365 exchange server supports Foreign Connector?

    if yes, then How to create Foreign Connector in Office 365.


    Create the Transport Rule and Foreign Connector in office 365 exchange server using remote power shell script.

    Step Completed:

    I created the 30 days trailer office 365 developer account

    and i am able to import all powershell commands from office 365 using below scripts remotely

    $cred = New-Object System.Management.Automation.PSCredential -ArgumentList @($username,(ConvertTo-SecureString -String $pwd -AsPlainText -Force))
    $pso = New-PSSessionOption -SkipCACheck -SkipCNCheck
    $s = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri -Credential $cred -Authentication Basic –AllowRedirection -SessionOption $pso
    Import-PSSession $s

    After importing i able to create the Transport Rule Using "New-TransportRule" Command

    but i didn't find the   "New-ForeignConnector"  command in imported session, after running "New-ForeignConnector" command it gives the  error like "Not recognized  command"

    How to solve the above problem?

    Thanks in advance

    Sunday, February 2, 2014 6:32 PM

All replies

  • No Office365 doesn't not support Foreign connector's or Transport Agents, You can only route email over SMTP.


    Monday, February 3, 2014 2:10 AM
  • Thank you Glen for your quick reply

    But i want send the Fax Form Outlook 2013 client using Custom address space like [FAX:name@/FN=888] .


    without foreign connector i want to send email using above  email address [FAX:name@/FN=888] format from outlook 2013 client, i am getting Undeliverable message from Exchange Server.

    solution for Problem1:

    so i am creating the Dummy  foreign connector in my local exchange server with addressspace [FAX:*;1], then Outlook client starts sending custom address email format to Exchange server

    Now i am having the below problem


    Now my Exchange server server is moved to office 365 Exchange server

    so i am unable to send the Fax from my Outlook2013  client using custom email address format  like [FAX:name@/FN=888] , i am getting undeliverable message from office 365 exchange server

    but the above problem2 was solved after unchecked the "Use cached Exchange Mode" option in mail account

    [steps to disable the Use Cached exchange mode

    1)control panel -> click on Mail(32 bit) - > click on Email account -> double click on email file -> then uncheck the Use cached exchange mode


    after unchecked the use cached exchange mode, i am able sent the Fax using custom address format like [FAX:name@/FN=888] from outlook 2013 to Office 365 Exchange server


    Most of the users uses the default configuration given by outlook .ie "Use cached exchange mode" enabled.

    How to send FAX with above configuration[i.e Use Cached Exchange Mode is enabled] from Outlook 2013 client using custom address space format like [FAX:name@/FN=888] ( this problem was got solved with dummy foreign connector in local exchange server nut Office 365 exchange server doesn't support Foreign connector so how to solve this problem, please help me out from this issue )

    Thanks in advance,


    Monday, February 3, 2014 9:36 AM
  • As far as I know Office365 won't route the FAX AddressType (only SMTP and X500). While you can add these to a mailbox for it to work like you report I would say what's happening is that Outlook is just resolving the FAX address for you to a valid SMTP (you can see what's happening at the routing level by looking at the Internet Headers see ).

    From a practical standpoint Office365 (or pretty much any shared hosted Exchange) will only be able to route messages if they have a valid SMTP address. If you look at supported FAX solutions for Office365 these will all use something simular.

    From a development perspective you could maybe write your own OutlookPlugin that would check if the address being sent to is a FAX recipient and then perform some kind of translation (eg have a separate SMTP domain for Faxing). Otherwise you need to migrate to a FAX solution that supports Office365.


    Tuesday, February 4, 2014 2:16 AM
  • Thank you Glen for your quick reply

    office 365 Exchange server routes the Custom fax address email format like [FAX:name@/FN=333] from office 365 outlook web app client(OWA)..

    for supporting address type we have to do below steps:

    1) i created the "Transport rule" says that if any RecipientAddressMatchesPatterns @("FAX\-\\w*","RFAX\-\\w*") then redirect this message to particular user.

    2) after that open office 365 OWA and send the mail to [FAX:name@/FN=333] then this Email will redirect to configured user  in Transport Rule,

     Then i am reading  Email of configured user in Transport rule using "Exchange Web Service" and then i am sending these mail to fax server.


    i am able to send the Fax Using custom address format lie [FAX:name@/FN=333]  using below two methods

    1)successfully sent from office 365 outlook web app (OWA)

    2)and using outlook 2013 client  without  "Use Cached Exchange Mode"(Unchecked)

    My problem is that i am unable to send the fax from outlook 2013 client using fax format [FAX:name@/FN=333] with "Use Cached Exchange Mode"(checked).

    How to solve my problem. please help me out from this issue.

    Thanks in advance


    Tuesday, February 4, 2014 5:13 PM
  • >My problem is that i am unable to send the fax from outlook 2013 client using fax format [FAX:name@/FN=333] with "Use Cached Exchange Mode"(checked).

    If your getting an NDR where is the NDR being produced (eg is it being produced by the Exchange Online servers) and what does is say?. Have you had a look at Message Tracing for message that succeed vs one that doesn't . There aren't many options you can modify for Cache mode but you need to first determine what happens differently. Are there other Outlook Add-in's installed that maybe causing the issue ?.


    Wednesday, February 5, 2014 5:05 AM