locked
I need some advice to upgrade my development environment RRS feed

  • Question

  • Maybe this is not the right forum but i didn't find a better one. I write desktop and mobile applications for tourism businesses: hotel,restaurant and so on. Until now i' ve developed for win mobile 6.0 and win CE 5.0 devices through Visual Studio 2005. Now it's time to upgrade my development environment according to Microsoft products evolution and i need advice to make the best choice. All the devices i manage has O.S preinstalled, currently Mobile 6.5 or CE 6.0 : which is the most recent scenario in order to upgrade my applications ? is it better to jump directly to vs2010 or to go first to VS2008 ? which Add-On do i need ?

    i_m_lungomare


    • Edited by i_m_lungomare Wednesday, August 1, 2012 6:26 PM
    • Moved by Barry Wang Thursday, August 2, 2012 6:37 AM Related to Mobile Dev (From:Visual Studio Setup and Installation)
    Wednesday, August 1, 2012 6:19 PM

Answers

  • Since VS 2010 (and upcoming 2012) do not support development for Windows Mobile/CE your choice is very simple: VS 2008 Pro (or above). You probably don't need any add-ons as number of WM SDKs is included but you may want to install WM 6.5 SDKs.

    This posting is provided "AS IS" with no warranties, and confers no rights.

    • Marked as answer by Elegentin Xie Monday, August 27, 2012 7:05 AM
    Thursday, August 2, 2012 4:30 PM

All replies

  • Hi i_m_lungomare,

    Thanks for your post.

    Your issue is more related to Windows Mobile Development so I moved it.

    You will get better help here.

    Regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, August 2, 2012 6:39 AM
  • Hi, do you mean you have some problems about your compact framework installation?

    Please not forget mark your answer, and unmark your disagreed point.

    Thursday, August 2, 2012 10:54 AM
  • Since VS 2010 (and upcoming 2012) do not support development for Windows Mobile/CE your choice is very simple: VS 2008 Pro (or above). You probably don't need any add-ons as number of WM SDKs is included but you may want to install WM 6.5 SDKs.

    This posting is provided "AS IS" with no warranties, and confers no rights.

    • Marked as answer by Elegentin Xie Monday, August 27, 2012 7:05 AM
    Thursday, August 2, 2012 4:30 PM
  • I mean VS2005 is almost obsolete and i cant' find anymore devices with CE5 or Mobile 6 so i MUST move to 'newer' products but which one ?? I develop fo handeld (not for phone), does it matter ? sorry for my bad english and thank you


    i_m_lungomare

    Friday, August 3, 2012 6:40 PM
  • Thank you Ilya, i will do it but what is happened to mobile development (for handheld) after Vs2008 ?

    i_m_lungomare

    Friday, August 3, 2012 6:45 PM