none
Installing product update rollups for Windows CE 6.0 RRS feed

  • Question

  • I am using Windows CE 6.0, I am trying to install product update roll-up for windows CE 6.0. I found in some guides that we should install the following:

    • WinCEPB60-061231-Product-Update-Rollup-Armv4I.msi
    • WinCEPB60-071231-Product-Update-Rollup-Armv4I.msi
    • WinCEPB60-081231-Product-Update-Rollup-Armv4I.msi

    I couldn't find these updates in Internet. I just found the following updates:

    • WinCEPB60-131231-Product-Update-Rollup-Armv4I.msi
    • WinCEPB60-151231-Product-Update-Rollup-Armv4I.msi

    Are the updates that I found valid?

    When I tried to install the updates above, I always get the error message: there is a problem with this Windows Installer package. A script required for this install to complete could not be run. Contact your support personnel or package vendor.

    ANy help please.

    Monday, December 19, 2016 10:44 PM

All replies

  • Hi Mahdouch,

    I have three possibilities for you:

    1. Updates are cumulative therefore an update will not apply if a later update has already been applied or if it requires a prior update to be present.

    2. Antivirus software can block scripts from running so ensure whatever antivirus software you are using has the permissions set to allow scripts.

    3. Permission to the install location? Ensure the installer is being run with admin privileges and that Visual Studio is not running

    Sincerely,

    IoTGirl

    Tuesday, December 20, 2016 4:07 AM
    Moderator
  • Hi IoTGirl,

    Thank you for your answer.

    None of the pssibilities that you provided are applicable in my opinion.

    1. I haven't installed any update. I only found the two updates that I mentioned and no one can be installed due to error message.
    2. I don't have any antivirus installed on my computer
    3. I have administrator privilege when trying to install updates and Visual Studio is not running

    My question is are the updates that I found enough and are they mandatory?

    Greetings,

    Wednesday, December 21, 2016 9:49 AM
  • Hi Mahdouch,

    If you are running the evaluation edition, update will not apply.  You should reach out to whomever provided you the toolkit for support.

    Sincerely,

    IoTGirl

    Wednesday, December 21, 2016 10:48 PM
    Moderator
  • Hi IoTGirl,

    I am using a newly installed Windows 7 32 bits. Could it be the cause of update installation failure.

    Also, are the updates that I found enough and are they mandatory?

    Thanks a lot,

    Thursday, December 22, 2016 10:40 PM
  • Hi Mahdough,

    I have set up CE 6 build environments on Windows 7 32 bit PCs. My question was where did you get Platform Builder and the tools license?  If you do not have a licensed copy of Platform Builder Updates will not apply.

    Sincerely,

    IOTGirl

    Friday, December 23, 2016 12:24 AM
    Moderator