locked
sending e-mail RRS feed

  • Question

  • User-1832071357 posted

    Hello

     

    I am using Ulitmahosting and having trouble sending e-mail.

    I receive this error.

    Source Error:


    Line 416:        Public Default ReadOnly Property Item(ByVal index As Integer) As MemberInfoRow
    Line 417:            Get
    Line 418:                Return CType(Me.Rows(index),MemberInfoRow)
    Line 419:            End Get
    Line 420:        End Property
     

    Source File: C:\Users\Buddy\AppData\Local\Temp\Temporary ASP.NET Files\sonorapasssno-goers\3c98cf4c\658f96ce\App_Code.wii0alhb.7.vb    Line: 418

    Stack Trace:


    [IndexOutOfRangeException: There is no row at position 0.]
       System.Data.RBTree`1.GetNodeByIndex(Int32 userIndex) +1551046
       System.Data.RBTree`1.get_Item(Int32 index) +19
       System.Data.DataRowCollection.get_Item(Int32 index) +11
       MemberInfoDataTable.get_Item(Int32 index) in C:\Users\Buddy\AppData\Local\Temp\Temporary ASP.NET Files\sonorapasssno-goers\3c98cf4c\658f96ce\App_Code.wii0alhb.7.vb:418
       Admin_Email.GetRecipients() in C:\Users\Buddy\Documents\My Downloads\sonorapasssno-goers\admin\Email.aspx.vb:139
       Admin_Email.btnSend_Click(Object sender, EventArgs e) in C:\Users\Buddy\Documents\My Downloads\sonorapasssno-goers\admin\Email.aspx.vb:50
       System.Web.UI.WebControls.Button.OnClick(EventArgs e) +111
       System.Web.UI.WebControls.Button.RaisePostBackEvent(String eventArgument) +110
       System.Web.UI.WebControls.Button.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument) +10
       System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) +13
       System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) +36
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1565

     

    The web.config page is set with this code:

     

      <add key="ClubMailServer" value="mail.sonorapasssno-goers.com" />

        <add key="ClubMailUsername" value="admin@sonorapasssno-goers.com" />

        <add key="ClubMailPassword" value="xxxxxxxxx />

        <add key="ReportContentUpdate" value="false" />

        <add key="WebMaster" value="webmaster@sonorapasssno-goers.com" />

     

    At the bottom of the page there is this code:

     

       <mailSettings>

          <smtp from="admin@sonorapasssno-goers.com">

            <network host="mail.sonorapasssno-goers.com" password="xxxxxxxx" userName="admin@sonorapasssno-goers.com" />

          </smtp>

        </mailSettings>

     

     

    Are this right?

    <st1:city><st1:place>Lawrence</st1:place></st1:city>

    Wednesday, July 14, 2010 6:10 PM

Answers

  • User-1832071357 posted

    When I run our web site everything seems to run OK on line and local host.

    Shows all Members, Members roles when admin is signed into manage Members.

    When I run Administration Tool it shows all members and members roles.

    When I look in data base tables / aspnet_Memmbership,   aspnet_Users, UsersInRloes and click on one and run  show table data. There is nothing.

     Same thing in the Views / vw_aspnet_membershipUsers, vw_aspnet_Users, vw_aspnet_UsersinRoles. No one listed.

     This is the connection string Ulitahost gave me:

     <connectionStrings>

        <clear/>

        <add name="LocalSqlServer" connectionString="server=xx.xxx.xx.xxx;database=SONORAPASS;uid=sonorapass;pwd=XXXXXXXX;" providerName="System.Data.SqlClient"/>

        <add name="ClubSiteDB" connectionString="server= xx.xxx.xx.xxx;database=SONORAPASS;uid=sonorapass;pwd= XXXXXXXX;" providerName="System.Data.SqlClient"/>

      </connectionStrings>

     It looks like it is not connecting to data base, but how can members sign in and use roles?

    This probably why I get this error when I try to e-mail:

     Server Error in '/sonorapasssno-goers' Application.

    --------------------------------------------------------------------------------

     There is no row at position 0.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

     Exception Details: System.IndexOutOfRangeException: There is no row at position 0.

     Source Error:

     Line 416:        Public Default ReadOnly Property Item(ByVal index As Integer) As MemberInfoRow

    Line 417:            Get

    Line 418:                Return CType(Me.Rows(index),MemberInfoRow)

    Line 419:            End Get

    Line 420:        End Property

    Source File: C:\Users\Buddy\AppData\Local\Temp\Temporary ASP.NET Files\sonorapasssno-goers\3c98cf4c\658f96ce\App_Code.wii0alhb.7.vb    Line: 418

     

    How can I fix this?

    Lawrence

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, July 14, 2010 11:09 PM
  • User-1832071357 posted

    The web site is working OK.

     I do not know why it does not show any members in the

    database tables.

    Even the e-mail is working so far.

    Don't know what to say.

     

    LHR

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, July 15, 2010 10:57 PM

All replies

  • User-1832071357 posted

    When I run our web site everything seems to run OK on line and local host.

    Shows all Members, Members roles when admin is signed into manage Members.

    When I run Administration Tool it shows all members and members roles.

    When I look in data base tables / aspnet_Memmbership,   aspnet_Users, UsersInRloes and click on one and run  show table data. There is nothing.

     Same thing in the Views / vw_aspnet_membershipUsers, vw_aspnet_Users, vw_aspnet_UsersinRoles. No one listed.

     This is the connection string Ulitahost gave me:

     <connectionStrings>

        <clear/>

        <add name="LocalSqlServer" connectionString="server=xx.xxx.xx.xxx;database=SONORAPASS;uid=sonorapass;pwd=XXXXXXXX;" providerName="System.Data.SqlClient"/>

        <add name="ClubSiteDB" connectionString="server= xx.xxx.xx.xxx;database=SONORAPASS;uid=sonorapass;pwd= XXXXXXXX;" providerName="System.Data.SqlClient"/>

      </connectionStrings>

     It looks like it is not connecting to data base, but how can members sign in and use roles?

    This probably why I get this error when I try to e-mail:

     Server Error in '/sonorapasssno-goers' Application.

    --------------------------------------------------------------------------------

     There is no row at position 0.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

     Exception Details: System.IndexOutOfRangeException: There is no row at position 0.

     Source Error:

     Line 416:        Public Default ReadOnly Property Item(ByVal index As Integer) As MemberInfoRow

    Line 417:            Get

    Line 418:                Return CType(Me.Rows(index),MemberInfoRow)

    Line 419:            End Get

    Line 420:        End Property

    Source File: C:\Users\Buddy\AppData\Local\Temp\Temporary ASP.NET Files\sonorapasssno-goers\3c98cf4c\658f96ce\App_Code.wii0alhb.7.vb    Line: 418

     

    How can I fix this?

    Lawrence

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, July 14, 2010 11:09 PM
  • User-1832071357 posted

    The web site is working OK.

     I do not know why it does not show any members in the

    database tables.

    Even the e-mail is working so far.

    Don't know what to say.

     

    LHR

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, July 15, 2010 10:57 PM