locked
IE prompts for ID & Password for an intranet website RRS feed

  • Question

  • User-116968802 posted

    we have an intranet website which is set up to use windows authetication both in the web config and

    IIS (windows authentication only, removed anonymous access). But even now when we try to access the website, it still prompts for the credentials. I know that if we added the server to the trusted sites in IE through you internet explorer tools --->secuirty, it wont prompt for the credentials.

    But this wont be a good solution, is there an alternative way rather than adding the site to trusted sites on every client computers explorer settings?

     

     

    Tuesday, June 2, 2009 12:11 PM

All replies

  • User1491356988 posted

     Under security settings - user authentication - set Automatic logon only in Intranet zone.

    Tuesday, June 2, 2009 12:45 PM
  • User-116968802 posted

    Thanks for the reply but, how is this different form the solution I have.... we dont want to do it on every client machine. Is there a way around it...

     

    Tuesday, June 2, 2009 3:13 PM
  • User1491356988 posted

     you're right...I think the only way is to push security policies to the client machine...but I might be wrong. Hope someone else can help you with the right direction.

    Tuesday, June 2, 2009 6:06 PM
  • User-130687383 posted

    Hi,

    it might be nothing, but are your users and the servers joined to the same domain?

    Si

    Thursday, June 4, 2009 11:52 AM
  • User-116968802 posted

    Yes all of them are on the same domain...

    Thursday, June 4, 2009 12:05 PM
  • User717210030 posted

    Hi,

    This thread may helps

    http://forums.asp.net/p/1404045/3082872.aspx

    Friday, June 5, 2009 2:46 AM
  • User-116968802 posted

    Sorry for the delayed reply .... the above thread doesnt help much ... i tried all the options and thats what problem is ...i dont want IE to prompt for user credentials without adding it to the trusted sites on every client browser

    Thanks

    Tuesday, June 9, 2009 9:13 AM
  • User717210030 posted

    Hi,jsriharsha

    As I mentioned in another thread. If you are using IE and the clients and server are in one Domain(or domain forest),and you are using Windows Authentication.IE should do the Windows Auth Automatically without prompting any dialog. There is a method which force/disable login dialog pop up for whoever want to log into the system.
    1. Open "Internet Options" of IE
    2. Select "Security" tab and click Local Intranet under "Select a zone to view or change security settings" section
    3. click "Custom level..."
    4. go to the bottom of the settings list.check/uncheck "Prompt for user name and password".
    However, you have to make this settings in the client side, not in sever side. If there are lots of client terminals, Forms Authentication would much better for you.

    Hope it helps, if you find anything new, please update here.

    Regards

    Tuesday, June 9, 2009 10:36 PM
  • User-1203571585 posted

    Hey Guys,

    I have created a detailed how-to article for fixing this exact problem for all computers on an Active Directory domain. Please refer to the following blog post.

    http://clintboessen.blogspot.com.au/2013/09/ie-10-prompting-for-credentials-windows.html

    Kind Regards,

    Clint

    Wednesday, September 11, 2013 10:52 PM
  • User-847855536 posted

    Clint's post would be a excellent way to go about this.  If you have a domain controller and GPO setup for the domain or the OU you residein I would have it do the legwork for you and set the logon authentication method and intranet site per his blog post.

    Thursday, September 12, 2013 10:37 PM