none
RDLC report does not display on form RRS feed

  • Question

  • I have created an rdlc report in VS 2010 and corresponding form and bound the report to the form. But when I run the program it opens the form but nothing displays for the report. This is my first time creating a new report in VS2010. Is there something new that I am missing between VS2008 and VS2010?

    Thanks.

    Friday, January 13, 2012 9:31 PM

All replies

  • try to check the localreport path whether is correct or not?

    Or post the error to this topic.

    Saturday, January 14, 2012 6:44 AM
  • There is no error. It just doesn't display the report.

    Here is the code to call the report:

        Private Sub HL7DailyMgtRpt_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
            'TODO: This line of code loads data into the 'HL7DataSet.QryDailySummaryMgtRpt' table. You can move, or remove it, as needed.
            Me.QryDailySummaryMgtRptTableAdapter.Fill(Me.HL7DataSet.QryDailySummaryMgtRpt)
    
            Me.ReportViewer1.LocalReport.EnableExternalImages = True
            Me.ReportViewer1.Show()
            Me.ReportViewer1.RefreshReport()
    
        End Sub

     

    Here is the report layout:

     

    And this is what I see when I run it:

     

     

     

    Saturday, January 14, 2012 11:29 PM
  • Still struggling with this. I even created a report using the wizard and still don't see anything when the report is executed.  I double checked to make sure nothign was set as hidden. I don't know what else to check. Has anyone else hasd this issue?

    Thanks.

    Thursday, January 26, 2012 11:26 PM