none
[KinectV2]Supported USB 3.0 port detected with unknown bandwidth despite of 3.0 selected. RRS feed

  • Question

  • I am currently developing an app for kinect v2 and it is working perfectly fine with my surface pro.

    However, it is not able to run on my desktop and Kinect v2 configuration verifier is indicating that "Supported USB 3.0 port detected with unkonwn bandwidth. Kinect may or may not be compatible with your hardware." despite of my desktop's hardware is sufficient to run this device.

    Here is my hardware spec.

    Motherboard: ASROCK z77 extreme 4 ( It does have Intel 3.0 chipset )

    GPU: Geforece GTX770

    RAM: 8GB

    And I have made sure drivers are installed correctly and it is connected to intel chipset usb 3.0 port. Additionally, nothing else is connected to any of my USB  3.0 ports so there shouldn't be any bandwidth problem.

    Kinect studio does not run and doesn't display anything. Simple code written within visual studio 2013 does not display anything.

    Please help.

    Just FYI, I have tried all the troubleshooting guide and also checked required hardware spec.
    • Edited by t3dk Friday, July 1, 2016 2:15 AM Additional info
    Friday, July 1, 2016 2:11 AM

All replies

  • same problem here it's a shame that no one response yet.

    It is not hardware related, it's a development problem.

    Helo problem is also not solved in the 14372 build windows 10.

    Saturday, July 2, 2016 7:03 PM
  • The verifier says the same thing on my PC, but in my case the 3d Scan app that is part of the 3d builder app downloads and runs just fine.  The verifier is a little buggy i think.  My PC spec is: I5-6600k, Asus Z170-I, Samsung NVME 950Pro M.2 SSD, 8gb DDR-4 ram, Nvidia GTX-760 SC, Windows 10 x64.

    This particular Asus Mini ITX motherboard has an Intel USB 3.0 controller and an Asmedia usb 3.1 controller.  With the greatly increased bandwidth that usb 3.1 brings you would think the Kinect would shine using it but in this case the verifier once again says its unrecognized and the the 3dscan app DOES NOT work when plugged into a 3.1 port.

    I am not a software developer, just an avid tinkerer.  I own a 3d printer and have been designing stuff in Sketchup for just over a year.  If they can get the bugs worked out and get the support for Kinect v2 for Windows up to snuff then i think they will have a winner on their hands.  This device, as a 3d scanner, could be a great foot in the door kind of a device for people like me who just want to try it before making a much bigger jump to a true 3d scanner.

    Monday, July 4, 2016 2:21 PM
  • Great news!!

    I did not do anything and it suddenly started to work today. (Yesterday, I installed Windows 8 and windows 8.1 virtual machines to test Kinect V2 with but still failed)

    Before Depth and Color streams did not work but it does work and it also works within the program I have written.

    USB controller still indicates that unknown bandwidth but I am happy as long as it functions correctly.

    Cheers!

    • Proposed as answer by Yanis Lukes Saturday, July 9, 2016 11:52 AM
    Tuesday, July 5, 2016 5:52 AM