none
More than 2 Concurrent connections not working in BizTalk 2013 RRS feed

  • Question

  • Hello,

    I am trying to increase concurrent connections from BizTalk 2013 to remote server and i made changes to  BTSNTSvc64.exe.config (using 64 bit host)  as below. After my changes still BizTalk creating 2 connections at one time. Any one had any idea ...Pls help...

    <configuration>
      <system.net>
        <connectionManagement>
          <add address="testComputer" maxconnection="20" />
           </connectionManagement>
      </system.net>
    </configuration>




    Thursday, November 17, 2016 6:05 PM

Answers

  • I got IIS log files from Remote server and all the time i can see only 2 connections from BizTalk. I am trying to decrease the latency by allowing concurrent calls from BizTalk.

    After my config change i did reboot the server and still no luck

    Bobby,

    Yes you are right, By default the SOAP, HTTP, and HTTP-based WCF adapters (and .NET in general) open only two concurrent HTTP connections from each BizTalk server to any specific destination server.

    For accessing a service on a network that is hosted on a computer remember that computer name is case sensitive, and could not be fully qualified.  So http://MYCOMPUTERNAME , http://MYCOMPUTERNAME.FullyQualifiied.DomainName.com might not work. So whenever a computer is hosting the service the format is “http://computername” 

    So your configuration should be:

    <system.net>
            <connectionManagement>
                <add address = "http://testcomputer" maxconnection = "20" />
            </connectionManagement>
        </system.net>

    If it still doesn't work try setting like below to figure out if it not resolving the name:

    <system.net>
            <connectionManagement>
                <add address = "*" maxconnection = "20" />
            </connectionManagement>
        </system.net>

    Don't forget to restart all the host instances.


    Rachit Sikroria (Microsoft Azure MVP)

    Friday, November 18, 2016 2:28 AM
    Moderator

All replies

  • So, how do you know it's only 2 concurrent connections?

    Typically, we have to tune BizTalk to lower the number of concurrent connections.

    Is it possible you process is serialized in such a way that there would be only 2 outgoing messages at a time?

    Thursday, November 17, 2016 6:34 PM
    Moderator
  • I got IIS log files from Remote server and all the time i can see only 2 connections from BizTalk. I am trying to decrease the latency by allowing concurrent calls from BizTalk.

    After my config change i did reboot the server and still no luck

    Thursday, November 17, 2016 6:53 PM
  • Did u restart ur related host instance ? Do a stop and start and then test again. 

    The address should be the complete one ..


    Pi_xel_xar

    Blog: My Blog

    BizTalkApplicationDeploymentTool: BizTalk Application Deployment Tool/

    Thursday, November 17, 2016 8:01 PM
    Answerer
  • I got IIS log files from Remote server and all the time i can see only 2 connections from BizTalk. I am trying to decrease the latency by allowing concurrent calls from BizTalk.

    After my config change i did reboot the server and still no luck

    Bobby,

    Yes you are right, By default the SOAP, HTTP, and HTTP-based WCF adapters (and .NET in general) open only two concurrent HTTP connections from each BizTalk server to any specific destination server.

    For accessing a service on a network that is hosted on a computer remember that computer name is case sensitive, and could not be fully qualified.  So http://MYCOMPUTERNAME , http://MYCOMPUTERNAME.FullyQualifiied.DomainName.com might not work. So whenever a computer is hosting the service the format is “http://computername” 

    So your configuration should be:

    <system.net>
            <connectionManagement>
                <add address = "http://testcomputer" maxconnection = "20" />
            </connectionManagement>
        </system.net>

    If it still doesn't work try setting like below to figure out if it not resolving the name:

    <system.net>
            <connectionManagement>
                <add address = "*" maxconnection = "20" />
            </connectionManagement>
        </system.net>

    Don't forget to restart all the host instances.


    Rachit Sikroria (Microsoft Azure MVP)

    Friday, November 18, 2016 2:28 AM
    Moderator
  • Hi ,

    IIS logs files will let you know how connections are being made and the status of each connection . 

    can you see any timeout exception when you hit the http endpoint with multiple request ?

    BizTalk can handle multiple connections and you need to check the IIS settings ,amy be check the connection pool.

     


    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply


    Friday, November 18, 2016 2:43 AM
  • How are you confirming the 2 concurrent connections?

    You can use either a network capturing tool like Netmon, or check in Active Service instances (for your Port) in Admin Console to confirm this.

    Also, try out what Rachit has mentioned earlier.


    Thanks Arindam

    Friday, November 18, 2016 3:40 AM
    Moderator
  • Hello Rachit,

    After deleting domain name from address its working as expected. Thank you for the help.

    Monday, November 21, 2016 1:47 PM