none
ILogoAutomation access RRS feed

  • Question

  • Hi, 

        We have been trying to query Logo Automation OLE interface and we cannot seem to get it to work. Specifically, we have followed the guidelines in:

    http://msdn.microsoft.com/en-us/library/windows/hardware/jj906442.aspx

    But cannot see the ILogoAutomation OLE object (using OLEView) and obviously it fails to create this object even if we follow the recommended approach of trying to create an instance of this interface in a loop while the Logo3.exe application is running the tests. I also tried to make sure it had registered it server (using logo3.exe /RegServer command) and it still does not appear to be registered correctly. I have it running on a Windows 8 laptop with a touch screen - just to see if it will work.

    So, what I am doing wrong? Any thoughts?

    Thanks

    Jerome

    Friday, January 3, 2014 1:56 PM

All replies

  • Worked for me. Verify that your logo3 also is x64 .

    Use OLE/COM object explorer to verify registration. Run you app after the logo runs.

    Tuesday, January 7, 2014 12:11 PM
  • As pointed out below, WOW is not supported for RegServer. You can see the documentation link here - http://msdn.microsoft.com/en-us/library/windows/hardware/jj906442.aspx

    Can you confirm you're not trying to use the x86 version on an x64 machine?

    Tuesday, January 7, 2014 7:49 PM
  • If somebody tryed to use it on remote?

    I dont undestand the specs prerequisites that says: A user account that will be used on both the server and the robot controller .

    As i understand i need to setup same user on robot PC and system under test to be able to connect from robot pc to logo3.exe.

    If both pc's are not on domain how to setup same user for this ? 


    Wednesday, January 8, 2014 6:44 AM