locked
Deploying .Net Framework 3.5 application into .Net Framework 4.0 RRS feed

  • Question

  • User1579037345 posted

    Hello Friends


    i have devloped web application in .Net Framework 3.5 but i want to host it on server which uses .Net Framework 4.0 .....when i run application in web.config it gives some error


    ERROR

    The value for the 'compilerVersion' attribute in the provider options must be 'v4.0' or later if you are compiling for version 4.0 or later of the .NET Framework. To compile this Web application for version 3.5 or earlier of the .NET Framework, remove the 'targetFrameworkMoniker' attribute from the <compilation> element of the Web.config file.


    can anyone suggest what should setting to be done in web.config to run application successfully...



    Thank in Advanced

    Abhijit

    Tuesday, December 22, 2009 12:06 AM

Answers

  • User1452680134 posted

    just check this:

    http://www.aspspider.com/qa/Question4509.aspx

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, December 23, 2009 9:20 AM

All replies

  • User1452680134 posted

    check tis

    http://msdn.microsoft.com/en-us/library/dd759047%28VS.100%29.aspx

    http://vishaljoshi.blogspot.com/2009_08_01_archive.html

    http://blogs.microsoft.co.il/blogs/davids/archive/2009/05.aspx

    Tuesday, December 22, 2009 1:41 AM
  • User1452680134 posted

    check tis

    http://msdn.microsoft.com/en-us/library/dd759047%28VS.100%29.aspx

    http://vishaljoshi.blogspot.com/2009_08_01_archive.html

    http://blogs.microsoft.co.il/blogs/davids/archive/2009/05.aspx

    Tuesday, December 22, 2009 1:42 AM
  • User1579037345 posted
    thanks dude its really helpful ....thanks
    Tuesday, December 22, 2009 2:43 AM
  • User1579037345 posted

    unable to put  targetFrameworkMoniker=".NETFramework, Version=v4.0" property in 

    compilation tag.....its showing error .....plz help me where to put targetFrameworkMoniker property?

    Tuesday, December 22, 2009 2:53 AM
  • User1452680134 posted

    The solution for the above error in VS 2010 BETA 1 is to add below attribute under compilation node of the web.config file

    targetFrameworkMoniker=.NETFramework,Version=v4.0”


    Tuesday, December 22, 2009 3:24 AM
  • User1452680134 posted

    web.config  schema will support a special attribute called targetFramework=”4.0” as shown below:

    <system.web>

    <compilation debug="true" targetframework="4.0"/>

    </system.web>

    Tuesday, December 22, 2009 3:28 AM
  • User1579037345 posted

    Actually i am using VS 2008 and i am hosting my web site on server where .net framwork 4.0 used , so currently i am editing my web.config in VS 2008 which is not supporting targetframework attribute...what should i do ...?

    Tuesday, December 22, 2009 3:50 AM
  • User1452680134 posted

    have u tried publishing the appln which version of iis is used on the server


    Tuesday, December 22, 2009 8:44 AM
  • User1452680134 posted

    http://msdn.microsoft.com/en-us/library/dd759047%28VS.100%29.aspx

    Tuesday, December 22, 2009 8:48 AM
  • User1579037345 posted

    i have put targetFramework Tag in compilation i got this error

    Unrecognized attribute 'targetframework'. Note that attribute names are case-sensitive.


    Line 23: 		<customErrors mode="Off"/>
    Line 24: <compilation debug="true" targetframework="4.0">
    Line 25:
    Line 26: <assemblies>



    if u come across this error plz try to help me out....


    thank in advanced...

    Wednesday, December 23, 2009 12:26 AM
  • User1452680134 posted

    just check this:

    http://www.aspspider.com/qa/Question4509.aspx

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, December 23, 2009 9:20 AM