locked
patch for version 5.1.2 causing "unable to start debugging issue" RRS feed

  • Question

  • upon receiving the "Unable to start debugging.  The Silverlight Developer Runtime is not installed.  Please install a matching version" I did the research and uninstalled my silverlight editions then re-installed using the Silverlight 5 toolkit.  This puts the version at:  Microsoft Silverlight. Product Version: 5.1.10411.0.   Then everything was good again. 

    At 3:00 AM the company pushed the patch Microsoft Silverlight. Product Version: 5.1.20513.0 and I cannot debug again.  This has happened 3 days in a row now until I was able to track down exactly what is happening.

    The SDK version is the SDK (runtime) version is 5.061118.0.   We are looking at blocking the patch from coming to my computer but that is not a good fix.   From what I can tell I am runing the latest SDK version.

    Any insight on a solution that does not involve blocking silverlight patches would be greatly appreciated.  To rub salt in the wounds I am not using any silverlight controls in my app.  So if there is a way of completely removing silverlight from my VS 2010 I would be open to that solution as well.

    Thank you for taking the time to read/help with this.

    Friday, September 27, 2013 2:06 PM

All replies

  • Hi,

    According to the error message, it is suggested to install Silverlight developer runtime.

    You may go to the link below for reference:

    Silverlight 4.0 Debugging Issue – “Unable to start Debugging.The Silverlight Developer Runtime Not Installed. Please Install a matching version” – Resolution   

    http://abhijitjana.net/2010/09/25/silverlight-4-0-debugging-issue-unable-to-start-debugging-the-silverlight-developer-runtime-not-installed-please-install-a-matching-version-resolution/

    Besides, if you want to remove Silverlight, you can unintall it in control panel. And you can refer to the link below:

    http://jansonchun.hubpages.com/hub/uninstall-Microsoft-Silverlight

    Hope it helps.

     

    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Thursday, October 3, 2013 9:48 AM
  • I had the patch blocked but now the issue is coming in again.  The information you provided is for Silverlight 4.  As you can see in my original text I have Silverlight 5.  I also have the Silverlight runtime installed.  As of right now everything is fine because I just uninstalled Silverlight and re-installed again.  but tonight the patch for 5.12 of silverlight will come in again, and cause a problem with my silverlight 5.06 SDK.  I must uninstall and re-install every morning in order to work on my website.

    Thursday, November 7, 2013 2:32 PM
  • I had this issue due to upgrade to windows 8.1 and it's "improved" version of IE.

    My problem was(is) to do with EPM.  Every time I load a page with Silverlight on it, IE asks if I want to load the add in.

    You could try disabling epm in your IE settings.

    What worked for me:

    Uninstall the Silverlight sdk, restart, install the sdk again. Restart.

    Thursday, November 7, 2013 2:47 PM
    Moderator
  • We are still using IE 8 so EPM from my understanding is not in effect until IE 10.  Also I am on Windows 7 if that makes a difference.

    Wednesday, November 13, 2013 9:53 PM