none
installing .NET 3.5 SP1 as prerequisite without internet RRS feed

  • Question

  • I'm trying to install my application which has .NET 3.5 SP1 as prerequisite. I have included full bootstrapper package for .NET 3.5 SP1 but it still tried to connect to the internet.

    Is it possible to include full installer package as bootstrapper. Do I need to author product.xml etc., by hand. Anyone has used MSI prerequisite for .NET 3.5 which doesn't require an internet connectivity to install.

    Thank you.

    Rgds,

    Rajesh B

    Wednesday, August 11, 2010 1:36 PM

Answers

  • Hi Rajesh,

    Based on your description, it seems that the .NET Framework 3.5 SP1 installer is still downloaded from official website during the installation of your application even you have deployed it with the option of "Download prerequisites from the same location as my application".

    This behavior is by design. The reason is that .NET Framework 3.5 SP1 installer is shipped as Homesite Only. This means that it only supports "Download prerequisites from the component vendor's website" even we choose "Download prerequisites from the same location as my application".

    As a workaround, you might follow the instructions here "Enable Samesite for the .NET Framework 3.5 SP1 bootstrapper":
    http://download.microsoft.com/download/A/2/8/A2807F78-C861-4B66-9B31-9205C3F22252/VS2008SP1Readme.htm

    BTW, this forum is for the support of .NET Framework installation. Since your issue is related to application deployment, if you have any further concern, you could post your thread on ClickOnce and Setup & Deployment Projects forum. You will get more useful help there.

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg@microsoft.com


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Thursday, August 19, 2010 4:20 AM
    Thursday, August 12, 2010 9:23 AM

All replies

  • I'm trying to install my application which has .NET 3.5 SP1 as prerequisite. I have included full bootstrapper package for .NET 3.5 SP1 but it still tried to connect to the internet.

    Is it possible to include full installer package as bootstrapper. Do I need to author product.xml etc., by hand. Anyone has used MSI prerequisite for .NET 3.5 which doesn't require an internet connectivity to install.

    Thank you.

    Rgds,

    Rajesh B


    http://social.msdn.microsoft.com/Forums/en/netfxsetup/thread/cbe33875-eb56-45d9-8e39-afa4b6aa6e7e
    Just Be Humble Malange!
    Wednesday, August 11, 2010 3:07 PM
  • Thank you for your reply. I understood that Full Installer package doesn't require internet connection to complete the install.

    My question is can we have this full installer package as bootstrapper prerequisite.

    Rgds,

    Rajesh B

    Wednesday, August 11, 2010 5:33 PM
  • Hi Rajesh,

    Based on your description, it seems that the .NET Framework 3.5 SP1 installer is still downloaded from official website during the installation of your application even you have deployed it with the option of "Download prerequisites from the same location as my application".

    This behavior is by design. The reason is that .NET Framework 3.5 SP1 installer is shipped as Homesite Only. This means that it only supports "Download prerequisites from the component vendor's website" even we choose "Download prerequisites from the same location as my application".

    As a workaround, you might follow the instructions here "Enable Samesite for the .NET Framework 3.5 SP1 bootstrapper":
    http://download.microsoft.com/download/A/2/8/A2807F78-C861-4B66-9B31-9205C3F22252/VS2008SP1Readme.htm

    BTW, this forum is for the support of .NET Framework installation. Since your issue is related to application deployment, if you have any further concern, you could post your thread on ClickOnce and Setup & Deployment Projects forum. You will get more useful help there.

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg@microsoft.com


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Thursday, August 19, 2010 4:20 AM
    Thursday, August 12, 2010 9:23 AM
  • Hi Rajesh,

    I'm writing to follow up the post. Does the above suggestion work?

    Please feel free to let me know if you need any help.

    Best regards,
    Yichun Chen
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg@microsoft.com


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Wednesday, August 18, 2010 2:59 AM
  • Hi Rajesh,

    I've marked my reply as answer. If you have any concern, please feel free to let me know.

    Have a nice week!

    Best regards,
    Yichun Chen
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg@microsoft.com


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Thursday, August 19, 2010 4:19 AM