locked
I can't sign in with my Microsoft account in Visual Studio for Mac Preview RRS feed

  • Question

  • User247003 posted

    Visual Studio redirects me to the login page of my organisation, but once there the login screen remains blank (a small box should appear to ask me for my user and password, but it never happens):

    Any ideas?

    Monday, May 15, 2017 8:47 AM

All replies

  • User131278 posted

    Hi Julio, please exit Visual Studio for Mac, delete ~/.ServiceHub, then restart Visual Studio to see if that helps. Thanks!

    Monday, May 15, 2017 12:22 PM
  • User247003 posted

    @AshleyGazich said: Hi Julio, please exit Visual Studio for Mac, delete ~/.ServiceHub, then restart Visual Studio to see if that helps. Thanks!

    Still the same, just a blank screen.

    Monday, May 15, 2017 12:26 PM
  • User324110 posted

    Same thing happen to me here. Also try deleting the suggestion above, but still not working.

    Tuesday, May 16, 2017 3:38 PM
  • User131278 posted

    Do either of you happen to be behind a network proxy?

    Tuesday, May 16, 2017 6:24 PM
  • User247003 posted

    @AshleyGazich said: Do either of you happen to be behind a network proxy?

    No, I am not.

    Wednesday, May 17, 2017 8:16 AM
  • User131278 posted

    @"julio.cabanas" Could you please email the contents of ~/.ServiceHub/logs to my attention via hello@xamarin.com?

    Wednesday, May 17, 2017 9:23 PM
  • User247003 posted

    @AshleyGazich said: @"julio.cabanas" Could you please email the contents of ~/.ServiceHub/logs to my attention via hello@xamarin.com?

    Done!

    Thursday, May 18, 2017 8:34 AM
  • User304432 posted

    Was a solution found to this problem? I also have the same issue currently.

    Tuesday, May 23, 2017 10:04 AM
  • User131278 posted

    Julio and Adam, thanks for your patience during investigation. We just released a new preview that should help with some of the sign-in issues. If you'd like to give that a try, please change the updates channel to Beta (Stable can be safely reverted to at any time by simply switching back). Here are the corresponding release notes and blog post. Note that signing in to your Microsoft account behind a proxy still fails, so we are working on that. Thanks!

    Friday, June 16, 2017 7:08 PM
  • User332206 posted

    @AshleyGazich I am currently having a similar issue. My company recently switched emails from @company.com to @company.onmicrosoft.com. I have no issues logging into VS on my windows machine. However when I try to enter my credentials on VS for Mac it will not log on. Thanks!

    Monday, August 14, 2017 7:00 PM
  • User131278 posted

    @NolanSinclair apologies for the delayed reply--I'm just now seeing this notification. Is authentication happening behind a proxy? What is your full version information from Visual Studio > About Visual Studio > Show Details > Copy Information [button]? If this is still an issue, please go to Help > Report A Problem in Visual Studio and submit a report there with those details so that we can follow up directly. Thanks!

    Tuesday, August 29, 2017 8:57 PM
  • User76518 posted

    Im having the same issue too, not behind a proxy. Is there a workaround for this?

    Thursday, November 16, 2017 2:50 PM
  • User359330 posted

    I'm having the same issue here, running with:

    Visual Studio Community 2017 for Mac (Preview) Version 7.3 Preview (7.3 build 764) Installation UUID: e3590713-3173-4b16-b9f9-3e2dc4b0eecf Runtime: Mono 5.4.1.7 (2017-06/e66d9abbb27) (64-bit) GTK+ 2.24.23 (Raleigh theme)

    Package version: 504010007
    

    Update: when connecting to my cellular provider through hotspot the connection succeeded. not sure what is the case but i'm getting very slow response from you're servers even on safari. (when trying connect to VS)

    Sunday, November 19, 2017 10:03 PM
  • User363204 posted

    Same Issue here

    12/13/2017 06:17:04 : Error : An exception was encountered while reading data from the IdentityServiceAdalCacheStorage : System.NullReferenceException: Object reference not set to an instance of an object at Microsoft.Developer.IdentityService.AccountProvider.IdentityServiceAdalCacheStorage.ReadDataCore () [0x000ac] in <81b4c4c52fa54b43bf1f184f5ad4df28>:0 at Microsoft.Developer.IdentityService.AccountProvider.IdentityServiceAdalCacheStorage.ReadData () [0x0004d] in <81b4c4c52fa54b43bf1f184f5ad4df28>:0

    Wednesday, December 13, 2017 3:18 PM
  • User131278 posted

    @IainSmith @Shlomiza @"Louis.7875" and anyone else that may be affected: A bug related to signing in was fixed in Visual Studio for Mac 7.3.3.5 (release notes here).

    We are currently tracking Cannot sign in to VS 2017 on Mac with my company account, which you can comment on and vote for in the Visual Studio Developer Community.

    For behavior suspected to be a Visual Studio for Mac bug, please submit an issue via Help > Report a Problem in the IDE.

    Tuesday, January 16, 2018 9:46 PM
  • User76518 posted

    Its working for me now :) in on 7.4 thanks for the update.

    Monday, January 22, 2018 11:44 AM
  • User247003 posted

    Working for me on 7.3.3!

    Monday, January 22, 2018 11:51 AM