locked
Is anyone else having issues enabling Money, Email, Phone, etc.. data types in LightSwitch? RRS feed

  • Question

  • I am testing VS2012 LightSwitch and have found that I cannot set Money type (or others) in my table.  I see where the additional data types are needed and believe I have loaded in the correct but still dont have these types accessible. 

    http://msdn.microsoft.com/en-us/library/hh304426.aspx

    LightSwitch Extension Data Types

    If a LightSwitch project includes the Microsoft.LightSwitch.Extensions extension library, the following types are also supported:

    • Microsoft.LightSwitch.Extensions:EmailAddress

    • Microsoft.LightSwitch.Extensions:Image

    • Microsoft.LightSwitch.Extensions:Money

    • Microsoft.LightSwitch.Extensions:Percent

    • Microsoft.LightSwitch.Extensions:PhoneNumber

    • Microsoft.LightSwitch.Extensions:WebAddress

    Now, when I open the Expense tracker project it does show those types so there is a setting wrong in my project.  Looked at the .lsml file in my project vs. the expense tracker and see where expense tracker has the data type set. 

    Any thoughts on what I need to change in my project?

    Friday, December 21, 2012 5:04 PM

Answers

  • Argh... Just solved my own problem.  While I did in fact load the extensions I didnt make them available in my project.  I just went to the solution properties and checked "Microsoft LightSwitch Extensions".

    • Marked as answer by MJDinMD Friday, December 21, 2012 5:08 PM
    Friday, December 21, 2012 5:08 PM

All replies

  • Argh... Just solved my own problem.  While I did in fact load the extensions I didnt make them available in my project.  I just went to the solution properties and checked "Microsoft LightSwitch Extensions".

    • Marked as answer by MJDinMD Friday, December 21, 2012 5:08 PM
    Friday, December 21, 2012 5:08 PM
  • Hi

    I think Microsoft LightSwitch Extension has been disabled. Kindly go to the properties and in the Extenstion tab enable Microsoft LightSwitch Extension. I think your problem will fix.

    Regards


    Rashmi Ranjan Panigrahi
    www.lightswitchspecial.com

    If you found this post helpful, please “Vote as Helpful”. If it answered your question, please “Mark as Answer”.
    This will help other users to find their answer quickly.

    Friday, December 21, 2012 5:10 PM
  • There's another checkbox in the far right column (Use In New Projects) that will automatically enable the extension in any future projects that you create.


    Yann - LightSwitch Central - Click here for FREE Themes, Controls, Types and Commands
     
    Please click "Mark as Answer" if a reply answers your question. Please click "Vote as Helpful" , if you find a reply helpful.
     
    By doing this you'll help others to find answers faster.

    Friday, December 21, 2012 10:36 PM
    Moderator