none
How to replace .net compact framework from catalog item tomy own .net framework RRS feed

  • Question

  • Hi.

    I want replace .net framework from catalog item to .net 2.0 sp2

    I download .net CE 2.0 sp2 and I want add this to my os image.Can I do this?

    Friday, September 7, 2012 6:59 PM

All replies

  • Based on the following document,I dont think .net CE 2.0 is supported on Compact 7.

    http://msdn.microsoft.com/en-us/library/gg158497.aspx

    Wince 6.x supports .net ce 2 and ce 3.5

    Friday, September 7, 2012 7:28 PM
  • I use CE 6.0
    Friday, September 7, 2012 8:12 PM
  • Ahh gotcha

    if you downloaded SP2 thru the Windows CE update tool then it should automatically update your PB codebase.

    if not, then you may have to do it manually if you wish to 'bake' the sp2 into rom OR you could create the image, load it into the hardware and then install the sp2 to the target device and then finally install your app.

    I am not familiar with how to manually massage a sp2 code into the PB codebase, perhaps other experts can shed some light on that process. for one thing, its not an easily repeatable and maintainable way of doing things in the long run, best to go via the Windows CE update tool method.

    Friday, September 7, 2012 8:48 PM
  • On 9/7/2012 8:59 PM, Artem wrote:
    > Hi.
    >
    > I want replace .net framework from catalog item to .net 2.0 sp2
    >
    > I download .net CE 2.0 sp2 and I want add this to my os image.Can I do this?
    >
     
    As therockster already pointed out, just update your system by
    installing QFEs and rebuild your OS image.
    This will include the latest release of the .NET CF and also upgrade
    other components on your system.
     

    Valter Minute
    Windows Embedded MVP
    http://geekswithblogs.net/WindowsEmbeddedCookbook
    Saturday, September 8, 2012 9:45 AM