locked
connect to oracle RRS feed

  • Question

  • User-1384036652 posted

    If using system.data.oracleClient, I can connect to the oracle db and fetch data within visual studio, but not via IIS.

    If I add reference to oracle.dataAccess, it throws an error.

    I am confused.  Please help.

    Thursday, May 23, 2013 10:32 AM

Answers

  • User1924956857 posted

    Could be the Application Pool setting from IIS.

    In the advanced settings of the application pool try setting 'Enable 32-bit applications'

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, May 23, 2013 2:05 PM

All replies

  • User-578610739 posted

    Hi kzhu,

    Which error you got and what the mean by fetch data within vs , but not via iis.

    Thursday, May 23, 2013 11:19 AM
  • User-1384036652 posted

    An attempt was made to load a program with an incorrect format. (Exception from HRESULT: 0x8007000B)


    I did a little bit research showing the error message is vague and could mean many things.  My feeling is it has to do with system.data.oracleClient.

    By "within vs", I mean I view the page in browser from Visual Studio 10.  via IIS I mean from "localhost/test.aspx"

    Thursday, May 23, 2013 11:30 AM
  • User1924956857 posted

    Could be the Application Pool setting from IIS.

    In the advanced settings of the application pool try setting 'Enable 32-bit applications'

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, May 23, 2013 2:05 PM
  • User-1384036652 posted

    Could be the Application Pool setting from IIS.

    In the advanced settings of the application pool try setting 'Enable 32-bit applications'

    Hey, that did the magic!  Thanks.  But what's going on?

    Friday, May 24, 2013 9:19 AM
  • User1924956857 posted

    The connector (or other external component dll's) that are created for 32-Bit machines cannot run under a 64-bit IIS installation, except when you turn this feature on.

    A more in-depth answer as to why this is, I don't have Embarassed

    Friday, May 24, 2013 2:29 PM