locked
Solved (KathyW2) but left unanswered questions - web page looks weird in IE9 final version though it looks fine in EW4 SuperPreview with IE9 and also in Firefox 4 RRS feed

  • Question

  • I am facing a rather odd problem. If I view my web page on SP E9 it looks as it appears in EW4 SP1 Design View. If I view my web page on Firefox 4 it looks as it appears in EW4 SP1 Design View. But if I view my web page on IE9 Final version it does not look as it appears in EW4 SP1 Design View. The Logo shifts to west (left) and content shift to south (down).

    The web page is http://www.yashodharman.in/english/index.html as of 19:27 +05:30 hrs. By the time you get to view it if you find it okay then you might assume that I have found the solution. If it looks as I have described above then it would mean I haven't yet figured out how to fix it. The same URL if viewed on SP IE9 or Firefox 4 it sould appear okay as it is now.  

    Any help will be highly appreciated. Thank you. MR.


    Thank you,
    M.R.
    At times, my question may be unclear to you
    Please feel free to ask me counter-questions
    So I get to clarify before you decide to help me with your answer.
    • Edited by MR_2009 Saturday, April 9, 2011 8:27 PM title edited
    Friday, April 8, 2011 2:04 PM

Answers

  • Add "clear:both" to #navigation.  Fixes IE7.  See what it does for IE9.
    • Marked as answer by MR_2009 Friday, April 8, 2011 6:23 PM
    Friday, April 8, 2011 3:54 PM

All replies

  • Just a note: It looks wrong in IE7, too.
    Friday, April 8, 2011 3:33 PM
  • Add "clear:both" to #navigation.  Fixes IE7.  See what it does for IE9.
    • Marked as answer by MR_2009 Friday, April 8, 2011 6:23 PM
    Friday, April 8, 2011 3:54 PM
  • It worked but that leaves unexplained questions "why SuperPreview did not show the problem" and "why Firefox did not show the problem"?

    After all IE9 is as latest as as Firefox 4 and EW4 SP1 SuperPreview.

    Saturday, April 9, 2011 8:25 PM