locked
FSLogix CloudCache - multisession support RRS feed

  • Question

  • Hi, I would like to ask if someone can confirm whether FSLogix CloudCache is supported in multisession configuration type. That is if we have multiple sessions on different machines that share the same profile container (configuration parameter "ProfileType" with DWORD value 3 for exemple) - 1st access to profile vhdx in RW mode, 2nd session access in RO mode.

    Thanx in advance. 

    Tuesday, October 1, 2019 3:39 PM

All replies

  • Yes, CCD does support multisession. to configure this you'll set a few reg keys.
    HKLM\Software\FSLogix\Profiles\Enabled = 1
    HKLM\Software\FSLogix\Profiles\ProfileType = 3
    HKLM\Software\FSLogix\Profiles\ConcurrentUserSessions = 1
    CCDLocations = (see documentation)

    What you'd want to do is login on one machine to get the profile setup and created for the first time and then logoff. This creates your base disk on your network share so it can be used to create diff disks for the RW and RO disks. If you don't do this, and you login on the second machine before the base disk has been created it will create a new profile but it will be a RO disk and be tossed on logoff. After the base disk is created, any subsequent logins will grab a diff disk. The first diff disk will be the RW disk. When you logoff, doesn't matter the order, the last machine to log off will take the RW disk and merge it into the base disk. So, if you log off on the machine that has the RW disk, the RW disk will hang around till the last machine with a RO disk logs off. That machine will toss its RO disk and then merge the RW disk. We do this because we can't change the base disk while there are RO disks out. Once they are gone, the base disk can be updated.

    In the CCD configuration, if the machines doing multi session need to be capable of offline work (eg. a laptop) it is recommended that you leave ClearCacheOnLogoff set to its default setting (eg. don't configure it). This will copy the base disk to the machine logging in for offline use. As you can guess, each machine should be connected to the internet or a work network where it can access the file share where the base disk lives when it does its first login.


    https://docs.microsoft.com/en-us/fslogix/profile-container-configuration-reference
    https://docs.microsoft.com/en-us/fslogix/cloud-cache-configuration-reference



    • Proposed as answer by Will Cherry Wednesday, October 2, 2019 5:18 PM
    • Edited by Will Cherry Wednesday, October 2, 2019 5:21 PM
    Wednesday, October 2, 2019 5:18 PM
  • Hi Will,

    thank you very much for your answer, i do apologize to reply to you  with a bit of delay since i have been absent, at the same time i wanted to do some more testing following your explanation. As you can imagine I posted my first question since I'm facing some problems using CCD configuration in multisession setup. The use case is intended in Citrix XenApp (CVAD) where user starts 1st session on a full desktop (W2K16) and then launches published application (from within desktop session) on another VDA (also W2K16). FSLogix version installed is 2.9.7117.27413 (tried with the latest one as well 1909 with same result), tested in a clean environment with only the parameters configured as you suggested plus logging enabled.

    The issue i'm observing is a very long logon delay in a 2nd session ('Please wait for the fslogix apps services' message) ~160 seconds, after which the disk is mounted (RO) as expected. If i start  published application as a 1st session (disk mounts as RW), then there is no delay).

    Looking in the FSLogix logs (2nd session)  I can see:

    In Profile log (~157s)

    [16:32:21.180][tid:00000950.00001058][INFO]             Profile VHD Path: C:\ProgramData\FSLogix\Proxy\S-1-5-21-4075742445-2671179031-2475658168-1135_test-s01\Profile_test-s01.vhd
    [16:34:57.227][tid:00000950.00001058][INFO]             RW exists.  Taking RO role.
    [16:34:57.618][tid:00000950.00001058][INFO]             Created RO diff: C:\Windows\TEMP\S-1-5-21-4075742445-2671179031-2475658168-1135_RO.vhd
    [16:34:57.618][tid:00000950.00001058][INFO]             User Profile Path: C:\Users\test-s01.FSL0
    [16:34:57.712][tid:00000950.00001058][INFO]             VHD attached


    In CloudCache Service Log

    [16:32:21.227][tid:000008f8.00001234][INFO]           ===== Begin Session:  CCache::AcquireSharedReaderLock
    [16:32:21.227][tid:000008f8.00001234][INFO]             Acquiring shared reader CCD lock for file path: C:\ProgramData\FSLogix\Proxy\S-1-5-21-4075742445-2671179031-2475658168-1135_test-s01\RW.vhd
    [16:32:21.227][tid:000008f8.00001234][INFO]             File Name converted to NT path name "C:\ProgramData\FSLogix\Proxy\S-1-5-21-4075742445-2671179031-2475658168-1135_test-s01\RW.vhd" -> "\Device\HarddiskVolume2\ProgramData\FSLogix\Proxy\S-1-5-21-4075742445-2671179031-2475658168-1135_test-s01\RW.vhd"
    [16:34:57.227][tid:000008f8.00001234][INFO]             Failed to acquire Shared Reader CCD Lock for C:\ProgramData\FSLogix\Proxy\S-1-5-21-4075742445-2671179031-2475658168-1135_test-s01\RW.vhd
    [16:34:57.227][tid:000008f8.00001234][INFO]           ===== End Session:  CCache::AcquireSharedReaderLock
    [16:34:57.227][tid:000008f8.00000da0][DBG]             Vdisk 1 opened.  Created = 0.  SectorSize = 200
    [16:34:57.305][tid:000008f8.00000da0][DBG]             Provider 5923534784581209081 is most up to date:
    [16:34:57.305][tid:000008f8.00000da0][DBG]              File Size: 98828288
    [16:34:57.305][tid:000008f8.00000da0][DBG]              Sequence: 1001
    [16:34:57.305][tid:000008f8.00000da0][DBG]              Cache Identifier: 8102b4b1-e90a-11e9-9c19-000c29c3fa0b
    [16:34:57.305][tid:000008f8.00000da0][DBG]              Is Flushing: False
    [16:34:57.305][tid:000008f8.00000da0][INFO]            Local cache was found to be invalid.
    [16:34:57.305][tid:000008f8.00000da0][DBG]             Vdisk 1 closed.  Reason = 0, Unregistered = 0
    [16:34:57.618][tid:000008f8.00000da0][DBG]             Vdisk 1 closed.  Reason = 0, Unregistered = 0

    CloudCacheProvider Log (can see error at 16:33:07.477 faid to read lockf file)

    [16:32:21.212][tid:000008f8.00001234][INFO]                 Connected to  \ \filer02\FSLogixProfiles   
    [16:32:21.212][tid:000008f8.00001234][INFO]                 Found File (SMB): \ \filer01\FSLogixProfiles\S-1-5-21-4075742445-2671179031-2475658168-1135_test-s01\RW.vhd
    [16:32:21.212][tid:000008f8.00001234][INFO]                 Successfully detached VHD
    [16:32:21.212][tid:000008f8.00001234][INFO]           ===== End Session:      SMB Cloud Cache Provider
    [16:32:21.212][tid:000008f8.00001234][INFO]                Successfully detached VHD
    [16:32:21.212][tid:000008f8.00001234][INFO]           ===== End Session:     SMB Cloud Cache Provider
    [16:33:07.477][tid:000008f8.00001234][ERROR:00000000]     Failed to read lock file: smbstorage.cpp(809): [WCODE: 0x00000020] Unable to open/create the lock file:  \ \filer01\FSLogixProfiles\S-1-5-21-4075742445-2671179031-2475658168-1135_test-s01\RW.vhd.lock
    [16:34:57.290][tid:000008f8.00000da0][INFO]               Successfully attached  \ \filer01\FSLogixProfiles\S-1-5-21-4075742445-2671179031-2475658168-1135_test-s01\Profile_test-s01.vhd
    [16:34:57.305][tid:000008f8.00000da0][INFO]               Successfully attached  \ \filer02\FSLogixProfiles\S-1-5-21-4075742445-2671179031-2475658168-1135_test-s01\Profile_test-s01.vhd

    If you have any idea, would be much appreciated. Thanx alot.


    Cheers

    Monday, October 7, 2019 5:38 PM
  • I am having this same problem with a Windows 10 2019 LTSC environment.  It happens on both physical desktops and in a Horizon VDI environment.  The issue has existed with the previous three versions of FSLogix (using 2.9.7237.48865 at the moment). 

    The first session connects quickly with RW, however the 2nd, and any subsequent sessions, connect very slowly with a 2-3 minute long delay at the same point as aforementioned.

    It should be noted that when using traditional method (not Cloud Cache) multiple concurrent sessions work fine without delay.  I have tried all the usual suspects of disabling any service not necessary, but to no avail.

    Is this a known issue or is there a fix available?  Thank you.

    Saturday, December 28, 2019 12:22 AM
  • Hallo,

    I have a question about the first time Login after configuring CCD.  We have two Session Hosts (WS 2019), fslogix are installed and configured on both serves . The configurations are as you stated above except that  "ProfileType = 1"- 1st access to profile vhdx in RW mode, 2nd session access in RO mode. Two file servers (SMB) have the same profile container.

    As you mentioned above "What you'd want to do is login on one machine to get the profile setup and created for the first time and then logoff. "  Here about "get the profile setup", could you please apply some more details about this? Is this setup manuell? oder in cmd/ps? Is Logoff after setup a Must?

    I'm glad to see your reply. Thanks.


    • Edited by _LS Tuesday, January 14, 2020 2:55 PM
    Tuesday, January 14, 2020 2:08 PM
  • Yes, CCD does support multisession. to configure this you'll set a few reg keys.
    HKLM\Software\FSLogix\Profiles\Enabled = 1
    HKLM\Software\FSLogix\Profiles\ProfileType = 3
    HKLM\Software\FSLogix\Profiles\ConcurrentUserSessions = 1
    CCDLocations = (see documentation)

    What you'd want to do is login on one machine to get the profile setup and created for the first time and then logoff. .....

    • Edited by _LS Tuesday, January 14, 2020 2:36 PM
    Tuesday, January 14, 2020 2:36 PM
  • I'm having very similar issues and can't get FSLogix Cloud Cache Profiles to work.

    [15:54:54.136][tid:00000ca0.000059d0][ERROR:00000000]                                 Failed to acquire a shared reader lock '\\xa-wms2019-01.domain.local\profiles_ctx$\anyusername_S-1-5-21-2505351160-4269483969-3991436212-4185\Profile_anyusername.VHDX.lock': SMBStorage.cpp(809): [WCODE: 0x00000005] Unable to open/create the lock file: \\xa-wms2019-01.domain.local\profiles_ctx$\anyusername_S-1-5-21-2505351160-4269483969-3991436212-4185\Profile_anyusername.VHDX.lock
    [15:54:54.248][tid:00000ca0.000059d0][ERROR:00000000]                                 Failed to read lock file: SMBStorage.cpp(809): [WCODE: 0x00000005] Unable to open/create the lock file: \\xa-wms2019-01.domain.local\profiles_ctx$\anyusername_S-1-5-21-2505351160-4269483969-3991436212-4185\Profile_anyusername.VHDX.lock
    [15:54:54.350][tid:00000ca0.000059d0][ERROR:00000000]                                 Failed to read lock file: SMBStorage.cpp(809): [WCODE: 0x00000005] Unable to open/create the lock file: \\xa-wms2019-01.domain.local\profiles_ctx$\anyusername_S-1-5-21-2505351160-4269483969-3991436212-4185\Profile_anyusername.VHDX.lock
    [15:54:54.454][tid:00000ca0.000059d0][ERROR:00000000]                                 Failed to read lock file: SMBStorage.cpp(809): [WCODE: 0x00000005] Unable to open/create the lock file: \\xa-wms2019-01.domain.local\profiles_ctx$\anyusername_S-1-5-21-2505351160-4269483969-3991436212-4185\Profile_anyusername.VHDX.lock
    [15:54:54.555][tid:00000ca0.000059d0][ERROR:00000000]                                 Failed to read lock file: SMBStorage.cpp(809): [WCODE: 0x00000005] Unable to open/create the lock file: \\xa-wms2019-01.domain.local\profiles_ctx$\anyusername_S-1-5-21-2505351160-4269483969-3991436212-4185\Profile_anyusername.VHDX.lock
    [15:54:54.655][tid:00000ca0.000059d0][ERROR:00000000]                                 Failed to read lock file: SMBStorage.cpp(809): [WCODE: 0x00000005] Unable to open/create the lock file: \\xa-wms2019-01.domain.local\profiles_ctx$\anyusername_S-1-5-21-2505351160-4269483969-3991436212-4185\Profile_anyusername.VHDX.lock
    [15:54:54.756][tid:00000ca0.000059d0][ERROR:00000000]                                 Lock file read retry count exceeded

    I created a Microsoft ticket today, as this kills my projects.

    Wednesday, January 29, 2020 4:03 PM
  • Hi XenAdmin, were you able to resolve this problem? I am currently facing the exact same problem, same error message. Happened right after I've configured CloudCache for Office container. Before when using single "VHDLocation", no problem.
    Thursday, April 2, 2020 12:05 PM
  • No. MS Support told us to test without Anti Virus installed (ESET), but the problem still exists.

    Although it happens quite rarely, but when it hits, it hits hard.

    Thursday, April 2, 2020 12:11 PM
  • Hi there, 

    just fyi, there is a new public preview release (needs sign up) that apparently addresses many issues (including this one), not yet tested just got to sign up for it, but haven't received download link yet.

    If you want to try it ..

    New Public Preview: FSLogix Apps release 2004 (2.9.7349.30108)

    https://social.msdn.microsoft.com/Forums/windowsserver/en-US/e82cb114-2459-4a99-bcbf-50b7d314b5b9/new-public-preview-fslogix-apps-release-2004-29734930108?forum=FSLogix 

    Thursday, April 2, 2020 12:35 PM
  • Did anyone got an answer from support about this issue ?
    Thursday, October 8, 2020 3:01 PM