locked
After deploying in IIS the UCMA-WCF service I am getting Bugs. RRS feed

  • Question

  • while localy UCMA-WCF service working fine after publishing the service  I am getting error

    1. lf I am calling methods which are referring any dll(Lync dll like Rtc.collaboration dll) , then i am  getting error like "The server encountered an error processing the request.".
     
    2. If I am not referring dll(Lync dll like Rtc dll)  .and calling simple methods to display some string, then it's working.
      
    Both the Point 1 and 2  are working fine while running application locally
     
    In Event viewer: details
    reason:failed to open the explicitly spacified database
    database:msql$RTCLOCAL
    "login failed for user'NTAUTHORITY/NETWORK SERVICE'

     

    that means through servise its invoking rtc dll but that dll is not getting the details from RTCLOCAL.

    rtc dll is connecting to RTCLOCAL database but that time error getting like "login failed for user'NTAUTHORITY/NETWORK SERVICE'

    reason:failed to open the explicitly spacified database

    Saturday, December 3, 2011 12:50 PM

All replies

  • pls help me after publishing its not connecting database.
    Sunday, December 4, 2011 11:48 AM
  • The user account that your WCF service is using  needs to be a member of the RTCComponentUniversalServices group in AD.  If you add the machine account to the group, then the "Network Service" account hosting your WCF service will be a member.

    Oscar Newkerk

    Oscarnew Consulting


    • Edited by Oscarn Sunday, December 4, 2011 8:57 PM Correct group name.
    • Proposed as answer by Kai Strandskov [Msft] Tuesday, December 6, 2011 11:05 PM
    Sunday, December 4, 2011 8:56 PM