none
.NET Framework 3.5 doesn't install. Windows 10.. Error code: 0x800F081F RRS feed

  • Question

  • When I try to enable the .NET Framework from windows features I got this message
    Windows couldn't find required files to complete the requested changes. Make sure you're connected to the internet and try again.

    Error code: 0x800F081F

    (BTW the internet connection is fine, i think the problem may be in the update center)

    I did every thing yet it still not working,

    I already try this:

    1- Installing .net3.5 from the installer and the package 

    2-installing it from the command prompt
    3- installing it from distribuion CD, mounted ISO, or folder Sources\sxs folder copied to hard drive (including using /LimitAccess switch).

    4-from  *Windows features on or off* 

    5- From the group police (then administrator then system then specify settings for opt.. ) I found that *contact windows update dir..* is enabled and ok

    6-No success with DISM method of scanhealth & restorehealth, although these run OK.

    7- many people say that i have to  Uninstall  KB2966826 and KB2966828, then try installing 3.5 from programs and features... but unfortunately I didn't find those updates -I neither found them in update history nor from control panel - 

    the error i found every time is "the system cannot find the file specified error code 0x80070002"

    Can any one helpd please, I really to fix it ASAP.


    • Edited by khashabolla Sunday, January 10, 2016 11:17 AM
    Sunday, January 10, 2016 11:16 AM

All replies

  • Hi khashabolla,

    Thank you for posting in MSDN forum.

    .NET Framework 3.5 is included in Win 10, so you couldn't install it from outside, no matter web installer or standalone installer.

    So, you may first check if the .NET Framework 3.5 is available in the Control Panel on Windows 10 Technical Preview and if available, you may enable it from the Control Panel to install it on the computer. To check if the.NET Framework 3.5 is available in Control Panel and to enable it, please follow these steps:

    a) Press “Windows Logo” + “R” keys on the keyboard.

    b) Type “appwiz.cpl” in the “Run” command box and press “ENTER”.

    c) In the “Programs and Features” window, click on the link “Turn Windows features on or off”.

    d) Check if the “.NET Framework 3.5 (includes .NET 2.0 and 3.0)” option is available in it.

    e) If yes, then enable it and then click on “OK”.

    f) Follow the on-screen instructions to complete the installation and restart the computer, if prompted.

    This will install the .NET Framework 3.5 feature on the computer. There is also another way by which .NET Framework 3.5 gets installed on the computer. This is done by the apps on demand.

    If an app requires the .NET Framework 3.5, but doesn't find that version enabled on your computer, it displays the prompt for installing the .NET Framework 3.5 on demand, either during installation, or when you run the app for the first time after its installation. In this prompt, you can choose the option “Install this feature” to enable the .NET Framework 3.5 on the computer.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Monday, January 11, 2016 9:21 AM
    Moderator
  • Windows10 online update create this folder:
    C:\ESD\Windows\sources\sxs
    There are just one file. (microsoft-windows-netfx3-ondemand-package)
    Take windows 8.1 installation media and copy files from x:\sources\sxs to C:\ESD\Windows\sources\sxs  (1174 files)
    run cmd.exe as administrator
    execute this command
    Dism /online /enable-feature /featurename:NetFx3 /All /LimitAccess /Source:C:\ESD\Windows\sources\sxs
    • Proposed as answer by Harvey J Sunday, August 21, 2016 1:56 PM
    Friday, March 18, 2016 12:03 PM
  • I did everything stated here but when i got to step f) i got the same error code and message (The system cannot find the file specified)... please what do i do!?
    • Proposed as answer by kucharzgotuje Friday, July 13, 2018 11:59 AM
    Friday, August 5, 2016 3:50 PM
  • I had this problem as well on my machine at work. Try doing the following it worked and allowed me to download the .Net Framework 3.5 on my Windows 10 PC :  Go into RegEdit and set the HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU folder.  DoubleClick on UseWUServer(UseWindowsUpdateServer) and change the value to 0.  If the value is already 0 this fix may not work for you.  You may need to restart afterwards.

    If this works for you please mark as answer.

    • Proposed as answer by felipe55 Thursday, January 12, 2017 4:00 PM
    Wednesday, January 4, 2017 4:03 PM
  • This worked perfectly for me!! Thank YOU!!
    Monday, March 20, 2017 3:06 AM
  • Thanks this works for me!!! I had been looking for a resolution over 2 hrs.
    Wednesday, April 19, 2017 5:58 PM
  • This does not work!  I follow theses instructions, pretending I have not tried it a hundred times myself, and the outcome is no different than before.  This is a BIG problem.  I am rolling Windows 10 out to more than a 200 machines and I cannot have these problems. I have tried enabling the .NET 3.5 immediately after installing the image, prior to any other installations, updates, or profile moves; the problem comes up later.  I started removing installed Security updates to see if that would help, it doesn't.  Please help, this is a BIG problem for me and many others. 
    Tuesday, May 2, 2017 2:21 PM
  • Unfortunately, this does not work for me.  I get the same error message.  I downloaded the 3.5 installer and that would not even complete the install for me.  This is not just one machine, this is many. Please, any other ideas you have would be much appreciated. 

    Tuesday, May 2, 2017 2:31 PM
  • This registry change worked for me. Thanks.
    Wednesday, May 10, 2017 2:44 PM
  • It helped. Thanks a lot for the answer
    Tuesday, May 16, 2017 10:38 AM
  • Not sure how this got marked as the correct answer given that the orginal query actually states the the user already tried this approach

    When I try to enable the .NET Framework from windows features I got this message
    Windows couldn't find required files to complete the requested changes. Make sure you're connected to the internet and try again.

    Wednesday, June 7, 2017 3:14 AM
  • This registry edit seemed to help with installing this and some other problems with finding updates, such as with SQL Server Express.  Thanks.
    Wednesday, June 14, 2017 5:53 PM
  • This worked for me, but to reiterate, a restart was indeed required.
    Thursday, June 15, 2017 1:57 PM
  • Yes! Thanks so much, this worked after trying multiple other solutions. Note also that you have to run regedit as administrator or you won't be able to change the value to 0.
    Thursday, June 15, 2017 5:56 PM
  • The registry edit worked for me, thanks!  It did not work until I restarted the computer though.  After restarting, it worked fine! 
    Tuesday, June 20, 2017 11:55 AM
  • DISM /Online /Enable-Feature /FeatureName:NetFx3 /All

    • Proposed as answer by jyatesNZ Friday, March 22, 2019 4:01 AM
    Tuesday, June 20, 2017 3:07 PM
  • Registry edit worked for me. Thx!  You could also tell the person or dept. who manages the internal WSUS machine to approve the dot Net 3.5 installer package.  That would most likely work as well once the source files are downloaded to WSUS.




    • Edited by AStutso Friday, July 7, 2017 3:57 PM
    Friday, July 7, 2017 3:54 PM
  • Thank you. It saved my day!
    Friday, July 7, 2017 4:39 PM
  • This worked great for me.  Thanks.
    Monday, July 10, 2017 7:27 PM
  • Regedit and reboot. Spot on thanks.
    Wednesday, July 12, 2017 8:51 PM
  • This one worked for me . Thankyoi
    Tuesday, July 18, 2017 8:27 PM
  • Worked for me here!!!

    Windows 10 Pro, fresh lappy install...

    Thanks you!!!

    Wednesday, July 26, 2017 8:11 PM
  • Removing the workstation from the domain also makes allows the feature to install. It seems that a group policy is configuring a WSUS server that is either down or not working. Fixing the WSUS config would also like fix the problem. 
    Wednesday, August 23, 2017 11:40 PM
  • Thx for this, fixed it for me too!
    Thursday, August 31, 2017 7:01 PM
  • Many thanks for this fix, I had been looking for some time. Regards,
    Monday, September 4, 2017 2:11 PM
  • This worked for me. Thanks.


    Monday, September 11, 2017 8:14 AM
  • Windows10 online update create this folder:
    C:\ESD\Windows\sources\sxs
    There are just one file. (microsoft-windows-netfx3-ondemand-package)
    Take windows 8.1 installation media and copy files from x:\sources\sxs to C:\ESD\Windows\sources\sxs  (1174 files)
    run cmd.exe as administrator
    execute this command
    Dism /online /enable-feature /featurename:NetFx3 /All /LimitAccess /Source:C:\ESD\Windows\sources\sxs

    The dism command has worked for me on several machines.  However, what I did was copy the Windows 10 .iso file to the hdd and them mount it.  Then, I use the drive letter of the mounted .iso instead of C:\ESD in the dism command.
    Monday, October 2, 2017 3:53 PM
  • THIS is the fix that worked! Thanks, Paul Bill!
    • Edited by TexasGary Tuesday, October 10, 2017 1:53 PM
    Tuesday, October 10, 2017 1:52 PM
  • Thank you Paul! This just helped me. 
    Thursday, October 12, 2017 4:16 PM
  • Did you follow through on this, ie contacting WSUS admin and asking them to approve the 3.5 updates? I will trying this and post back if it works as the workaround is a poor solution in my opinion. If the machine is making use of WSUS no one should be circumventing that unless all else fails and your post was the first one I saw that had this idea which I believe should be the recommended and approved solution (if it works that is).

    Thursday, October 19, 2017 12:49 PM
  • This worked for me.

    ITG

    Thursday, October 19, 2017 8:00 PM
  • Thank you! It worked.
    Friday, October 20, 2017 6:48 AM
  • is not working.i don't see where the install this feature is
    Wednesday, October 25, 2017 9:29 PM
  • Perfect, it works like a charm. Just remember to run Regedit as an administrator and do a restart when done.
    Friday, October 27, 2017 7:01 AM
  • This worked perfectly for me also after a couple of hours of internet search. Thanks for posting this , as already mentioned ,Just remember to restart the PC..

    Jenki

    Wednesday, November 1, 2017 2:16 PM
  • This worked for me! Thank you!
    Thursday, November 2, 2017 4:55 PM
  • Office Windows 10, version 1703 (OS Build 15063.674)

    I have tried to install by using either dotnetfx35Setup.exe or dotnetfx35.exe(full package) without success. 

    Thanks for your registry solution which did resolve this issue. The office PC was <g class="gr_ gr_419 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del" data-gr-id="419" id="419">setup</g> to receive the update from WSUS server which I assume the value "1" to force PC only get <g class="gr_ gr_578 gr-alert gr_gramm gr_inline_cards gr_run_anim Grammar only-ins doubleReplace replaceWithoutSep" data-gr-id="578" id="578">update</g> from internal WSUS. 

    After change value to "0", it works. 

    Thanks,


    JohnnyW2012

    Friday, November 3, 2017 7:41 PM
  • This worked for me!

    Thanks!

    Monday, November 6, 2017 10:32 PM
  • works after using regedit as administrator
    Friday, November 24, 2017 12:58 AM
  • Thank you very much, Harvey,

    That was the winning hint after testing douzend of other hints. The only I did change was I did use the Windows 10 installation media.

    Wolfgang
    Friday, November 24, 2017 6:26 AM
  • Hi khashabolla,

    Thank you for posting in MSDN forum.

    .NET Framework 3.5 is included in Win 10, so you couldn't install it from outside, no matter web installer or standalone installer.

    So, you may first check if the .NET Framework 3.5 is available in the Control Panel on Windows 10 Technical Preview and if available, you may enable it from the Control Panel to install it on the computer. To check if the.NET Framework 3.5 is available in Control Panel and to enable it, please follow these steps:

    a) Press “Windows Logo” + “R” keys on the keyboard.

    b) Type “appwiz.cpl” in the “Run” command box and press “ENTER”.

    c) In the “Programs and Features” window, click on the link “Turn Windows features on or off”.

    d) Check if the “.NET Framework 3.5 (includes .NET 2.0 and 3.0)” option is available in it.

    e) If yes, then enable it and then click on “OK”.

    f) Follow the on-screen instructions to complete the installation and restart the computer, if prompted.

    This will install the .NET Framework 3.5 feature on the computer. There is also another way by which .NET Framework 3.5 gets installed on the computer. This is done by the apps on demand.

    If an app requires the .NET Framework 3.5, but doesn't find that version enabled on your computer, it displays the prompt for installing the .NET Framework 3.5 on demand, either during installation, or when you run the app for the first time after its installation. In this prompt, you can choose the option “Install this feature” to enable the .NET Framework 3.5 on the computer.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Another example of someone under the Microsoft moniker who should not be allowed to mark posts as answers...

    This is not the fix to the poster's issue.

    The regedit answer is the solution (albeit a bit of a kluge).  That should be marked as the answer.

    Wednesday, November 29, 2017 10:57 AM
  • doesn't work for me

    there's nothing like that in my Win 10 registry :(

    Thursday, December 14, 2017 4:38 PM
  • Dear Microsoft.

    Have you lost your mind? This issue is 1 year old and it still reproducible. Installing one of your products to another your product requires 1 hour research and hacking registry. 

    This is really charming, one "Moderator" (Jiayi Li) wrote senseless and helpless post and another Moderator (Wen Xu) marked it as answer. I hope that you will get bonus for your great hard work

    And finally, thanks Paul Bill for answer that helped me. Paul's post has 45 votes, but it isn't marked as an answer... Probably because he is not a moderator.

    Sunday, December 17, 2017 2:47 PM
  • Which registry change? I searched and searched, found nothing except repetitions that "it works". The DSIM command does not work either, it complains with error 50.
    Saturday, January 6, 2018 5:00 PM
  • Hi,

    In Windows 10  the issue is reolved if you run windows update and let it complete and restart when required. After restart the required update for installing .netfx3 is able to complete itself. (internet required)

    Tried all below solutions but failed. There is possibility that when windows update restart is pending then it won't get any more updates till it is completed and restarted.

    Monday, January 8, 2018 5:08 AM
  • Hello,

    I am hoping you can please help me as I have been trying to install net 3.5 for many days and many many hour spent. This is the first instance I have seen this fix yet the directory does not exist for me. in regedit as admin I can only find HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows and \WindowsUpdate is not there. I also can find nothing with AU. Also the error I have when trying to install 3.5 from my mounted drive is this:

    Error: 50

    The operation is complete but NetFx3 feature was not enabled.


    The DISM log file can be found at C:\Windows\Logs\DISM\dism.log

    After this checking my log file I will see this error :

    2018-01-11 10:45:38, Error                 DISM   DISM Package Manager: PID=3820 TID=3964 Parent features must be enabled before this feature can be enabled. "NetFx3" - CPackageManagerCLIHandler::Private_ProcessFeatureChange
    2018-01-11 10:45:38, Error                 DISM   DISM Package Manager: PID=3820 TID=3964 One or more features could not be enabled. - CPackageManagerCLIHandler::Private_ProcessFeatureChange(hr:0x80070032)
    2018-01-11 10:45:38, Error                 DISM   DISM Package Manager: PID=3820 TID=3964 Failed while processing command enable-feature. - CPackageManagerCLIHandler::ExecuteCmdLine(hr:0x80070032)

    So something about Parent features must be enabled. Any help would really be appreciated, thank you

    Thursday, January 11, 2018 3:52 PM
  • same as you. i tried two given solutions like you, and now, every time I'm booting up my laptop, windows requires me restart my laptop to complete installing .NET FRAMEWORK 3.5.

    Damn it!


    • Edited by mywill102 Friday, January 12, 2018 4:52 AM
    Friday, January 12, 2018 4:50 AM
  • out of the 100s of things i've tried this was the only one that worked for us, thanks Paul.  One workstation fixed 100 to go, lets hope this fixes them all! thanks MS. 
    Thursday, January 18, 2018 6:21 PM
  •  in regedit as admin I can only find HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows and \WindowsUpdate is not there. I also can find nothing with AU. Also the error I have when trying to install 3.5 from my mounted drive is this:

    Error: 50

    The operation is complete but NetFx3 feature was not enabled.


    The DISM log file can be found at C:\Windows\Logs\DISM\dism.log

    After this checking my log file I will see this error :

      DISM   DISM Package Manager: PID=3820 TID=3964 Parent features must be enabled before this feature can be enabled. "NetFx3" [....]

    I have the exactly same problem here (no only me). Dear Microsoft, please help.

    Sunday, January 21, 2018 12:10 AM
  • Hello,

    I am hoping you can please help me as I have been trying to install net 3.5 for many days and many many hour spent. This is the first instance I have seen this fix yet the directory does not exist for me. in regedit as admin I can only find HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows and \WindowsUpdate is not there. I also can find nothing with AU. Also the error I have when trying to install 3.5 from my mounted drive is this:

    Error: 50

    The operation is complete but NetFx3 feature was not enabled.


    The DISM log file can be found at C:\Windows\Logs\DISM\dism.log

    After this checking my log file I will see this error :

    2018-01-11 10:45:38, Error                 DISM   DISM Package Manager: PID=3820 TID=3964 Parent features must be enabled before this feature can be enabled. "NetFx3" - CPackageManagerCLIHandler::Private_ProcessFeatureChange
    2018-01-11 10:45:38, Error                 DISM   DISM Package Manager: PID=3820 TID=3964 One or more features could not be enabled. - CPackageManagerCLIHandler::Private_ProcessFeatureChange(hr:0x80070032)
    2018-01-11 10:45:38, Error                 DISM   DISM Package Manager: PID=3820 TID=3964 Failed while processing command enable-feature. - CPackageManagerCLIHandler::ExecuteCmdLine(hr:0x80070032)

    So something about Parent features must be enabled. Any help would really be appreciated, thank you


    I have just the same problem.
    Tuesday, January 23, 2018 8:03 AM
  • Nope , not a solution for me. Tried all methods suggested after a day on forums. Inlcuding reg mods still no joy I get the same as other users when using dsim command which is error 50 Basically it appears to have installed 3.5 fine as it is readily available for selection under windows features. However if i select it , install process seems to go fine and asks for restart. doesnt matter how many times i try this and restart it is still not enabled under windows features. Please someone help with this . (recently fresh installed windows 10pro 64 anniversary pack which started this problem. previous install of windows 10 pro 64 wasnt anniversary and 3.5 worked fine from the start) something to do with the 4.6 in anniversary taking over and disabling 3.5 for good ???????????????
    Thursday, January 25, 2018 11:48 PM
  • This should not be marked as the answer to the issue the OP had.

    More worrisome is that this is still an issue on a fresh fully updated Windows 10 install. If this is working as designed, which it may be, we could at least be provided with a meaningful error message.

    Friday, February 2, 2018 5:29 PM
  • Winner winner chicken dinner!
    Friday, February 2, 2018 8:58 PM
  • Say,  I was int he same boat where none of the above suggestions worked. However, I ran across a fix in another post that worked for me.  Essentially, reboot into safe mode (repair mode, I guess) and install it from there.

    -Restart from power button in windows with 'shift' key held down. 

    -Go to troubleshoot, then advanced options

    -startup repair

    -log in to windows

    -go to Control panel->programs and features->Turn Windows features on (with your sexy moves) and off

    -Check the box by the install .net framework 3.5 

    -watch it finally work (hopefully!)

    restart and it should finally stay checked on.

    • Proposed as answer by cuculcina Monday, February 12, 2018 1:26 PM
    Thursday, February 8, 2018 9:28 PM
  • This is the solution for error 50, posted from PapaJon_s1


    • Edited by cuculcina Monday, February 12, 2018 1:26 PM
    Monday, February 12, 2018 1:25 PM
  • Works for me too! :) in Windows 10 1709 with error 50 in DISM.
    SOLUTION: Restart in reapir mode. Check the box for install .net framework 3.5 and finally works!
    Sunday, February 18, 2018 12:59 PM
  • After trying many different solutions, this was the one that did the trick. Thank you!
    Tuesday, February 27, 2018 9:20 AM
  • This worked for me as well. Thank you!
    Thursday, March 8, 2018 2:37 PM
  • After many attempts and hours of researching - what worked for me to fix the problem.

    Problem: Trying to Add Windows Feature - .NET Framework 3.5 (includes .NET 2.0 and 3.0). After attempting to use the Dism command line within normal Windows use - kept getting the "Error 50" message and failure to install the above. My system is Windows 10 Pro 64-bit; the original Windows 10 install disk inserted into my DVD drive ("E").

    Solution: Reboot system - holding down the "shift" key right after or when you see your Bios screen - you need to be able to have the option - "To specify an advanced option for this choice, press F8." [note - your screen should also be highlighting that you are choosing Windows 10 to start your system]

    Next step: choose to start your system with "Safe Mode with Command Prompt". Note - even on a fast system you need to wait a minute or 2 until the c:\windows \system32> prompt appears [I have an AMD Ryzen 1700x with a Samsung 960EVO SSD drive plus 32GB high speed RAM and it takes a minute or so to load]

    Next step: [you need to have a DOS window with c:\windows\system32> showing or the next command won't work.

    Type in the Dism command (my DVD drive is "E"

    dism /online /enable-feature /featurename:NetFx3 /All /Source:e:\sources\sxs\ /LimitAccess

    Your system should reply with "Deployment Image Servicing and Management tool  - Version: 10.0.16299.15

    My system stated also - Image Version: 10.0.16299.214

    Then processed 100.0% - enabling feature(s) and stated "The operation completed successfully."

    Final step: Reboot and verify the installation of ".NET Framework 3.5" by checking in through the Control Panel of Windows.

    Hope this help others.

    Really Micro$oft - what a royal pain in the A... We really don't need this kind of stuff happening. You guys need to check your work a lot better. This Creators update has been a nightmare!


    • Edited by Pedro99999 Thursday, March 8, 2018 5:40 PM
    • Proposed as answer by Pedro99999 Thursday, March 8, 2018 6:05 PM
    Thursday, March 8, 2018 4:58 PM
  • I had this problem as well on my machine at work. Try doing the following it worked and allowed me to download the .Net Framework 3.5 on my Windows 10 PC :  Go into RegEdit and set the HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU folder.  DoubleClick on UseWUServer(UseWindowsUpdateServer) and change the value to 0.  If the value is already 0 this fix may not work for you.  You may need to restart afterwards.

    If this works for you please mark as answer.

    Worked for me, and no restart required.

    Thank you.

    • Proposed as answer by ESSENCE56 Tuesday, March 20, 2018 6:36 PM
    Wednesday, March 14, 2018 9:43 AM
  • PapaJon - After many many tries this did the trick for me. Thx 
    Sunday, March 18, 2018 2:56 AM
  • Thank you for this tip. It has worked

    Nice day

    Monday, March 19, 2018 10:40 AM
  • PERFECT!!!!!!

    Thank You. This worked for me. It makes sense too.

    Tuesday, March 20, 2018 6:37 PM
  • This is of no help to me the \AU folder for me I have a folder named UX in it is is another folder named settings
    Thursday, March 22, 2018 5:24 PM
  • this seems to be the ultimate solution.

    calling the command line  from "Safe Mode with Command Prompt"

    dism /online /enable-feature /featurename:NetFx3 /All /Source:e:\sources\sxs\ /LimitAccess

    To make it easier  I copied the cab-file from \sources\sxs   to C:\  and saved the command line

    dism /online /enable-feature /featurename:NetFx3 /All /Source:C:\ /LimitAccess

    to a batch-file  net35.bat  also at C:\

    Sunday, March 25, 2018 1:08 AM
  • worked like a charm for me !!! Tks for the tip man ;)
    Monday, March 26, 2018 1:33 PM
  • I had this problem as well on my machine at work. Try doing the following it worked and allowed me to download the .Net Framework 3.5 on my Windows 10 PC :  Go into RegEdit and set the HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU folder.  DoubleClick on UseWUServer(UseWindowsUpdateServer) and change the value to 0.  If the value is already 0 this fix may not work for you.  You may need to restart afterwards.

    If this works for you please mark as answer.

    Thanks a ton, most helpful answer on this by far.
    Tuesday, April 3, 2018 2:43 PM
  • Thank God this regedit worked for me.

    Thank you guys

    Wednesday, April 4, 2018 2:12 PM
  • I love you

    John

    Wednesday, April 4, 2018 6:29 PM
  •  can't find any UseWUServer.There are only Default and NoAutoReboot.Please help!

    • Edited by Soumya1729 Friday, April 6, 2018 6:58 AM
    Friday, April 6, 2018 6:58 AM
  • i cant find the windows update folder are you sure its the right directory !?

    Saturday, April 7, 2018 10:21 AM
  • 2 hours ? i looking for almost a year and a half man youre lucky mate
    Saturday, April 7, 2018 10:22 AM
  • In order to resolve this issue, you need the installation media.

    Must be an Administrator to do this

    Insert the Installation Media

    Copy the file from <CDROM>\Sources\SXS to C:\Temp

    Launch an elevated command prompt

    execute this command
    Dism /online /enable-feature /featurename:NetFx3 /All /LimitAccess /Source:C:\Temp\sources\sxs

    Sunday, April 8, 2018 7:27 PM
  • I had the same problem, the HKEY/LOCALMACHINE.../AU folder does not exist in the RegEdit folder on my computer. What worked for me:

    1. Enable the WindowsUpdate service via 'computer management' --> 'services and applications' --> double click 'services' and search for 'windows update' service --> enable

    2. Once the windows update service is enabled go to 'control panel' --> 'program and features' -->'turn windows features on or off' --> check the '.net framework 3.5' box and click OK

    3. Windows will now download the necessary files (takes about 5 to 10min)

    Hope this helps!

    • Proposed as answer by staples66 Sunday, April 22, 2018 3:56 PM
    Monday, April 9, 2018 2:06 PM
  • This worked for me.

    Make sure Computer is connected to Internet.

    Go to services.msc

    Scroll down to Windows Update

    Right Click, then Properties

    Make sure Start Type is Automatic, then Start the service by clicking on Start Button in same dialog box

    Now Go to Control Panel > Programs > Programs and Features > Turn Windows features on or off

    In Windows Features Check all boxes for .NET Framework 3.5 (includes .NET 2.0 and 3.0), then OK

    Windows should try to connect on internet and install this .NET Framework 3.5

    Monday, April 30, 2018 9:33 PM
  • Windows10 online update create this folder:
    C:\ESD\Windows\sources\sxs
    There are just one file. (microsoft-windows-netfx3-ondemand-package)
    Take windows 8.1 installation media and copy files from x:\sources\sxs to C:\ESD\Windows\sources\sxs  (1174 files)
    run cmd.exe as administrator
    execute this command
    Dism /online /enable-feature /featurename:NetFx3 /All /LimitAccess /Source:C:\ESD\Windows\sources\sxs

    This solution worked for me. OS Build: 14393.1944

    I copied the microsoft-windows-netfx3-ondemand-package.cab from my Windows 10 installer.



    Wednesday, May 2, 2018 3:11 AM
  • Hey Cuculcina, thank you, your solution worked for me, I was going crazy, after trying dozens of methods,

    cheers, God bless you all..........

    Friday, May 4, 2018 12:47 AM
  • This was my fix, I really thought I was losing it since 3 of 20 of our systems did not need special tweaks.

    Thank you Paul


    ChazBo Jr.

    Wednesday, May 9, 2018 5:31 PM
  • I had the same problem with the computer in my Display Name but this fixed it thanks so much the real answer form Microsoft above this says to try the same thing the creator had problems with LOL.
    Wednesday, May 9, 2018 10:35 PM
  • Say,  I was int he same boat where none of the above suggestions worked. However, I ran across a fix in another post that worked for me.  Essentially, reboot into safe mode (repair mode, I guess) and install it from there.

    -Restart from power button in windows with 'shift' key held down. 

    -Go to troubleshoot, then advanced options

    -startup repair

    -log in to windows

    -go to Control panel->programs and features->Turn Windows features on (with your sexy moves) and off

    -Check the box by the install .net framework 3.5 

    -watch it finally work (hopefully!)

    restart and it should finally stay checked on.

    WOW! I never knew Startup Repair actually did anything besides annoying people!
    This worked like a charm, instead of going direcctly to pop-up asking to reboot, it actually did something for a few seconds, then it said it was activated, not even needed to reboot.

    Thank you very much, whoever you are.

    Saturday, May 12, 2018 2:52 AM
  • I tried this and No luck! Although my registry value was set to 1 and I changed it to 0.

    Computer\HKEY_Machine\Software\Policies\Microsoft\Windows\WindowsUpdate\AU  change the value of USeWUServer to 0

    Windows 10 Pro.


    Tuesday, May 15, 2018 4:49 PM
  • I tried all of the above mentioned methods, unfortunately without any luck

    I am getting 0x8E5E03FA error

    I searched it and I think its connected to WU service, but service is working.

    getting same error when trying offline with DISM , safe mode also not working, (Microsoft conveniently hid this feature even more by the way in version 1803)

    My system:

    OS: Windows 10 pro version 1803 build 17134.48

    Mainboard: Asus X99 Sabertooth,

    CPU: Intel i7 6800K

    GPU: Nvidia GTX 1070

    RAM 4×4 Gb Corsair Vengence LPX

    OS is loaded Son Samsung 850 EVO SSD (120Gb)

     






    Tuesday, May 15, 2018 11:13 PM
  • You are the man! worked great been trying to fix for some time.

    Monday, May 21, 2018 10:57 PM
  • Thank you , it's works for me .

    Good day !

    Tuesday, May 29, 2018 1:03 PM
  • Worked perfectly ... thank you!
    Monday, June 11, 2018 3:45 PM
  • I had this problem as well on my machine at work. Try doing the following it worked and allowed me to download the .Net Framework 3.5 on my Windows 10 PC :  Go into RegEdit and set the HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU folder.  DoubleClick on UseWUServer(UseWindowsUpdateServer) and change the value to 0.  If the value is already 0 this fix may not work for you.  You may need to restart afterwards.

    If this works for you please mark as answer.

    Thanks a ton, most helpful answer on this by far.
    The registry worked for me. I had an issue with a laptop at work! Thank you! 
    Tuesday, June 12, 2018 3:34 PM
  • I had this problem as well on my machine at work. Try doing the following it worked and allowed me to download the .Net Framework 3.5 on my Windows 10 PC :  Go into RegEdit and set the HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU folder.  DoubleClick on UseWUServer(UseWindowsUpdateServer) and change the value to 0.  If the value is already 0 this fix may not work for you.  You may need to restart afterwards.

    If this works for you please mark as answer.

    Can this please be marked as the real answer?
    The marked answer will give the same error as trying to install from Win Update. This Reg fix allows the download through Windows Features to complete.
    Tuesday, June 19, 2018 7:54 AM
  • i dont have the registry value "WindowsUpdate\AU" under HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows.

    i have also tried every other suggestion in this blog but nothing works for me.

    i also get the error i found every time is "the system cannot find the file specified error code 0x80070002"

    any ideas please?


    Wednesday, June 20, 2018 1:26 AM
  • This is it.
    Friday, June 29, 2018 6:34 PM
  • This did not work for me. I get the error code: 0x800F0954.

    I also have tried everything listed in the initial question. This is a fresh install of Windows 10.

    Thursday, July 5, 2018 2:47 PM
  • This worked. I had to run the DISM.exe from the command line to install .NET 3.5

    Thursday, July 5, 2018 2:51 PM
  • Worked for me after doing all the same steps as the original poster. Thank you!
    Thursday, July 5, 2018 6:22 PM
  • https://www.microsoft.com/en-gb/download/details.aspx?id=25150
    Tuesday, July 10, 2018 4:30 PM
  • The Full Package installer should work:

    https://www.microsoft.com/en-gb/download/details.aspx?id=25150

    Tuesday, July 10, 2018 4:30 PM
  • None of the above didn't worked for me, but this did: 

    Downlad Windows 10 upgrade
    https://download.microsoft.com/download/E/0/A/E0A1E6A8-26F8-4399-9C22-27419BC37B51/Windows10Upgrade9252.exe

    Wait like forever

    Try once again to enable dotNet Framework 3.5 in System Function whatever

    Should work. 
    Friday, July 13, 2018 12:01 PM
  • This finally worked for me!  All of the other options failed.  The registry key was not on my system.  Rebooting to safe mode with command line is the ONLY thing that worked.  I spent hours on this... thank you!
    Wednesday, July 18, 2018 3:42 PM
  • I tried to do this RegEdit fix but I don't have a WindowsUpdate or AU folder. Why would I be missing those?

    Thursday, July 19, 2018 12:53 AM
  • This may or may not fix the error for others, but it worked on mine.

    From the following 2 webpages I was able to clarify the Microsoft instructions on the first webpage for fixing the 0x800F081F error. It would be nice if Microsoft would clarify the first webpage since it is linked in the 0x800F081F Error window in Windows 10.

    https://support.microsoft.com/en-us/help/2734782/net-framework-3-5-installation-error-0x800f0906-0x800f081f-0x800f0907

    https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-8.1-and-8/hh825020(v=win.10)

    Resolution for Windows 10
    Error code 0x800F0906, 0x800F081F, or 0x800F0907

    To fix the error codes for Windows 10, follow these steps:

    1. Download the Windows Media Creation tool, and create an ISO image locally, or create an image for the version of Windows that you have installed.

    2. Open the group policy editor. For example, on a computer that is running Windows 10, from the start screen, type Edit Group Policy, and then select Edit Group Policy to open the Group Policy Editor.

    3. Click Computer Configuration, click Administrative Templates, click System, and then double-click the Specify settings for optional component installation and component repair setting.

    Also follow these steps:

    1. Mount the ISO image that's created in step 1 above.

    2. In the window opened in step 3 above, select Enabled, and point the "Alternate source file path" to the ISO X:\sources\sxs folder from the mounted ISO.   <-- "X:" is your mounted drive letter for the ISO

    3. Run the gpupdate /force from the command line.    <-- I ran this step as Admin (Admin may not be needed)

    4. Now add the .Net framework feature.

    I didn't need to restart.  Hope this works for people who couldn't get the methods above to work.

    • Edited by RFguy Thursday, July 19, 2018 3:35 PM
    • Proposed as answer by Einherj Tuesday, April 9, 2019 7:19 PM
    Thursday, July 19, 2018 3:29 PM
  • This may or may not fix the error for others, but it worked on mine.

    From the following 2 webpages I was able to clarify the Microsoft instructions on the first webpage for fixing the 0x800F081F error. It would be nice if Microsoft would clarify the first webpage since it is linked in the 0x800F081F Error window in Windows 10.

    https://support.microsoft.com/en-us/help/2734782/net-framework-3-5-installation-error-0x800f0906-0x800f081f-0x800f0907

    https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-8.1-and-8/hh825020(v=win.10)

    Resolution for Windows 10
    Error code 0x800F0906, 0x800F081F, or 0x800F0907

    To fix the error codes for Windows 10, follow these steps:

    1. Download the Windows Media Creation tool, and create an ISO image locally, or create an image for the version of Windows that you have installed.

    2. Open the group policy editor. For example, on a computer that is running Windows 10, from the start screen, type Edit Group Policy, and then select Edit Group Policy to open the Group Policy Editor.

    3. Click Computer Configuration, click Administrative Templates, click System, and then double-click the Specify settings for optional component installation and component repair setting.

    Also follow these steps:

    1. Mount the ISO image that's created in step 1 above.

    2. In the window opened in step 3 above, select Enabled, and point the "Alternate source file path" to the ISO X:\sources\sxs folder from the mounted ISO.   <-- "X:" is your mounted drive letter for the ISO

    3. Run the gpupdate /force from the command line.    <-- I ran this step as Admin (Admin may not be needed)

    4. Now add the .Net framework feature.

    I didn't need to restart.  Hope this works for people who couldn't get the methods above to work.

    This is the only thing that worked for me on Windows 10, SurfacePro 4.
    Friday, July 20, 2018 5:00 PM
  • it is hellps! Thank you!
    Friday, July 20, 2018 5:10 PM
  • Alexander Nikolaev VI's solution of running Dism /online /enable-feature /featurename:NetFx3 /All /LimitAccess /Source:C:\ESD\Windows\sources\sxs on an admin command prompt worked for me. Thanks Alex.
    Tuesday, July 24, 2018 7:19 PM
  • I actually signed in to say thank you as this was driving me up the wall and your solution was what fixed my issue
    Friday, July 27, 2018 11:15 AM
  • This worked for me. Thank you very much :)

    Monday, July 30, 2018 6:39 PM
  • I had this problem as well on my machine at work. Try doing the following it worked and allowed me to download the .Net Framework 3.5 on my Windows 10 PC :  Go into RegEdit and set the HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU folder.  DoubleClick on UseWUServer(UseWindowsUpdateServer) and change the value to 0.  If the value is already 0 this fix may not work for you.  You may need to restart afterwards.

    If this works for you please mark as answer.

    Worked 100% for me thanks Paul
    Tuesday, July 31, 2018 12:12 PM
  • This works for me. I have a WIndows 10 Enterprise running as VMware workstation host and couple WIndows 10 Enterprise image running as VMware VM. So far, this only happened with my WIn10 host machine. ALl Win10 VMs don't have this issue. Strange!
    Friday, August 3, 2018 4:32 PM
  • Windows 10, 10.0.17134 Build 17134, the path was Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PolicyManager\default\Update\AllowUpdateService

    Change "Value" to 0

    Tuesday, August 7, 2018 4:35 PM
  • Tried all the options from this post, this was the one that worked for me. Had to delete the last two folders of the path.

    I inserted the Windows 10 Pro Disc and copied the only file inside this directory:

    <CDROM>\Sources\SXS

    into this directory:

    C:\Temp

    Then launched command prompt as admin and pasted this:

    Dism /online /enable-feature /featurename:NetFx3 /All /LimitAccess /Source:C:\Temp

    There was a percentage of the progress, then finally ended up at 100% and saying that it completed successfully.

    Thanks all for the help.

    Sunday, August 19, 2018 8:25 AM
  • In my case, it was a corrupted installation of "Microsoft Visual C++ 2017 Redistributable (x64)".

    I went to Control Panel -> Programs and Features -> Uninstall or change a program -> Right clicked "Microsoft Visual C++ 2017 Redistributable (x64)" and uninstall.

    When the window appears click repair and wait for the operation to complete then reboot. After that everything worked fine :)

    Wednesday, August 22, 2018 12:51 PM
  • Worked for me thanks. You should get an interview for Microsoft ;)
    Monday, September 10, 2018 12:58 AM
  • Superb! FYI: repair stated that it could not repair the system, however, after returning to program and features, it actually worked. Thanks!!!
    Monday, September 17, 2018 6:39 PM
  • I tried this for installation of .Net framework 3.5  but getting following error:

    The changes couldn't be completed. Please reboot your system and try again. Error code 0x800F0950

    Tuesday, September 18, 2018 6:52 AM
  • This worked perfect!!  Thank You!!

    Should I change the value back to 1 ??

    Thanks Again!!!

    Wednesday, September 19, 2018 3:17 PM
  • This worked form me also!  Thank you!
    Thursday, September 27, 2018 11:45 PM
  • Brilliant. just exporting the file in the location that that file is copied (you don't have to extract all of it)

    Wednesday, October 10, 2018 3:53 PM
  • GOD BLESS YOU! IT WORKED! I was in dispire after trying all Microsoft recommended things. Yours HELPED! THANK YOU!!!
    Saturday, October 13, 2018 2:13 PM
  • In Given Directory after RegEdit there is no windows Update option in \windows Directory . 
    Suggest me some thing so that it work 
    Saturday, October 13, 2018 9:42 PM
  • Thank you. This solved the problem
    Monday, October 15, 2018 9:06 AM
  • It is a loop of the problem.

    Best Regards Ari

    Sunday, November 4, 2018 10:30 PM
  • that path is unfortunately unavailable on my system.

    Best Regards Ari

    Sunday, November 4, 2018 10:36 PM
  • Thank you very much this also worked for me. 



    • Proposed as answer by koreli Wednesday, November 7, 2018 6:46 AM
    • Edited by koreli Wednesday, November 7, 2018 6:47 AM
    Wednesday, November 7, 2018 6:43 AM
  • I tried .net repair, online installers. Must use/download the latest iso (1803) and DISM command with my Windows 10.0.17134.345 on Lenovo T480

    Dism /online /enable-feature /featurename:NetFX3 /All /Source:D:\sources\sxs

    • Proposed as answer by JonHalseth Friday, November 9, 2018 4:41 PM
    Friday, November 9, 2018 4:41 PM
  • Changing the registry entry to 0 worked for me.  Our environment uses WSUS and the failure was telling me that it could not find the files using WSUS. After changing the registry, I rebooted and retried checking the box to allow MS to download the files. it was able to go out and get the .net files. 

    William McConnell

    Thursday, November 15, 2018 5:11 PM
  • I had this problem as well on my machine at work. Try doing the following it worked and allowed me to download the .Net Framework 3.5 on my Windows 10 PC :  Go into RegEdit and set the HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU folder.  DoubleClick on UseWUServer(UseWindowsUpdateServer) and change the value to 0.  If the value is already 0 this fix may not work for you.  You may need to restart afterwards.

    If this works for you please mark as answer.

    This fixed it for me. I can't believe I had to do this on my brand new Surface Pro. This was an issue almost TWO  YEARS AGO, and I still had to find this registry hack on a forum to fix it? Get it together MS. Seriously. 

    Tuesday, November 27, 2018 2:36 AM
  • its worked perfectly for me!!  thank you.
    Wednesday, November 28, 2018 12:44 PM
  • Thank you.  Removing from the domain, restarting, deleted the registry entry.  I was then able to go to the control panel and turn Windows features on/off for .NET 2.0 and 3.5.
    Friday, December 7, 2018 4:58 AM
  • works perfectly thanks
    Thursday, December 13, 2018 3:04 PM
  • Great. It's working fine. Thanks for your support and sharing knowledge.
    Friday, December 21, 2018 6:23 AM
  • Thank you very Much. This helped me after I've struggled for days.
    Sunday, December 30, 2018 7:16 AM
  • It worked! Thanks for your contribution to the community.
    Monday, January 7, 2019 2:44 AM
  • This saved me a ton of time and frustration.  Thanks!
    Tuesday, January 8, 2019 5:02 PM
  • This worked.  Reboot was needed.  Thank you!!! 
    Wednesday, January 9, 2019 4:47 PM
  • MVP - Hello from 2019 - Thanks for the save. 
    Wednesday, January 16, 2019 11:15 PM
  • Ironically, 2019 here, he didn't specify where this actually works, and if you still a full installer (like I did at first) it doesn't actually work - instead you need to install it through the control panel -> windows and features. 

    Not exactly sure why that worked, but when none of the installers work, I tried that, and well, it worked. 

    Wednesday, January 16, 2019 11:23 PM
  • This worked for me. Thanks
    Thursday, January 17, 2019 7:23 PM
  • Bravo!  So SIMPLE it was painful, but thank you so much!...
    Tuesday, February 19, 2019 7:11 PM
  • This worked for me!

    Thanks!


    Saturday, February 23, 2019 7:03 PM
  • Thank you!

    Worked for me.

    Monday, February 25, 2019 2:50 PM
  • Thank you Paul!  Life saver on this fix...
    Tuesday, February 26, 2019 12:46 AM
  • Close! and thank you for the clue

    Set the reg key above and restart Windows update Service

    Tuesday, February 26, 2019 11:58 PM
  • Thanks this worked for me too with the Microsoft Windows Server 2019 Standard. it was nightmare as I wasted time one after the other and finally hit the jackpot. Thanks @jkbarr30
    Friday, March 8, 2019 12:48 AM
  • Very useful
    Thursday, March 28, 2019 9:57 AM
  • I wish I could vote 1000 times for Paul Bill's answer.  Thanks so much.

    • Edited by lunarquaker Friday, March 29, 2019 8:49 PM clarify whose answer
    Friday, March 29, 2019 8:48 PM
  • This may or may not fix the error for others, but it worked on mine.

    From the following 2 webpages I was able to clarify the Microsoft instructions on the first webpage for fixing the 0x800F081F error. It would be nice if Microsoft would clarify the first webpage since it is linked in the 0x800F081F Error window in Windows 10.

    https://support.microsoft.com/en-us/help/2734782/net-framework-3-5-installation-error-0x800f0906-0x800f081f-0x800f0907

    https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-8.1-and-8/hh825020(v=win.10)

    Resolution for Windows 10
    Error code 0x800F0906, 0x800F081F, or 0x800F0907

    To fix the error codes for Windows 10, follow these steps:

    1. Download the Windows Media Creation tool, and create an ISO image locally, or create an image for the version of Windows that you have installed.

    2. Open the group policy editor. For example, on a computer that is running Windows 10, from the start screen, type Edit Group Policy, and then select Edit Group Policy to open the Group Policy Editor.

    3. Click Computer Configuration, click Administrative Templates, click System, and then double-click the Specify settings for optional component installation and component repair setting.

    Also follow these steps:

    1. Mount the ISO image that's created in step 1 above.

    2. In the window opened in step 3 above, select Enabled, and point the "Alternate source file path" to the ISO X:\sources\sxs folder from the mounted ISO.   <-- "X:" is your mounted drive letter for the ISO

    3. Run the gpupdate /force from the command line.    <-- I ran this step as Admin (Admin may not be needed)

    4. Now add the .Net framework feature.

    I didn't need to restart.  Hope this works for people who couldn't get the methods above to work.


    This worked for me. Windows 10 Pro, old install. I just needed to reinstall .NET 3.5 for a reason.
    Tuesday, April 9, 2019 7:20 PM
  • Yes this Work - Must restart then install feature
    Tuesday, April 9, 2019 9:38 PM
  • Thanks Paul for this fix. It has certainly worked for many but I wanted to add one thing here. This fix may not work for corporate environment with WSUS and GPOs in place. 

    Fix for this is to download the latest ISO of Windows 10 and point the installer to it 

    CMD -> dism /online /enable-feature /featurename:NetFX3 /all /Source:'newSXSfolderfromISO' /LimitAccess

    in my case command looks like -> dism /online /enable-feature /featurename:NetFX3 /all /Source:E:\support\sxs\ /LimitAccess


    Raghu Sharma

    Wednesday, April 10, 2019 1:36 AM
  • Thanks,

    this works for me. 

    Thursday, April 18, 2019 8:43 AM
  • I had this problem as well on my machine at work. Try doing the following it worked and allowed me to download the .Net Framework 3.5 on my Windows 10 PC :  Go into RegEdit and set the HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU folder.  DoubleClick on UseWUServer(UseWindowsUpdateServer) and change the value to 0.  If the value is already 0 this fix may not work for you.  You may need to restart afterwards.

    If this works for you please mark as answer.

    worked very well. thanks a lot
    Wednesday, April 24, 2019 9:56 AM
  • This worked Thanks
    Tuesday, May 28, 2019 6:55 AM
  • Hi Guys 

    This worked perfectly as soon as I changed the value to 1=0 

    I was able to enable the Feature for .Net 

    Thanks a million

    Thursday, May 30, 2019 2:03 PM
  • I can find my way here HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\  But there is no WindowsUpdate\AU Folder listed 
    Sunday, June 2, 2019 9:38 AM
  • What worked for me was going into gpedit.msc, administrative templates, windows components, windows updates. There were a few items in there that were enabled such as 'specify intranet windows update location'. I disabled those and then it worked. You need admin rights to do that. 


    Thursday, June 13, 2019 3:18 PM
  • Installing .NET Framework 3.5 is not always the same solution depending of the Windows version !

    This is my solution to install this package "Offline" without Internet access:

    Windows 7/Windows Server 2008 R2:

    DISM.EXE /Online /Enable-Feature /FeatureName:NetFx3 /NoRestart

    Windows 8.1/Windows Server 2012 R2:

    Put original DVD / ISO in the computer (D:)

    DISM.EXE /Online /Enable-Feature /FeatureName:NetFx3 /All /LimitAccess /Source:D:\sources\sxs

    Windows 10 (1507 - LTSB 2015 Or 1607 - LTSB 2016):

    CAB File is available on the DVD /ISO, assume is D:

    DISM.EXE /Online /Add-Package /PackagePath:"D:\sources\sxs\Microsoft-Windows-NetFx3-OnDemand-Package.cab"

    Windows 10 (1809 - LTSC 2019):

    CAB File is available on the DVD / ISO, assume is D:

    DISM.EXE /Online /Add-Package /PackagePath:"D:\sources\sxs\microsoft-windows-netfx3-ondemand-package~31bf3856ad364e35~amd64~~.cab" /NoRestart 

    Then install language pack also on the DVD / ISO (Sample for French Canada):

    DISM.EXE /Online /Add-Package /PackagePath:"Microsoft-Windows-NetFx3-OnDemand-Package~31bf3856ad364e35~amd64~fr-CA~.cab" /NoRestart

    Friday, June 14, 2019 8:17 PM
  • This is exactly a description of the process which the OP describes as failing with the error code 0x800F081F. With respect, what we are looking for is a solution to the problem, not a description of what doesn't work.
    Monday, June 17, 2019 7:51 AM
  • Try Go into RegEdit and set the HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU folder.  DoubleClick on UseWUServer(UseWindowsUpdateServer) and change the value to 0.  

    and Restart your machine. That should do the trick!

    Thursday, June 20, 2019 4:44 PM
  • this help. perfect! yey...
    Friday, July 26, 2019 12:30 AM
  • I had this problem as well on my machine at work. Try doing the following it worked and allowed me to download the .Net Framework 3.5 on my Windows 10 PC :  Go into RegEdit and set the HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU folder.  DoubleClick on UseWUServer(UseWindowsUpdateServer) and change the value to 0.  If the value is already 0 this fix may not work for you.  You may need to restart afterwards.

    If this works for you please mark as answer.

    This fixed it for me!!
    Thursday, August 15, 2019 8:30 PM
  • thank you. this worked for me.
    Monday, August 26, 2019 4:46 PM
  • There is no WindowsUpdate folder under HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\ .... I am using Windows 10 version 18343 19h1 insider preview (slow)... Can you tell me how can I do this....
    Tuesday, August 27, 2019 10:46 AM
  • This worked for me, thank you!
    Tuesday, August 27, 2019 11:46 PM
  • Thank you that worked. Question - do you need to switch it back after the install is complete?

    Tuesday, September 10, 2019 7:29 PM