locked
Small Basic is Not Responding immediately RRS feed

  • Question

  • I have Windows 7 Service Pack 1, Small Basic 1.2 and .NET Framework 4.6. I did have .NET Framework 4.5, and the same problem occurred, so I updated to 4.6 to see if it would make a difference. It did not. I typed in the "Hello World" program from the "Introducing Small Basic" PDF file, I clicked the Run button, and immediately the program becomes Not Responding. Nothing happens after that, and I must close the program. I have tried several times, and the same thing happens each time. Any suggestions? Thank you.
    Tuesday, November 24, 2015 9:22 PM

Answers

  • SB 1.2 targets .Net 4.5.

    Do you have any extensions installed, errors can happen if the SB/lib folder contains bad dlls or expecially SmallBasicLibary.dll - as a test make sure there is nothng in the extension SB/lib folder.

    I would possibly then try uninstall SB/delete SB installation folder and reinstall SB, but I doubt that would solve - most likey is the extension lib folder.

    I would also save the hello world program somewhere you definitely have wite access - e.g. MyDocuments.  Then try running it, is an exe created in this folder when you run it?

    Also try cleaning you temp folder - it can get stuffed with aborted SB files.

    If any above not clear how to do then ask.

    • Edited by litdev Tuesday, November 24, 2015 10:33 PM
    • Marked as answer by Projectile1 Monday, November 30, 2015 3:43 AM
    Tuesday, November 24, 2015 10:05 PM

All replies

  • SB 1.2 targets .Net 4.5.

    Do you have any extensions installed, errors can happen if the SB/lib folder contains bad dlls or expecially SmallBasicLibary.dll - as a test make sure there is nothng in the extension SB/lib folder.

    I would possibly then try uninstall SB/delete SB installation folder and reinstall SB, but I doubt that would solve - most likey is the extension lib folder.

    I would also save the hello world program somewhere you definitely have wite access - e.g. MyDocuments.  Then try running it, is an exe created in this folder when you run it?

    Also try cleaning you temp folder - it can get stuffed with aborted SB files.

    If any above not clear how to do then ask.

    • Edited by litdev Tuesday, November 24, 2015 10:33 PM
    • Marked as answer by Projectile1 Monday, November 30, 2015 3:43 AM
    Tuesday, November 24, 2015 10:05 PM
  • Thank you for all of the suggestions.  Cleaning the temp folder made it work for me. I appreciate your help.
    Monday, November 30, 2015 3:43 AM