locked
Published Task Status Updates Not Updating Project RRS feed

  • Question

  • I posted before regarding this, but now I have more specific data.

    I have our managers completing milestones through 'Tasks'.  They check the box, click 'Mark Complete', change the dates if necessary, and Send Status for 'Selected Tasks'.  They usually go to me as I'm the status manger in all the templates, but I have my rules configured to auto approve & publish.

    I look in my approval history and all the status updates show as 'published'.  If I open the project in PWA it still shows the milestone at 0% complete.  What makes it even more confusing is if I complete a milestone using the same method, the task is updated with no issues.

    Any ideas what may cause this?  

    Thursday, July 12, 2018 8:27 PM

Answers

  • I believe I actually figured this out.

    If I'm updating dates AND marking a task complete at the same time it will not update the project correctly.  Only the dates will flow thru.

    The workaround is to update the start/finish date, send status update, then mark complete and send another status update OR update start/finish date, then manually fill actual finish and send status update once.

    • Marked as answer by dcase840 Monday, July 16, 2018 9:35 PM
    Monday, July 16, 2018 9:35 PM

All replies

  • Hi,

    I have 2 ideas that may help.

    You are updating Milestones - do these have just a single Resource Assigned, if they have more than 1 Resource Assigned the % complete will not show 100% until all resources have provided updates that have been approved and published. The "published" status viewed from the Status Updates History page is a useful way to determine what has happened with processed updates.

    A long shot - what setting do you have in the Options>Schedule section as shown below?

    I have seen cases where updates have not been applied to projects when this option is not active.

    I hope one of these suggestions helps you resolve your issue.


    With good wishes,

    Dominic

    Microsoft Project Evangelist

    Twitter:   LinkedIn:    Web:   

    Friday, July 13, 2018 9:57 AM
  • Hi,

    I have 2 ideas that may help.

    You are updating Milestones - do these have just a single Resource Assigned, if they have more than 1 Resource Assigned the % complete will not show 100% until all resources have provided updates that have been approved and published. The "published" status viewed from the Status Updates History page is a useful way to determine what has happened with processed updates.

    A long shot - what setting do you have in the Options>Schedule section as shown below?

    I have seen cases where updates have not been applied to projects when this option is not active.

    I hope one of these suggestions helps you resolve your issue.


    With good wishes,

    Dominic

    Microsoft Project Evangelist

    Twitter:   LinkedIn:    Web:   

    Thanks for the suggestions.

    I checked the schedule settings on several projects and they're all setup correctly.  I can see that the task update was processed through my approvals, and I can even see the publish job in the queue history.

    Sunday, July 15, 2018 11:43 PM
  • I believe I actually figured this out.

    If I'm updating dates AND marking a task complete at the same time it will not update the project correctly.  Only the dates will flow thru.

    The workaround is to update the start/finish date, send status update, then mark complete and send another status update OR update start/finish date, then manually fill actual finish and send status update once.

    • Marked as answer by dcase840 Monday, July 16, 2018 9:35 PM
    Monday, July 16, 2018 9:35 PM