none
"Create App Service" locks up

    Question

  • I'm using Visual Studio Pro 2015 running Windows 10. Everything is a new fresh install done 12/24/2015. I'm trying to create a new Web Forms project that will be hosted in the cloud on Azure and I have chosen "No Authentication".  When the "Create App Service" window displays it has created a name for my web app and set my subscription to "BizSpark" which is correct. The "Resource Group" is blank and there is an "X" next to the dropdown.  However I cannot chose anything nor make any changes to any of the other fields. In fact Visual Studio is locked up. Click on anything within the "Create App Service" window will sometimes show a notification saying that Visual Studio is completing an internal process. Even after waiting more than 10 minutes it is still locked up.

    I suspect that there is some configuration issue but I'm not sure where to look.  Any help is appreciated.

    Thanks.

    Friday, December 25, 2015 2:25 AM

All replies

  • Hi tdinpsp-pd,

    Is this problem occur when host your web forms project into cloud on Azure or for any operations in Visual Studio? Please provide some screenshots and detailed steps to help us understanding and reproduce your problem.

    Before get more information from above question, please make sure your computer environment is not busy, especially CPU and Memory.

    Then please try with following steps to troubleshoot this problem.

    1. Run Visual Studio as administrator.
    2. Please try run Visual Studio in safe mode with "Devenv.exe /SafeMode" command to prevents all third-party VSPackages from loading when Visual Studio starts, thus ensuring stable execution.
    3. Close all third part software, such as antivirus.
    4. Remove all third part extensions one by one in your Visual Studio to make sure whether some extensions caused Visual Studio.
    5. Reset all settings for your Visual Studio.

    Please check the ActiveLog.xml under the path of %AppData%\Microsoft\VisualStudio\14.0. This file will log all operations when you operate Visual Studio.

    Best Regards,
    Weiwei

    Monday, December 28, 2015 5:08 AM
    Moderator
  • So I can't attach screen shots because it says that I'm not verified (even though I am).

    The method I'm following to create the problem is after launching Visual Studio I go to <File><New><Project>.  The "New Project" window is displayed and I choose <Templates><Visual C#><Cloud><ASP.Net Web Application>.  Then the New ASP.Net Project window displays and I choose "Web Forms" under the "ASP.Net 4.5 Templates".  I change the Authentication to "None" and click OK.  Normally this is where the "Create App Service" window displays and locks up Visual Studio.  However if I run as Administrator and in Safe Mode I get the following:

         Unable to create remote resources. 'Value cannot be null.
         Parameter Name: accountManager'

         To continue creating the project without remote resources you
         can uncheck the 'Create remote resources' checkbox.

    The Warning message box only has an OK button and if I click the button it will create a project, not in the folder I selected originally but in the default location.  I didn't try to play with this version as I'm not sure what I exactly have as I'm new to Azure and I'm unsure how to tell if things are as they should be when there is an error.

    Tuesday, December 29, 2015 6:01 AM
  • Hi tdinpsp-pd,

    According to your description, I create a Web form and after I click OK, it pop up an "Configure Microsoft Azure Web App Settings", not a  "Create App Service" window as you mentioned.

    Since your problem is Visual Studio locked up when you create web app, please check the ActiveLog.xml under the path of %AppData%\Microsoft\VisualStudio\14.0. This file will log all operations when you operate Visual Studio.

    Then please repair your Visual Studio 2015 first.

    Besides please check whether the Microsoft Azure SDK is the latest version. It should be 2.8.1. If not, please download and install it from below link.

    http://go.microsoft.com/fwlink/?linkid=699285&clcid=0x409

    In addition, please install Visual Studio 2015 Update 1 from following link.

    https://www.visualstudio.com/en-us/news/vs2015-update1-vs.aspx

    Best Regards,
    Weiwei

    Wednesday, December 30, 2015 1:47 AM
    Moderator
  • I've repaired Visual Studio, and even done a new fresh install of windows and visual studio.  I definitely have the correct Azure SDK version installed.

    There is no ActiveLog.xml file to be found.  The only files that are in the folder are ObjBrowEx.dat and User.vsk.

    Here is a screen shot of where things lock up.

    Wednesday, January 6, 2016 4:33 AM
  • Hi tdinpsp-pd,

    According to your steps, I create a sample project with Visual Studio 2015 Professional as below image shows.

    And when I click OK, it pop up a Configure Microsoft Azure Web App Settings windows. Please tell me which step I do wrong.

    In addition, the Create App Service is used to connect to Azure site, please change another account to confirm your account has enough permissions. If Visual Studio can't connect to Azure, it will try connect again and again, which may cause Visual Studio blocked.

    Please turn on the log switch with command "Devenv /log". And then operate your Visual Studio to collect the operations log.

    Best Regards,
    Weiwei

    Thursday, January 7, 2016 1:51 AM
    Moderator
  • Any resolution to this? I am encountering the exact same issue as OP.
    Tuesday, January 26, 2016 1:09 AM
  • Good news/bad news.

    Good news: I was able to solve the problem.

    Bad news: I reformatted my drive installed the OS, VS, Azure SDK again (three times) and it finally worked.

    Sorry I know that doesn't really help.


    • Edited by tdinpsp-pd Sunday, January 31, 2016 9:11 PM
    Sunday, January 31, 2016 9:11 PM