locked
Unable to run sample projects in Blend 3 RRS feed

  • Question

  • Have just installed Blend 3 onto a XP sp3 box.
    When trying to run any of the supplied sample wpf projects I get the following error - (in this instance running 'Wall3D'

    "Unable to copy file "obj\Debug\Wall3D.dll" to "bin\Debug\Wall3D.dll". The process cannot access the file "bin\Debug\Wall3D.dll" becuase it is being used by another process" in file Microsoft.Commo at line 2606.

    Have changed folder permissions from the default "Read only" to try and fix this problem but no joy.

    Not much point trying to develope anything if I won't be able to run/test it in the dev. environment...:(
    Saturday, December 5, 2009 9:47 PM

All replies

  • can you post a link to this Wall3D project?  I'll try it out and see how it works on my end.
    Sunday, December 6, 2009 4:23 AM
  • Thanks for the reply! The project is in the 'Samples' sub-folder of the 'Blend' installation location. Hope this helps. FYI I've tried all the other WPF samples in that come with the app. and get the same errors on all. Again, thanks for the reply. Regards
    Sunday, December 6, 2009 12:39 PM
  • Sure enough, I had the same problem.  Process Explorer showed that it was in use by Blend.  Try this -- it worked for me -- close Blend, then delete the bin and obj folders in Wall3D.  Now open blend again.  You'll get an error telling you that it needs you to build the project.  When you build it, it'll work.
    • Proposed as answer by DaveyBoy1138 Monday, December 7, 2009 4:14 AM
    Monday, December 7, 2009 4:14 AM