none
In EDIFACT to IDOC mapping i am getting this errors RRS feed

  • General discussion

  • Hi all,

    I am doing EDIFACT to IDOC mapping but i am getting below errors any body pls help me, and give me u r valubal suggestions.

    1.The 'SEGMENT' attribute is invalid - The value '' is invalid according to its datatype 'String' - The Enumeration constraint failed.

    2.The element 'EDI_DC40' has invalid child element 'IDOCTYP'. List of possible elements expected: 'MANDT, DOCNUM, DOCREL, STATUS, DIRECT'.

    3.The 'SEGMENT' attribute is invalid - The value '' is invalid according to its datatype 'String' - The Enumeration constraint failed.

    Best regards,

    Ram.

    Wednesday, June 2, 2010 7:23 AM

All replies

  • Hi Joshap,

    1.The 'SEGMENT' attribute is invalid - The value '' is invalid according to its datatype 'String' - The Enumeration constraint failed.

    'SEGMENT' attribute is mapped with blank in the output. You can rid off this error by assigning a default string value for the this element.

    2.The element 'EDI_DC40' has invalid child element 'IDOCTYP'. List of possible elements expected: 'MANDT, DOCNUM, DOCREL, STATUS, DIRECT'.

    Under the 'EDI_DC40' segment you have some mandatory elements like 'MANDT, DOCNUM, DOCREL, STATUS, DIRECT' which are not getting mapped during the transformation. You need to also map these fields in the output. If the corresponding element is not present in your EDIFACT source schema, you can hard code these fields with appropriate values.

    3.The 'SEGMENT' attribute is invalid - The value '' is invalid according to its datatype 'String' - The Enumeration constraint failed.

    'SEGMENT' attribute is mapped with blank in the output. You can rid off this error by assigning a default string value for the this element.

    Regards,

    Abhijit


    Abhijit Mahato Please "Mark as Answer" if Post has Answered the Question
    Wednesday, June 2, 2010 8:27 AM
  • Hi Abhijit,

    thnks for u r quick responce,

    where i want assign string value for the this element.could u tell me navigations.

    Best Regards,

    Ram kumar.

    Wednesday, June 2, 2010 8:53 AM
  • Hi,

    Open your IDOC schema and in the 'SEGMENT' attribute assign some default string value.

    Regards,

    Abhijit


    Abhijit Mahato Please "Mark as Answer" if Post has Answered the Question
    Wednesday, June 2, 2010 9:22 AM
  • Hi Abhijit,

    still unable to fix this errors could u give me brif navigations.

    It is very urgent.

    Best Rgards,

    Ram.

    Thursday, June 3, 2010 5:21 AM
  • Hi,

    Please post your input and output schema.

    Regards,

    Abhijit


    Abhijit Mahato Please "Mark as Answer" if Post has Answered the Question
    Thursday, June 3, 2010 5:48 AM