locked
Project not reading CSS RRS feed

  • Question

  • User1961047501 posted

    I have a project that is giving me a Uncaught Syntax Error on the first line. I am trying to integrate darwEditor (https://github.com/mburakerman/draweditor) into an existing project.

    I put all the dependencies into their own bundle and referenced them in the View but this error occurs for the CSS.

    bundles.Add(new ScriptBundle("~/bundles/imageBundle").Include( "~/Scripts/jquery.ezdz.min.js", "~/Scripts/lity.js", "~/Scripts/jquery.ezdz.min.js", "~/Scripts/draweditor.js" + "~/Scripts/imageEditor.js")); bundles.Add(new StyleBundle("~/Content/imageEditorCSS").Include( "~/Content/draweditor.css", "~/Content/jquery.minicolors-2.1.2.css", "~/Content/lity.css", "~/Content/normalize.css", "~/Content/wenk.css", "~/Content/jquery.ezdz.min.css"));

    Wednesday, April 17, 2019 9:18 PM

All replies

  • User839733648 posted

    Hi Kwe7777,

    According to description and codes, I'm sorry that I could not reprodcue your issue successfully.

    When I run your code, there is only one error message after selecting an image on my computer.

    Uncaught ReferenceError: previewFile is not defined

    And I've checked your js file, there is no previewFile function. So the error exists.

    I've tried to remove onchange="previewFile()" and run the code, it works well.

    I'm curious that I do not see the CSS file error on my side. Have you shared the complete code?

    Or I suggest that maybe you could download the github's project and run again to test it.

    Here is my running result.

    Best Regards,

    Jenifer

    Thursday, April 18, 2019 3:35 AM
  • User753101303 posted

    Hi,

    The weird thing is that it rather looks like a javascript error ? Seems something making the browser confused about that..

    Thursday, April 18, 2019 10:46 AM