locked
Unable to launch Technical Preview 2 AzureStackDownloader.exe RRS feed

  • Question

  • Anyone having issues launching the stack downloader exe for Technical Preview 2?  Hardware check is OK, running on Windows Server 2012 R2.

    Tried two different OS installs and both have same error. get the "AzureStackDownloader.exe has stopped working" and get the stack trace.

    Thanks.

    Monday, November 21, 2016 12:32 AM

Answers

  • Hello!

    Have you tried Windows Server 2016?

    Cheers


    Andy.PT

    • Marked as answer by Vinnie888 Monday, November 21, 2016 7:52 PM
    Monday, November 21, 2016 12:38 AM

All replies

  • Hello!

    Have you tried Windows Server 2016?

    Cheers


    Andy.PT

    • Marked as answer by Vinnie888 Monday, November 21, 2016 7:52 PM
    Monday, November 21, 2016 12:38 AM
  • Hi Andy, no I haven't.  Documentation says the version does not matter as long as its 2012 R2 and newer:

    "The Technical Preview 2 deployment requirements for the POC are the same as those required for Technical Preview 1. "  see link https://docs.microsoft.com/en-us/azure/azure-stack/azure-stack-deploy

    If no path forward, I can try 2016.

    Monday, November 21, 2016 1:08 AM
  • ;)

    Please let us know how it turns out.

    Being on TP2 or TP1 it is expected to have some bugs, and OS version and patches is one of the most typical issues.

    Cheers.


    Andy.PT

    Monday, November 21, 2016 1:32 AM
  • Andy, yes you have to run the installer on Windows 2016.  Or otherwise follow some other procedure to make it work on 2012.

    Thanks!

    Monday, November 21, 2016 4:11 AM
  • Hi,

    It might that .net framework 4.5 is missing on your 2012R2 host. Please try to add that and also include the TCP Port Sharing feature if I recall correctly (not sure about the last one if it is required but works for me).


    Best regards, Mark Scholman. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, November 21, 2016 4:38 PM
  • I validated that .NET 4.5 is installed and TCP Port sharing is enabled.  Does ASP.NET 4.5 need to be installed?
    Tuesday, November 22, 2016 3:44 PM
  • I ran into the same issue.  I resolved this by installing .NET framework 4.6 (393297).
    Tuesday, November 22, 2016 8:25 PM
  • Azure Stack TP3 has been released on March 1, 2017.

    If you are experiencing any issues with the TP2 release, please download and redeploy using the latest Azure Stack POC deployment package

    Please see the updated deployment documentation:

    https://docs.microsoft.com/en-us/azure/azure-stack/azure-stack-run-powershell-script

    And updated Azure Stack Docs:

    https://docs.microsoft.com/en-us/azure/azure-stack/

    If you experience any issues with TP3 release, feel free to contact us.

    https://azure.microsoft.com/en-us/blog/hybrid-application-innovation-with-azure-and-azure-stack/

    Wednesday, March 1, 2017 7:24 PM