locked
SSO Application Configuration .msc - Unable to load mmc and unable to uninstall/repair RRS feed

  • Question

  • This tool was installed on a QA server by an ex-employee and nobody knows for sure if it ever worked.  Attempting to uninstall/repair fails with below errors in the event log.

    The description for Event ID 11001 from source MsiInstaller cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

     

    If the event originated on another computer, the display information had to be saved with the event.

     

    The following information was included with the event:

     

    Product: SSO Application Configuration -- Error 1001. Error 1001. Company Name is a required field.

    (NULL)

    (NULL)

    (NULL)

    (NULL)

     

     

     

    The description for Event ID 11001 from source MsiInstaller cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

     

    If the event originated on another computer, the display information had to be saved with the event.

     

    The following information was included with the event:

     

    Product: SSO Application Configuration -- Error 1001. Error 1001. An exception occurred while uninstalling. This exception will be ignored and the uninstall will continue. However, the application might not be fully uninstalled after the uninstall is complete. --> Cannot delete a subkey tree because the subkey does not exist.

    (NULL)

    (NULL)

    (NULL)

    (NULL)

     

    The tool is currently unusable.  And worse, we cannot uninstall and re-install this tool.  Please advise.

    Thursday, February 9, 2012 5:15 AM

Answers

All replies

  • Hi,

    How are you uninstalling the software.

    In case you are getting error while uninstalling it from control panel then download the tool from http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=14524 and then try installing it. it will ask you for uninstall of existing product.


    Thanks With Regards,
    Shailesh Kawade
    MCTS BizTalk Server
    Please Mark This As Answer If This Helps You.
    http://shaileshbiztalk.blogspot.com/

    Thursday, February 9, 2012 6:00 AM
  • Hi

    It seems lilke you would need to do some deletion in the registry manually. Could you location the uninstallation location of the tool in registry and check if any path is missing or incorrect?

    Thanks

    Naushad

    Thursday, February 9, 2012 1:32 PM
    Moderator
  • Hi,

    There are alternatives for SSO Application Configuration MMC. See Custom Configuration options for BizTalk Solution for different options. For reference see also this wiki.

    HTH

    Steef-Jan Wiggers

    MVP & MCTS BizTalk Server 2010

    http://soa-thoughts.blogspot.com/ | @SteefJan

    If this answers your question please mark it accordingly


    BizTalk

    Thursday, February 9, 2012 3:05 PM
    Moderator
  • Hi - This was exactly what I did.  It asked me to uninstall the existing product.  However, the uninstall process failed and terminated with the errors mentioned in my original post.
    Thursday, February 9, 2012 3:09 PM
  • @NaushadAlam - All locations listed in the registry are correct.

    @Steef-Jan Wiggers - Thank you.  I'll check it out.  We still would like to explore if there're any other solutions out there for the issue with mmc we're having.

    Thursday, February 9, 2012 3:53 PM
  • got the exact same error and I REALLY need help with it. This is the only place that I have found via google with the same error as me.

    Please help me!
    Thursday, September 12, 2013 2:39 PM
  • Exeetor,

    Can you try following:


    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful.

    Thursday, September 12, 2013 3:06 PM
  • Hi,

    Sadly i had the same issue trying to uninstall the SSO App Con... I also could not repair the install due to another 1001 error.

    Instead of uninstalling the program i found the registry file i needed to repair the install and imported it to my registry.

    1 Open notepad and paste the following

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\MMC\SnapIns\FX:{ce255ef6-9e3d-42c8-b725-95ccc761b9d9}]
    "UseCustomHelp"=dword:00000000
    "Type"="Microsoft.ManagementConsole.Samples.ActionsSnapIn, SSOMMCSnapIn, Version=1.5.0.0, Culture=neutral, PublicKeyToken=null"
    "ApplicationBase"="C:\\Program Files (x86)\\Microsoft Services\\SSO Application Configuration"
    "ConfigurationFile"="SSOMMCSnapIn.dll.config"
    "NameString"="SSO Application Configuration"
    "Description"="Allows a BizTalk Administrator to Configure the SSO Configuration Store"
    "Provider"="Microsoft"
    "ModuleName"="SSOMMCSnapIn.dll"
    "AssemblyName"="SSOMMCSnapIn"
    "RuntimeVersion"="v2.0.50727"
    "FxVersion"="3.0.0.0"
    "About"="{00000000-0000-0000-0000-000000000000}"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\MMC\SnapIns\FX:{ce255ef6-9e3d-42c8-b725-95ccc761b9d9}\NodeTypes]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\MMC\SnapIns\FX:{ce255ef6-9e3d-42c8-b725-95ccc761b9d9}\Standalone]

    2 Save file as .reg

    3 Open regedit.exe and import the saved <filename.reg> 

    This should allow you to use the SSO App Conf.. again.

    I hope this helped.


    • Proposed as answer by TechXLLC Tuesday, June 9, 2015 2:03 AM
    Sunday, February 23, 2014 8:25 PM
  • Tried this (importing registry settings) but by itself it didn't allow me to use SSO Application Configuration.

    However, it allowed me to uninstall (fixed the missing registry entries) and then let me install again.

    After this, SSO worked again for me.


    Wednesday, March 18, 2015 8:15 AM
  • This solution worked :)

    Friday, January 22, 2016 5:20 AM
  • Hi,

    Sadly i had the same issue trying to uninstall the SSO App Con... I also could not repair the install due to another 1001 error.

    Instead of uninstalling the program i found the registry file i needed to repair the install and imported it to my registry.

    1 Open notepad and paste the following

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\MMC\SnapIns\FX:{ce255ef6-9e3d-42c8-b725-95ccc761b9d9}]
    "UseCustomHelp"=dword:00000000
    "Type"="Microsoft.ManagementConsole.Samples.ActionsSnapIn, SSOMMCSnapIn, Version=1.5.0.0, Culture=neutral, PublicKeyToken=null"
    "ApplicationBase"="C:\\Program Files (x86)\\Microsoft Services\\SSO Application Configuration"
    "ConfigurationFile"="SSOMMCSnapIn.dll.config"
    "NameString"="SSO Application Configuration"
    "Description"="Allows a BizTalk Administrator to Configure the SSO Configuration Store"
    "Provider"="Microsoft"
    "ModuleName"="SSOMMCSnapIn.dll"
    "AssemblyName"="SSOMMCSnapIn"
    "RuntimeVersion"="v2.0.50727"
    "FxVersion"="3.0.0.0"
    "About"="{00000000-0000-0000-0000-000000000000}"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\MMC\SnapIns\FX:{ce255ef6-9e3d-42c8-b725-95ccc761b9d9}\NodeTypes]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\MMC\SnapIns\FX:{ce255ef6-9e3d-42c8-b725-95ccc761b9d9}\Standalone]

    2 Save file as .reg

    3 Open regedit.exe and import the saved <filename.reg> 

    This should allow you to use the SSO App Conf.. again.

    I hope this helped.


    Thanks MarlzyMarl, your solution worked for me.

    Please mark the post as answer if this answers your question. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply.

    Monday, October 8, 2018 7:29 AM