locked
[Bug Report]: Azure Resource Health REST API response health status inconsistent with portal result for web app resource type RRS feed

  • Question

  • Hi, I believe to have discovered a bug in the recent Azure resource health REST API based on the blog link below.

    Microsoft Azure Resource Health blog

    When I send a GET request using the Azure ARM REST API to get the resource health status of all the resources under a particular subscription Id like below:

    https://management.azure.com/subscriptions/<subscriptionId>/providers/Microsoft.ResourceHealth/availabilityStatuses?api-version=2015-01-01

    I get the response as below:

    As shown, this Azure web app resource's availabilityState is "Unknown" as returned by the REST API call.

    However, in the Azure portal, this web app is deliberately paused to check whether the REST API response is consistent with the actual status in the portal, which is expected to return "Stopped" instead of "Unknown".

    Can your team kindly look into this? This issue is consistently reproducible. Thanks very much.

       {
          "id": "/subscriptions/<subscriptionId>/resourceGroups/<resGrp-name>/providers/Microsoft.Web/sites/<webAppName>/providers/Microsoft.ResourceHealth/availabilityStatuses/current",
          "name": "<webAppName>",
          "type": "Microsoft.ResourceHealth/AvailabilityStatuses",
          "location": "northeurope",
          "properties": {
            "availabilityState": "Unknown",
            "summary": "We are sorry, we are unable to report the health of your Web App",
            "reasonChronicity": "Persistent",
            "recommendedActions": [
              {
                "action": "Continue to monitor this page for updated status",
                "actionUrl": "",
                "actionUrlText": ""
              }
            ],
            "detailedStatus": "No health activity detected on your Azure Web App in past 10 minutes.",
            "occuredTime": "2015-11-18T23:54:59.543Z"
          }
        }


    Thursday, November 19, 2015 12:50 PM

All replies

  • Hello juvchan,
    Thank you for posting in here. I am researching on this with regards your request and will get back to you with an update.

    Thank you for your patience.

    Regards,

    Friday, November 20, 2015 10:17 AM
  • Hello juvchan,

    There is a delay of 15 minutes for the health data to be updated in the Resource health. I have tried to reproduce this and currently don't find any issues with the report. But however, we would like to check the issue that you are reporting.
    I would need the following details to get a status on this:

    a. Name of the website, please share the name of the Webapp following the instructions in the link below:
    https://github.com/projectkudu/kudu/wiki/Reporting-your-site-name-without-posting-it-publicly
    b. Exact time stamp when you stop the Webapp from the portal and get the status as Unknown in UTC.

    Thanks,
    Syed Irfan Hussain

    Monday, November 23, 2015 10:51 AM
  • Thanks!
    Tuesday, November 24, 2015 10:58 AM