none
Different response time for same user RRS feed

  • Question

  • My page is giving different response time for same user during the same session. What can be the issue. 

    Please remember to mark the replies as answers or vote as helpful if they help.

    Monday, August 29, 2016 7:32 AM

Answers

  • Hi HS Rana,

    It is difficult to make the response time consistent for all users on all time. A lot of reasons could cause the slow performance issue, such as many users visits the site at the same time, the page need to load too much data, network and so on.

    Some articles for performance and capacity management in SharePoint Server 2013, which could be helpful to you:

    https://technet.microsoft.com/en-us/library/cc262971.aspx

    Best regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, September 7, 2016 2:07 AM
    Moderator

All replies

  • Hi HS Rana

    what different reponse time are you getting? is the difference too much ?

    You can use tool netmon to trace if there is any network issue.


    Mark it as an answer if it helped you out. Regards Rahul Dagar

    Monday, August 29, 2016 7:39 AM
  • Hi,

    The difference is 4-5 seconds. we have used wireshark & there is no issue on network.


    Please remember to mark the replies as answers or vote as helpful if they help.

    Monday, August 29, 2016 11:46 AM

  • try to enable Sharepoint Developer Dashboard and see which server component "stucks". There could be performance peaks on the server (e.g. if a lot of users use the site at the same time) which may cause different response time for the same page for the same user.

    Blog - http://sadomovalex.blogspot.com
    Dynamic CAML queries via C# - http://camlex.codeplex.com

    Monday, August 29, 2016 2:17 PM
  • Hi HS Rana,

    For your issue, I need to collect some Information from you.

    1. Does the slow performance issue occur on the first load? When you refresh page, does the page still load slowly?

    2. What are web parts on that page?

    Please try to unselect 'Automatically detect settings' as IE >Tools > Internet Options > Connections > LAN settings, compare the result.

    A lot of reasons would cause the performance issue, for example:

    1. Have high CPU Or memory use on server.

    2. A lot of web parts on the page would slow down the page.

    3. Anti-virus software. If it is scanning every document that is uploaded, or is scanning the database or BLOB store directly, can slow things down tremendously.

    As sadomovalex mentioned, you could use SharePoint Developer Dashboard to monitor the page load process, which would be helpful to you to find the reason of the issue.

    Best regards,

    Linda Zhang


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, August 30, 2016 10:15 AM
    Moderator
  • Thanks for replaying. 

    The different response time comes in different time & not on first load. It comes sometime during the same session or sometime it come when page first load. There is not much CPU/Memory usage. How I can make it consistent for all users on all time. 

    The page contains multiple content query web part.


    Please remember to mark the replies as answers or vote as helpful if they help.

    Wednesday, August 31, 2016 8:14 AM
  • Hi HS Rana,

    It is difficult to make the response time consistent for all users on all time. A lot of reasons could cause the slow performance issue, such as many users visits the site at the same time, the page need to load too much data, network and so on.

    Some articles for performance and capacity management in SharePoint Server 2013, which could be helpful to you:

    https://technet.microsoft.com/en-us/library/cc262971.aspx

    Best regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, September 7, 2016 2:07 AM
    Moderator