The following forum(s) have migrated to Microsoft Q&A (Preview): Developing Universal Windows apps!
Visit Microsoft Q&A (Preview) to post new questions.

Learn More

 locked
Windows App crashing at start, when build not made on same machine RRS feed

  • Question

  • Im working on a windows 8.1 store app project, when i create a App package and install it on the same machine it works well, if i then use that package on a diferent machine, i get a crash at splash screen

    Machine 1: PC with windows 10, developer mode activated.

    Machine 2: Surface with windows 8.1

    On the tablet logs i see 2 errors first one is:

    Event id 5973

    Activation of app app_03ym3vjwssmsm!App failed with error: The remote procedure call failed. See the Microsoft-Windows-TWinUI/Operational log for additional information.

    and the second one:

    Faulting application name: myapp.exe, version: 1.0.0.4, time stamp: 0x563a19ef Faulting module name: Windows.UI.Xaml.dll, version: 6.3.9600.17904, time stamp: 0x557b0ffa Exception code: 0xc000027b Fault offset: 0x00000000009829ea Faulting process id: 0xad8 Faulting application start time: 0x01d11754e5d0b115 Faulting application path: C:\Program Files\WindowsApps\app_1.1.0.25_x64__03ym3vjwssmsm\myapp.exe Faulting module path: C:\Windows\System32\Windows.UI.Xaml.dll Report Id: 23b679c5-8348-11e5-be73-6045bde98157 Faulting package full name: app_1.1.0.25_x64__03ym3vjwssmsm Faulting package-relative application ID: App

    Also, both machines run on x64 , and i build my package as x64.

    Do i need to something extra for my package to run on other machines?

    If i create app package on Machine 1, and install on Machine 1 - Works

    If i create app package on Machine 2, and install on Machine 2 - Works

    If i create app package on Machine 1, and install on Machine 2 - fails

    If i create app package on Machine 2, and install on Machine 1 - fails


    • Edited by Thought2 Wednesday, November 4, 2015 3:52 PM
    Wednesday, November 4, 2015 3:47 PM

Answers

  • >>and i tried the steps on the second link, but i dont get any errors

    Then this is very strange. I currently am not able to reproduce you encountered scenario, you could have a try to debug the crashed app yourself by analyzing the crash dump to see if you could get a caused reason:

    Debugging a Windows 8.1 Store App Crash Dump

    Regards,

    --Fred.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    • Edited by Fred Bao Thursday, November 19, 2015 4:18 AM
    • Proposed as answer by Fred Bao Wednesday, November 25, 2015 9:19 AM
    • Marked as answer by Fred Bao Wednesday, December 2, 2015 11:41 AM
    Tuesday, November 10, 2015 8:38 AM

All replies

  • >>Do i need to something extra for my package to run on other machines?

    Have you installed the self-signed certificate on client machine? According to this link: Try it out: sideload Windows Store apps

    Also, have a check this link for some approaches to debug the deployment of the windows runtime project:

    Troubleshooting packaging, deployment, and query of Windows Store apps

    If I do not understand correctly, please feel free to let me know.

    Regards.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, November 5, 2015 10:04 AM
  • Yes, i have installed the self-signed certificate on client machine, and i tried the steps on the second link, but i dont get any errors on Microsoft-Windows-AppxPackaging/Operational. log or Microsoft-Windows-AppXDeploymentServer/Operational. :(
    Thursday, November 5, 2015 12:59 PM
  • >>and i tried the steps on the second link, but i dont get any errors

    Then this is very strange. I currently am not able to reproduce you encountered scenario, you could have a try to debug the crashed app yourself by analyzing the crash dump to see if you could get a caused reason:

    Debugging a Windows 8.1 Store App Crash Dump

    Regards,

    --Fred.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    • Edited by Fred Bao Thursday, November 19, 2015 4:18 AM
    • Proposed as answer by Fred Bao Wednesday, November 25, 2015 9:19 AM
    • Marked as answer by Fred Bao Wednesday, December 2, 2015 11:41 AM
    Tuesday, November 10, 2015 8:38 AM