locked
Slider with style doesn't work in windows phone 8 RRS feed

  • Question

  • I have a silder with a style, which works in wp7, but doesn't work in wp8. The thumb doesn't move with mouse.

    I tried the default style created by Blend, and doesn't work either.

    Anybody has the same question?
    Friday, November 2, 2012 8:55 AM

Answers

  • To use the new slider style of WP8 resolves the problem, thank you all the same.

    Tuesday, November 6, 2012 6:05 AM

All replies

  • Can you share your style definition?

    Does this problem occur when running the WP7 version of the app on WP8?
    ... or did this start after you upgraded the project to target WP8 platform?


    -Eric.

    Friday, November 2, 2012 3:29 PM
  • The thumb doesn't move with mouse.


    Since you mention the mouse, I assume this is in the emulator? Have you tested this on an actual device?

    Friday, November 2, 2012 5:01 PM
  • Yes, I upgraded code from wp7.

    I notice that the slider style in WP8 is different from that in WP7, which may be the reason of not working.

    Thanks for your reminder.

    Tuesday, November 6, 2012 6:00 AM
  • To use the new slider style of WP8 resolves the problem, thank you all the same.

    Tuesday, November 6, 2012 6:05 AM
  • To use the new slider style of WP8 resolves the problem, thank you all the same.

    Same problem.

    Where you got "new slider style" ? Blends one fails as you said.


    • Edited by Ingerdev Sunday, November 25, 2012 3:13 AM
    Sunday, November 25, 2012 3:13 AM
  • To use the new slider style of WP8 resolves the problem, thank you all the same.

    Same problem.

    Where you got "new slider style" ? Blends one fails as you said.


    Got it in Blend. You could drag a slider conotrol to the design panel and right click it -> eidt style -> edit a copy. Hope that help.
    • Proposed as answer by JooPoo Sunday, January 13, 2013 5:42 AM
    Sunday, December 16, 2012 2:38 PM