locked
Font problem in vs2008 Crystal Report RRS feed

  • Question

  • User1255597977 posted

    I have just migrated project from vs2003 to vs2008.

    I have problem with Crystal Report.Alignement was not in proper.Font Size not Coming in proper Size

    Do you have any solution

    Thursday, February 16, 2012 7:31 AM

Answers

  • User1255597977 posted

    Hi guys finally Got Solution for font reduction problem in  Local PC!!!

    To fix the bug, just follow steps below by adding 2 registry keys.
    
    1. Select Start > Run. Type regedit and click OK.
    
    2. For Crystal Reports 2008, Expand HKEY_CURRENT_USER\Software\Business Objects\Suite 12.0\Crystal Reports\Export.
    
    For Crystal Reports 11.0, Expand HKEY_CURRENT_USER\Software\Business Objects\Crystal Reports.
    
    For Crystal Reports 10.0, Expand HKEY_CURRENT_USER\SOFTWARE\Crystal Decisions\10.0\Crystal Reports\Export
    
    For Crystal Reports 9,0, Expand HKEY_CURRENT_USER\software\crystal decisions\9.0\Crystal Reports\Export
    
    3. Right-click the Export folder and select New > Key. This creates a new folder. Name the new folder PDF.
    
    4. Right-click the PDF folder and select New > DWORD Value.
    
    5. Name this 'ForceLargerFonts' with no quotes and note that it is case sensitive.
    
    6. Double-click ForceLargerFonts and change the Value data to 1 and click OK.
    
    7. Close all the registry folders and expand the following registry For Crystal Reports 2008, HKEY_LOCAL_MACHINE\Software\Business Objects\Suite 12.0\Crystal Reports.
    
    For Crystal Reports 11.0, HKEY_LOCAL_MACHINE\Software\Business Objects\Suite 11.0.
    
    For Crystal Reports 10.0, HKEY_LOCAL_MACHINE\SOFTWARE\Crystal Decisions\10.0\Crystal Reports
    
    For Crystal Reports 9.0, HKEY_LOCAL_MACHINE\Software\Crystal Decisions\9.0\Crystal Reports
    
    8. Right-click the Crystal Reports folder and select New > Key. Name this key Export.
    
    9. Right-click the Export folder and select New > Key. This creates a new folder. Name this folder PDF.
    
    10. Repeat steps 4 through 6.
    
    11. Close the Registry Editor and restart Crystal Reports.
    
    
    After adding these two registry keys, Crystal Reports won't have this font size problem any more.
    
    
    However, if you want to generate barcode in Crystal Reports from IIS server, you need to modify permissions of these registry keys.
    
    IIS security model prevents the application pool identity to read those registry entries by default.
    
    Open Windows application Regedit and browse to
    
    HKEY_LOCAL_MACHINE\SOFTWARE\Business Objects\Suite 12.0\Crystal Reports\Export\PDF
    
    Right click the key and choose “Permissions” from context menu.
    
    Add in default IIS user account. Usually it's IUSR_MachineName.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, January 3, 2014 6:20 AM

All replies

  • User-536335358 posted

    Can you explain the scenario? and if possible paste the code..

    Thursday, February 16, 2012 7:47 AM
  • User1255597977 posted

    We had a project in visual Studio 2003 and we have migrated version to Visual Studio 2008
    Except Crystal Report all where working fine.
    In the crystal Report we have problem like not properly aligned,reduction in fontsize.

    Thursday, February 16, 2012 8:02 AM
  • User-448512826 posted

    Hi,

    same resolved thread here....

    http://forums.asp.net/t/1753417.aspx/1

    Thursday, February 16, 2012 8:06 AM
  • User1255597977 posted

    Hi,

    same resolved thread here....

    http://forums.asp.net/t/1753417.aspx/1

    hi salman this is not a design issue its about migration ssue from vs 2003 to vs 2008

    Wednesday, March 7, 2012 6:33 PM
  • User1255597977 posted

    while converting or migrating vs2003 to vs2008 there where small reduction in size and font in report .

    Made adjustment in all report like page size font size 

    it worked perfects

    Thanks

    Monday, April 2, 2012 11:46 PM
  • User1255597977 posted

    Hi guys finally Got Solution for font reduction problem in  Local PC!!!

    To fix the bug, just follow steps below by adding 2 registry keys.
    
    1. Select Start > Run. Type regedit and click OK.
    
    2. For Crystal Reports 2008, Expand HKEY_CURRENT_USER\Software\Business Objects\Suite 12.0\Crystal Reports\Export.
    
    For Crystal Reports 11.0, Expand HKEY_CURRENT_USER\Software\Business Objects\Crystal Reports.
    
    For Crystal Reports 10.0, Expand HKEY_CURRENT_USER\SOFTWARE\Crystal Decisions\10.0\Crystal Reports\Export
    
    For Crystal Reports 9,0, Expand HKEY_CURRENT_USER\software\crystal decisions\9.0\Crystal Reports\Export
    
    3. Right-click the Export folder and select New > Key. This creates a new folder. Name the new folder PDF.
    
    4. Right-click the PDF folder and select New > DWORD Value.
    
    5. Name this 'ForceLargerFonts' with no quotes and note that it is case sensitive.
    
    6. Double-click ForceLargerFonts and change the Value data to 1 and click OK.
    
    7. Close all the registry folders and expand the following registry For Crystal Reports 2008, HKEY_LOCAL_MACHINE\Software\Business Objects\Suite 12.0\Crystal Reports.
    
    For Crystal Reports 11.0, HKEY_LOCAL_MACHINE\Software\Business Objects\Suite 11.0.
    
    For Crystal Reports 10.0, HKEY_LOCAL_MACHINE\SOFTWARE\Crystal Decisions\10.0\Crystal Reports
    
    For Crystal Reports 9.0, HKEY_LOCAL_MACHINE\Software\Crystal Decisions\9.0\Crystal Reports
    
    8. Right-click the Crystal Reports folder and select New > Key. Name this key Export.
    
    9. Right-click the Export folder and select New > Key. This creates a new folder. Name this folder PDF.
    
    10. Repeat steps 4 through 6.
    
    11. Close the Registry Editor and restart Crystal Reports.
    
    
    After adding these two registry keys, Crystal Reports won't have this font size problem any more.
    
    
    However, if you want to generate barcode in Crystal Reports from IIS server, you need to modify permissions of these registry keys.
    
    IIS security model prevents the application pool identity to read those registry entries by default.
    
    Open Windows application Regedit and browse to
    
    HKEY_LOCAL_MACHINE\SOFTWARE\Business Objects\Suite 12.0\Crystal Reports\Export\PDF
    
    Right click the key and choose “Permissions” from context menu.
    
    Add in default IIS user account. Usually it's IUSR_MachineName.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, January 3, 2014 6:20 AM