none
Merged hlkx package with HLK Kit version 1703 ( build 15063) RS2 encountering signing error RRS feed

  • Question

  • Hi,

    We have to sign our print driver for the follwoing OS versions.

    Win 10 x86 15063 (RS2 RTM)
    Win 10 x64 15063 (RS2 RTM)
    Win 10 x86 14393 (RS1 RTM)
    Win 10 x64 14393 (RS1 RTM)

    Win Server 16 x64

    We generated the following logs.


    With HLK Kit version 1607 ( build 14393)
    ========================================
    Win Server 16 x64


    With HLK Kit version 1703 ( build 15063)
    ========================================
    Win 10 x86 15063 (RS2 RTM)
    Win 10 x64 15063 (RS2 RTM)
    Win 10 x86 14393 (RS1 RTM)
    Win 10 x64 14393 (RS1 RTM)

    Then we merged all the logs using  HLK Kit version 1703 ( build 15063) RS2. While signing the merged .hlkx  package, the following error is given.

    Microsoft.Windows.Kits.Hardware.ObjectModel.Submission.PackageException: Package (\\Merged.hlkx) with a version (3.3.0.0) is not compatible with this instance of PackageManager. This instance of Package Manager accepts versions 3.2.0.0, 3.1.0.0, and 2.0.0.0 "

    Additional Info : 

    However, when the package is generated  with HLK Kit version 1607 (build 14393) RS1, it can be signed properly.


    Can you please guide us how to resolve this issue.

    Thanks,

    Upamanyu Sarkar

    Sunday, July 2, 2017 9:43 AM