locked
Publish Wizard Not Responding RRS feed

  • Question

  • I have been experiencing a problem with the publish wizard of Lightswitch applications.

    Every time I create a new Lightswitch HTML application, and I try to run the publishing wizard, it works fine until I close off Visual Studio and reopen the project, then the Publish wizard appears but it's completely unresponsive.

    So every time a project is created, closed and reopened, it breaks the publish wizard.

    Repairing Visual Studio sometimes fixes the problem but it's not consistent. I've tried all sort of things, like deleting the .user file but with no luck..

    I am using Visual Studio 2013 with Update 4. Any help would be so appreciated so thank you in advance!

    Thursday, July 2, 2015 6:40 PM

Answers

  • Having same issue here, also with Visual Studio 2013 Update 4.

    A little easier workaround I found rather than creating new user - if you delete the file:

    c:\users\username\documents\visual studio 2013\settings\windows azure subscriptions.xml

    then you'll be able to use publish wizard again.

    • Marked as answer by Angie Xu Thursday, July 16, 2015 1:56 AM
    Monday, July 13, 2015 8:06 PM
  • I found an even simpler workaround. The problem seems to be visual studio isn't resuming connection to Azure, which is why the earlier workarounds fixed the problem - deleting user settings or creating new user removes the connection string to azure. If that connection string is there, the publish wizard tries to connect to Azure but isn't able to make that connection. Simple workaround -when you first open your project, but before you publish, go into Server Explorer and you will see Azure (Not Connected). That's what you need to correct before publishing, so open up something in Azure like App Service, so that Azure connects and refreshes. then lightswitch is good to go.
    • Proposed as answer by William Hodges Wednesday, December 23, 2015 7:34 AM
    • Marked as answer by Tarek Sharbak Friday, January 22, 2016 5:04 PM
    Thursday, December 3, 2015 6:40 PM

All replies

  • im having the same problem. Does anyone know how to solve?

    Thursday, July 2, 2015 7:44 PM
  • If it might help diagnose the problem. I now found a workaround, a really annoying one that is, every time I want to publish, I create a new user, and then open the project in that user and then the publish wizard works again. Of course, closing the project and reopening even in that user, also breaks the publish wizard. So I keep deleting the temp user and recreating a new one every time I wanna publish..
    Monday, July 6, 2015 8:06 AM
  • Having same issue here, also with Visual Studio 2013 Update 4.

    A little easier workaround I found rather than creating new user - if you delete the file:

    c:\users\username\documents\visual studio 2013\settings\windows azure subscriptions.xml

    then you'll be able to use publish wizard again.

    • Marked as answer by Angie Xu Thursday, July 16, 2015 1:56 AM
    Monday, July 13, 2015 8:06 PM
  • Thanks a lot! that saves me so much time :) I hope they fix this problem though!
    Monday, July 13, 2015 8:24 PM
  • Thanks such a simple fix. I have wasted hours on getting this corrected.

    I am going to add a few words here so others may find this post easier.

    • New Developer Machine Publish fails
    • New Developer Machine Publish Hangs
    • Windows reinstall publish will not work
    • windows reinstall publish hangs
    • Publish spinning donut

    Thanks again

    Cliff

    Saturday, August 8, 2015 3:35 PM
  • Thanks! Very Much!
    Thursday, December 3, 2015 6:04 PM
  • I found an even simpler workaround. The problem seems to be visual studio isn't resuming connection to Azure, which is why the earlier workarounds fixed the problem - deleting user settings or creating new user removes the connection string to azure. If that connection string is there, the publish wizard tries to connect to Azure but isn't able to make that connection. Simple workaround -when you first open your project, but before you publish, go into Server Explorer and you will see Azure (Not Connected). That's what you need to correct before publishing, so open up something in Azure like App Service, so that Azure connects and refreshes. then lightswitch is good to go.
    • Proposed as answer by William Hodges Wednesday, December 23, 2015 7:34 AM
    • Marked as answer by Tarek Sharbak Friday, January 22, 2016 5:04 PM
    Thursday, December 3, 2015 6:40 PM
  • Thank you!
    Wednesday, December 23, 2015 7:34 AM
  • This didn't work in the past for me. But I think it works now with the new Azure SDK. Thank you!
    Friday, January 22, 2016 5:05 PM