locked
PerformancePoint 2010 - Filter connections limit to chart reports in a dashboard RRS feed

  • Question

  • Hi,

     

    I am wondering if anyone experienced the issue of limitations when tried to make multiple connections from filters to the analytic chart reports in a dashboard. The error ‘Cannot deploy dashboard because the document library “Dashboards” is unavailable.’ happens during the deployment when connections are too many. 

     

    Here is the detail. I am working on a SPS2010 PerformancePoint deployment task. I was trying to create filter connections to connect the selected filtered values (2 report filers) to 9 small analytic chart reports on the same dashboard; each of the chart will refresh based on the selected filter values. When I tried to deploy this dashboard, with all these webparts NOT connected, I could get the dashboard deployed successfully. When I tried to connect the filters with 1 or 2 charts then deployed, it still succeeded and the connected charts would still take the selected values from filters and reflected the value changes, which is what I wanted. However, if I keep adding more connections to more charts, usually around 3 and definitely for 4 or above, then this error started to appear during the deployment and I would not be able to finish the deployment because of it. Again, the connection threshold seems to be around 3.

     

    I was wondering if anyone has similar experience on this issue before, or any advice for things to check on the configurations. Any suggestions and experience sharing would be much appreciated. Thanks a bunch in advance.

     

    David

    Wednesday, January 19, 2011 6:30 PM

Answers

  • Hi,

    I ran in to the same issue, & got it resolved. I was succesfully able to regenerate the scenario & resolve the issue.

    Scenario

    1. I had deleted one of my filters which was used in the dashboard
    2. When I reopened the Dashboard in the designer it prompted me below

       3. I pressed Ok, & tried to deploy the Dashboard when the below error occured

    Resolution

    My Dashboard has 2 pages, so when I went to the 2nd page below error reappeared. I said Ok, & was able to deploy the package succesfully.

    My Observation

    All Dashboard Pages in which the Objects (filter atleast) have been used need to be refreshed if the ‘Cannot deploy dashboard because the document library “Dashboards” is unavailable.’ error has to be avoided.

     

    Thanks,

    Kalyan

    Sunday, August 28, 2011 11:51 PM

All replies

  • Yes, having the same issue after adding my 12th filter.

    Works fine up to 9... then I added three more and now get the 'Cannont deploy to dashboard...'.

    Sorry, but I have no workaround.

    THis product will be the end of me.

    Monday, June 13, 2011 10:54 PM
  • I ran into this recently.  However, in my case it was an existing dashboard, with probably 75 connections between filters and web parts, and we'd been running the solution in a development environment for a while.

    Then it bombed when we went to deploy it in a new environment.

    Cutting back on the connections, by removing nearly everything from the dashboard, allowed it to deploy.  Once we got up to 6 or 7 connections it started to fail again.  Very odd, and not anything like I'd ever seen with the product.

    After a call to MS support, and getting a product engineer on the line we now know (mostly) what's happening:  There's an issue when you deploy from the server (or any SharePoint server in the farm) to that farm that's related to security checks on the loopback interface.  What, exactly, goes screwy isn't clear to me.  Actually I'm not sure anybody knows what goes wrong, but it has happened in a few instances.

    If you're seeing this error message, and you're rather certain there isn't a security issue, try deploying from a machine that's outside the SharePoint farm entirely.

    Wednesday, July 6, 2011 1:18 AM
  • Hi,

    I ran in to the same issue, & got it resolved. I was succesfully able to regenerate the scenario & resolve the issue.

    Scenario

    1. I had deleted one of my filters which was used in the dashboard
    2. When I reopened the Dashboard in the designer it prompted me below

       3. I pressed Ok, & tried to deploy the Dashboard when the below error occured

    Resolution

    My Dashboard has 2 pages, so when I went to the 2nd page below error reappeared. I said Ok, & was able to deploy the package succesfully.

    My Observation

    All Dashboard Pages in which the Objects (filter atleast) have been used need to be refreshed if the ‘Cannot deploy dashboard because the document library “Dashboards” is unavailable.’ error has to be avoided.

     

    Thanks,

    Kalyan

    Sunday, August 28, 2011 11:51 PM
  • Hi Heidi

    I'm experiencing a similar issue, what is meant by "Refreshed" above. Is this on the web page or in Dashboard designer? Thanks

    Friday, May 4, 2012 7:04 AM
  • Dashboard Designer...
    Thursday, September 20, 2012 8:34 PM
  • Thaks its hellped
    Friday, January 18, 2013 8:31 AM