none
Napa error 400. RRS feed

  • Question

  • Within a Office 365 Developer environment, I open the Napa tool, create a new "Content App for Office" (runs Excel).

    The project is created, and the HTML file is created and opened.  then, at the top, I get "400: Unknown Operation".

    If I try to run it in that state, I get a dialog with "Server Error, Invalid Product ID".

    This is using IE11 from Windows 7.   If I try the same thing with Chrome, it creates the content app, lets me run it, and I don't get an error until Excel starts up with the little embedded content window, when I get an "unsupported browser".

    thanks.

    Tuesday, June 3, 2014 8:08 PM

Answers

  • hi,

    I am trying to reproduce the issue but failed. My test environment is Windows 8 and IE 11. I suspect this issue is relate to the IE environment, I suggest you trying it in a clean computer to see whether this issue is fixed. Or you can try to restore the IE settings and disable the third part add-ons like figure below:

    If it is not help, please try to repair or reinstall the IE to see whether this issue is fixed.

    Best regards

    Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, June 5, 2014 5:39 AM
    Moderator

All replies


  • Well, moving to another Windows 7 system with IE11 allowed me to run the content app, so it's something about my system.  I've clicked"Reset all Zones to default" in IE security, that didn't help.

    If anyone has anysuggestions....  
    Wednesday, June 4, 2014 2:43 PM
  • hi,

    I am trying to reproduce the issue but failed. My test environment is Windows 8 and IE 11. I suspect this issue is relate to the IE environment, I suggest you trying it in a clean computer to see whether this issue is fixed. Or you can try to restore the IE settings and disable the third part add-ons like figure below:

    If it is not help, please try to repair or reinstall the IE to see whether this issue is fixed.

    Best regards

    Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, June 5, 2014 5:39 AM
    Moderator
  • Thanks. I did try another Windows 7 / IE11 system here and everything worked...so I went back to the system with problems and did a Reset on the Advanced Tab of IE options.  After a Reboot, everything worked.  I'm wishing now I had saved a log of my IE settings, but I forgot to do that.

    I still have a problem with Exchange in "provisioning..." state after multiple days.  Not sure what to do about that. (Outlook, Calendar and People buttons on top bar all greyed out).

    Thursday, June 5, 2014 7:41 PM
  • >>I still have a problem with Exchange in "provisioning..." state after multiple days.<<

    I am not sure what's mean of "a problem with Exchange in 'porvisioning...'state", did you mean you have some issues about Exchange? If I understand correctly, I suggest you reopen a new thread in Exchange forum to get more effective response.

    >>  Not sure what to do about that. (Outlook, Calendar and People buttons on top bar all greyed out).<<

    If you have issues about Outlook settings and usage, you also can consider post it to Outlook Technet forum.

    This forum is for developers disscussing the issues about apps for Office. The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who read the forums regularly can either share their knowledge or learn from your interaction with us.

    Thanks for your understanding.

    Best regards

    Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, June 6, 2014 2:07 AM
    Moderator