none
Visual Studio 2017 User Control problem RRS feed

  • Question

  • Hello everyone.

    C++/ Visual Studio 2017

    Have some problems with User Controls.

    I have create it, can see on toolbox, but can't put it on my Form.

    Actually, I can put it in with some code

    private: UC_main_window^ ob;
    
    this->ob = (gcnew UC_main_window());
    this->panel1->Controls->Add(this->ob);
    

    it works, I can see my User Control when start .exe, but this crash MY Form Design preview.

    If I try drag and drop method without this code Visual studio just give me error.

    Failed to load toolbox item 'UC_main_window'. It will be removed from the toolbox.

    Any ideas how to fix it?

    Am seeing some answers about same problem. But there talk about x64 and x32 build version. Already have x32, I haven't do some changes on it.

    Sunday, September 1, 2019 2:33 AM

All replies

  • Hi Dzeky,

    I have reproduced the problem you described, and this is indeed an urgent problem. Maybe you can report a problem on Developer Community. There will be professional people to deal with this problem.

    Thank you for your understanding.

    Regards,

    Kyle


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, September 2, 2019 9:06 AM
    Moderator