none
A RANT

    Question

  • I would really like to thank the MS team that created VS 2015.  Beyond the fact that the editor is so broken and intellisense is no longer intelligent it has now destroyed my project.  I still have the source but really not looking forward to the busy work of trying to reconstitute the project.

    I was thinking of uninstalling VS 2015 but now I will.  What a mess!!!!!!!!!


    Lloyd Sheen

    Sunday, November 15, 2015 11:00 PM

Answers

  • The solution was created in VS 2013 then used in VS 2015, one project was added using VS 2015.  

    I reset the Settings as shown but I think the problem is more with VS 2015.  For example I create a new value for an Enum.  I cannot get the value to show in Intellisence until I have compiled and run the solution and put the value in manually.  After that the value will show.

    I recreated the solution and added all the files.  Now the solution compiles and runs.

    I don't have another VS 2015 environment to use to measure against.

    Thanks


    Lloyd Sheen

    Monday, November 16, 2015 4:38 PM

All replies

  • Beyond the fact that the editor is so broken and intellisense is no longer intelligent it has now destroyed my project. 

    Hi,

    how did it destroy it? I once had the issue that - assumingly - the project files *.CS/VBproj were broken, so it gave me a lot of "not found" etc errors. I had a backup, so it was easy to recover. So my advice is to create a backup before working with VS2015 and backup the current state whenever a change in code will be a persistent change... IMHO they really should publish an Update for the major issues soon.

    Regards,

      Thorsten

    Monday, November 16, 2015 7:07 AM
  • Hi sqlguy,

    Thanks for your feedback, and really sorry for that if the VS IDE impacts your project files or others.

    >>Beyond the fact that the editor is so broken and intellisense is no longer intelligent it has now destroyed my project.

    So one issue is that the intellisense not work in your VS, but for project issue is that whether this project was created by the VS2015 if it was impacted by the VS2015. 

    (1)For the intellsense issue, just to make this issue clearly, Whether all projects have the same issue?

    For the specific language developing like VC# app, we could check the setting under TOOLS->Options->Text Editor->the specific language(C#) ->IntelliSense.

    I have met this kind of issue like the IntelliSense doesn’t work, but it works well after we reset my VS settings.

    TOOLS->Import and Export Settings Wizard->Reset all settings->select “No, just reset settings, overwriting my current settings”->Choose a Default Collection of settings. Check it again. Hope it could help.

    (2)But to really make sure that whether the VS destroyed the project, like my previous issue, we have to know that whether it is the VS2015 project, whether you get any compiled error or warning?

    A. For example, if it was developed in old VS version, but you upgrade it to VS2015, before we really update it, we would think about the VS2015's compatibility or others.

    B. To make sure that whether it is related to the project files, one idea is that you could delete the .suo file, and then re-open the .xxproj file, clean and rebuild your solution, run it again.

    C. Or you could create a blank solution, and then add all project files to the new blank solution, we often use this workaround if the project files were corrapted corrupted. Of course, you could take a backup before you really test it using the above steps.

    D. Of course, to really make sure that whether it is related to your VS2015, you could run it in other VS2015 Environment, if it worked well in other VS2015 machine, maybe we would think about the VS installation.

    If you get any latest information, please feel free to let me know.

    Sincerely,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, November 16, 2015 7:26 AM
    Moderator
  • The solution was created in VS 2013 then used in VS 2015, one project was added using VS 2015.  

    I reset the Settings as shown but I think the problem is more with VS 2015.  For example I create a new value for an Enum.  I cannot get the value to show in Intellisence until I have compiled and run the solution and put the value in manually.  After that the value will show.

    I recreated the solution and added all the files.  Now the solution compiles and runs.

    I don't have another VS 2015 environment to use to measure against.

    Thanks


    Lloyd Sheen

    Monday, November 16, 2015 4:38 PM
  • Forgot one big problem. 

    Intellisence no longer shows the parameters when you click in a call after the first attempt to code the call, VS 2013 does it quite nicely.  

    All in all this version of VS is not very good.


    Lloyd Sheen

    Monday, November 16, 2015 5:34 PM
  • Hi sqlguy,

    Thanks for your friendly response.

    >>I recreated the solution and added all the files.  Now the solution compiles and runs.

    Glad to know that it works well now. If so, maybe you are right, the project files meet certain issues when the VS2015 upgrades the old project files automatically. But it is a good information that the new solution works well. We often use this workaround if the project files are corrupted.

    >>Intellisence no longer shows the parameters when you click in a call after the first attempt to code the call, VS 2013 does it quite nicely. All in all this version of VS is not very good.

    For this issue, if you have good suggestions or feedbacks, if possible, you can submit them to Microsoft Connect feedback portal: http://connect.microsoft.com/VisualStudio/feedback/CreateFeedback.aspx,Microsoft engineers will evaluate them seriously. You could share the link here after you submit it, so other members who get the same issue as yours would help you vote your report.

    Sincerely,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, November 17, 2015 8:18 AM
    Moderator
  • I have tried on Connect several times to get problems fixed but it never worked.

    The Go To Definition is so broken I can only assume that those who decided to break it never use the product and have little knowledge of why the object browser is useful.  I cannot see myself using this terrible iteration of a formerly good product.


    Lloyd Sheen

    Tuesday, November 17, 2015 10:07 PM
  • Hi Lloyd Sheen,

    Thanks for your friendly response.

    One idea is that you could share me a simple sample using one dirve, I will set up the same Environment as yours, so I could really repro this issue in my side, if I could repro this issue, I will help you submit a report.

    Since we have resolved the project files issue in our previous disucssions, for the new issue, would you mind opening a new case in our forum? You know that one thread for one issue, it would be better if you open up a new thread for the new questions. In this way, our discussion here will not deviate too much from the original issue. This will make answer searching in the forum easier and be beneficial to other community members as well.

    If you open a new case in our forum, I will follow up your new issue as soon as possible. Of course, as my above suggestions, to really repro and troubleshoot this issue, it would be better if you could share us a sample and detailed steps in your new thread.

    If I could really repro this issue, I will help you submit the connect report or involve the senior members to analyze this issue. The product teams appreciate all community members' feedbacks or feature requests for the VS products.

    If there's any concern, please feel free to let me know.

    Sincerely,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, November 18, 2015 9:11 AM
    Moderator
  • I am getting rid of VS 2015.  It has so many problems I don't have time to enumerate them all.  VS 2015 is a disaster.  The latest is that debug.print does not send output anywhere I can find.  The whole idea of an IDE is to help development.  VS 2015 does not do that.

    Sorry but I have things to do not debug a terrible IDE!


    Lloyd Sheen

    Wednesday, November 18, 2015 6:50 PM
  • On the fourth hour of the uninstall.  I could say it is ridiculous but I am sure all MS people who work with VS know this.  Hasn't moved the status in two hours but Task Manager says it is active.

    Maybe VS 2200 will work.


    Lloyd Sheen

    Wednesday, November 18, 2015 8:12 PM
  • Hi Lloyd Sheen,

    Thanks for your feedbacks.

    Really want to help you troubleshoot certain questions or help you submit feedbacks to the product team experts, but if you will not use the VS2015, it is hard for us to really repro and troubleshoot this issue. I also have no good solution now.

    But I agree with you, the VS2015 really is the new product, I'm sure that I also meet some feedbacks of it, and I could repro it, so I often submit them to the product teams, the product team will resolve them one by one or using the next update package or others.

    The latest update package is the Update 1 RC, if possible, you could install it if you want to use the VS2015 in the furture.

    Of course, I think the old VS like the VS2010 or VS2013 also have good functions, maybe you could think about using the old VS version if you don't want to use the VS2015.

    I know that the VS2015 really impacts your delopment or usage, really sorry about it, but if possible, I sincerely suggest you submit this feedback to Microsoft Connect feedback portal: http://connect.microsoft.com/VisualStudio/feedback/CreateFeedback.aspx, Microsoft engineers will evaluate them seriously and update using Email. If this issue is urgent, please contact support at http://support.microsoft.com. That's the way I could get to contact to the procut team now.

    Sincerely,

    Jack Zhai


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, November 19, 2015 8:30 AM
    Moderator
  • I am back to using VS 2013.  It works!!

    VS 2015 is a new product is in no way a valid excuse for such a poor product.  Even if the bugs are fixed the non use of Object Browser in response to Go To Definition is a game breaker.


    Lloyd Sheen

    Thursday, November 19, 2015 6:12 PM
  • Hi Lloyd Sheen,

    Thanks for your friendly response.

    >>VS 2015 is a new product is in no way a valid excuse for such a poor product.  Even if the bugs are fixed the non use of Object Browser in response to Go To Definition is a game breaker.

    It seems that it really has this limitation now:

    http://stackoverflow.com/questions/32559263/vs2015-goto-definition-shows-metadata-instead-of-object-browser

    Thanks for your feedback, I will repro this issue later, if I get the same issue, I will submit this feedback.

    >>I recreated the solution and added all the files.  Now the solution compiles and runs.

    In addition, as our previous disucssion, we have resolved the solution issue, and you will use the VS2013 now, I will close this case, and mark your reply as the answer.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, November 20, 2015 7:14 AM
    Moderator