none
Global Navigation - Target Audience Issue RRS feed

  • Question

  • We are experiencing an issue with SharePoint 2010. We have imported Active Directory users and groups, but are unable to select them as a target audience in the navigation section of the website. We get the following error(below)

    "There were problems searching audiences, please contact the system administrator"

    ULS Logs show:

    Category: User Profiles

    AudienceQueryControl:IssueQuery(): Unknown Exception: System.NullReferenceException: Object reference not set to an instance of an object. at Microsoft.Office.Server.WebControls.AudienceEditor.SearchAudienceAndDL(UserProfileApplicationProxy userProfileApplicationProxy, String searchText, AudienceType types, Int32 pageIndex, Int32 pageSize, SortedList sortedResult, Int32& total) at Microsoft.Office.Server.WebControls.AudienceQueryControl.IssueQuery(String searchString, String groupName, Int32 pageIndex, Int32 pageSize)

    Any help would be greatly appreciated! We tried setting up the Search Service Application, but that didn't seem to do the trick either.

    Tuesday, December 7, 2010 2:45 PM

Answers

  • Hi ddrake87.

     

    I solved configuring two SharePoint Services:

    - Managed Metadata Service

    - User Profile Service Application

     

    After install them the problem was solved.

     

    I hope this help you.  

     

    • Marked as answer by ddrake87 Monday, September 26, 2011 2:18 PM
    Friday, September 23, 2011 8:08 AM

All replies

  • bump, any suggestions?

    We have done the following:

    1. Turned on SharePoint Search Service

    2. Imported all AD users and groups

    We can't see any Audiences we set up or the AD User groups in the web part audience picker.

    Thanks much,

    Don

     

     

    Tuesday, December 7, 2010 5:55 PM
  • Don,

    Did you ever resolve this?  I am encountering the same issue.

     

    Thanks.

     

    Tony

    Wednesday, July 13, 2011 4:58 PM
  • Hi ddrake87.

     

    I solved configuring two SharePoint Services:

    - Managed Metadata Service

    - User Profile Service Application

     

    After install them the problem was solved.

     

    I hope this help you.  

     

    • Marked as answer by ddrake87 Monday, September 26, 2011 2:18 PM
    Friday, September 23, 2011 8:08 AM