locked
BizTalk 2013 R2 TLS 1.2 support RRS feed

  • Question

  • Hi Team,

    We need to use TLS1.2 for one of the client.We are using BizTalk 2013 R2 with CU8 update installed on.Some body please tell me how to setup TLS1.2 for particular adapter not for all environment.We don't want to change registry setting for that.Do we need to write custom behavior?
    Any suggestion?



    • Edited by R.B06 Friday, November 30, 2018 10:49 AM
    Friday, November 30, 2018 9:15 AM

Answers

  •  setup TLS1.2 for particular adapter not for all environment

    Well...that's not how it works.

    TLS 1.2 comes with .Net 4.5 making it available to all apps.  But you do have to make so registry changes to enable this in Windows.

    Don't worry about specific Adapters.  TLS will negotiate whatever version is supported by the endpoint automatically, so if an endpoint support only 1.1, that's what it will use. 

    • Marked as answer by R.B06 Tuesday, December 18, 2018 10:53 AM
    Friday, November 30, 2018 1:41 PM
    Moderator

All replies

  • Hi,

    TLS1.2 is applied at .NET Framework level(v4.5x) and hence applied for all Adapters and Accelarators. Without changing the Registry(Refer Link#1) there is also an option to implement TLS1.2 using the Custom Behaviour 

    Link#1 https://social.technet.microsoft.com/wiki/contents/articles/51476.biztalk-configure-tls-1-2-on-biztalk-server.aspx

    HTH


    Hope this Helps!!!! Regards, Note: Please Mark As Answered if you satisfy with Reply.


    Friday, November 30, 2018 11:04 AM
  •  setup TLS1.2 for particular adapter not for all environment

    Well...that's not how it works.

    TLS 1.2 comes with .Net 4.5 making it available to all apps.  But you do have to make so registry changes to enable this in Windows.

    Don't worry about specific Adapters.  TLS will negotiate whatever version is supported by the endpoint automatically, so if an endpoint support only 1.1, that's what it will use. 

    • Marked as answer by R.B06 Tuesday, December 18, 2018 10:53 AM
    Friday, November 30, 2018 1:41 PM
    Moderator
  • Thanks Johns for your response.No need to change anythings.
    I have just verified from registry that TLS1.2 enabled or not , for us it was enabled. 
    Tuesday, December 18, 2018 10:55 AM